Flashing(updating) 5930G bios

Discussion in 'Acer' started by Engin Demir, Mar 28, 2018.

  1. Engin Demir

    Engin Demir Newbie

    Reputations:
    0
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    5
    Greetings all,

    Short version: I want to update/flash bios for my Acer Aspire 5930G laptop from 1.20 to v1.23. How do I do that?

    Long version: Last week I bought a 2GB RAM and upgraded my laptop to 4GB RAM total. However, I quickly realized that my systems actually see 4GB RAM but can only use 2.99 of it. After eliminating other scenarios like using 64bit OS, bad memory etc etc, I understood that I have to upgrade my bios to version 1.23 which enables 4GB RAM.

    I am using Linux Mint 18.3 alongside Win 7 dual-boot on this machine.

    I downloaded bios v1.23 for my laptop. Unlike other ACER bios models, 5930 only had exe files for 32 and 64 bits. I searched for a dos version first but failed so I booted my windows 7 64 bit and ran EGR-123.exe in the x64 folder. But I get:

    EGR-123
    ---------------------------
    Driver(WDM) Init fail!(0x137)
    ---------------------------

    I understood that lot's of people had the same error message on 64bit operating systems but I never actually found a solution. I tried to search for a dos version and came up with an exe file called phlash16.exe. I found a egr-123.rom file for 5930G online but then I get the "Phoenix Phash16 Error - File open failed on bios.rom"

    I made a windowsPE bootable USB-drive and copied the exe bios files there. But it does not run at all.

    trying to run egr-123.exe when I boot from win98 says "this program cannot be run in dos mode".

    I came up with some topics saying they ran a bios.bat file to flash their 5930G laptop but my download does not have that nor I could come up with such file online.

    So I have a few possible questions:

    1. How can I use the bios I downloaded from ACER support page
    2. Is there a way to find a dos version of that bios.
    3. I used a program called "Universal BIOS Backup ToolKit 2.0" and backed up my bios. It saved it as "PhoenixTechnologiesLTD-V1.20.rom". IF something goes wrong, how can I use that backup in the future?
    4. How can I use a xxxx.rom file to flash my bios?

    I have spent 6 days, over 40 hours searching for a solution. Any help would be appreciated.

    NOTE: Flashing my bios is my only option to be able to use my 4GB RAM. Rams are both flawless, tested by memtest individually.
     
  2. darnok44

    darnok44 Notebook Consultant

    Reputations:
    170
    Messages:
    260
    Likes Received:
    63
    Trophy Points:
    41

Share This Page