Fixing an Alienware 18 with seemingly faulty GPU's

Discussion in 'Alienware 18 and M18x' started by ColaMonster, May 7, 2018.

  1. Rengsey R. H. Jr.

    Rengsey R. H. Jr. I Never Slept

    Reputations:
    905
    Messages:
    2,152
    Likes Received:
    494
    Trophy Points:
    101
    Yes it's the dell r9 m290x from alienware 18. I'll look for it when I'm home and free.
     
  2. skindoe

    skindoe Notebook Geek

    Reputations:
    10
    Messages:
    79
    Likes Received:
    13
    Trophy Points:
    16
    I've sent you a PM with the stock m290x bios attached.
     
    ColaMonster likes this.
  3. ColaMonster

    ColaMonster Notebook Consultant

    Reputations:
    12
    Messages:
    155
    Likes Received:
    30
    Trophy Points:
    41
    Thanks a tonne! Ill let you know how it turns out :)
     
  4. ColaMonster

    ColaMonster Notebook Consultant

    Reputations:
    12
    Messages:
    155
    Likes Received:
    30
    Trophy Points:
    41
    Apologies everyone for never letting you all how it worked out, I got very busy lately, lots going on.

    Unfortunately updating the VBios had no effect, didnt seem to change anything at all, and I noticed in GPUz that it wasnt even registering GPU temps properly, so Im going to assume it was the cards issue.

    I ordered a 1060 , that should be here in a few days, which I will make a new thread for that project :D Hoping its not the motherboard, but Ill know by the end of the week :)
     
    electrosoft likes this.
Loading...

Share This Page