1. You may have noticed things look a little different around here - we've switched to a new platform (XenForo) and have some new forum styles and features. This how-to guide will help you find your way around. If you find anything that looks strange, post it in this thread.

FIX for Win7 i7 sluggish performance

Discussion in 'Windows OS and Software' started by Mr Pras, May 25, 2010.

?

Did this work for you?

  1. Yes, Great!

    54.0%
  2. I had problems getting it working

    4.0%
  3. I didn't see any difference

    37.0%
  4. It worked but I changed it back

    5.0%
  1. Mr Pras

    Mr Pras Notebook Deity

    Messages:
    714
    Likes Received:
    1
    Trophy Points:
    31
    Hi Everyone

    I just found a great fix to stop win7 parking the cores when Idle.

    This is an aggressive power saving approach which makes the system feel sluggish and underpowered..

    I've just tried it and my system really feels snappier, although I haven't tried any benches. Try it for yourself and see!

    from:
    UltimateComputers.net Forum - View topic - Disable Core Parking Windows 7 Tweak may improve performance

    Who is affected
    It only applies to Windows 7 X64 and X32 and only in systems using more than 2 physicial CPU's and/or more than 2 "logical" cores - ie: Core i7's.

    The Problem
    See here for a bit of info / explanation / more info about CPU Core Parking - Windows 7 / Windows Server 2008 R2: Core Parking / Intelligent Timer Tick / Timer Coalescing - Ask the Performance Team - Home - TechNet Blogs

    Core Parking is a feature of Windows 7 that is causing rare performance problems. I don't notice it on my home i7 / Win7 system but some people are getting microstutters and odd behavior in certain programs. Without the following " tweak" you may see CPU spiking in your programs and Windows Task Manager - some CPU cores will be "turned off" / "parked" depending on load and they will be dynamically turned on or off and dynamically loaded up or down as the system deems necessary - the scope for glitchs / pops / clicks / droputs etc.... in such an environment is simply enormous. To the best of my knowledge, there is no known "switch" to turn it off - no utility I am aware of to "tweak" it off.

    The Fix
    - Go to Regedit
    - Select Edit > Find... and find this key: " 0cc5b647-c1df-4637-891a-dec35c318583 "
    UPDATE: Try searching instead for "Specify the minimum number of unparked cores/packages allowed (in percentage)." (WITHOUT QUOTES)
    - Within this key, there is a value called: " ValueMax " This value represents the % number of cores the system will park
    - Change the value of " ValueMax" to 0 so that, it matches " ValueMin "
    - You will have to find the key a few times and repeat the process for each time it is found - the number of instances will depend on the number of power profiles in your system. To do this go back up to Edit > Find Next. (I had 3 instances of this key in my registry.)
    - Do a full shutdown and power-off and cold-re-start.

    This seems to work better.[/COLOR]
     
  2. Achilleus

    Achilleus Notebook Evangelist

    Messages:
    336
    Likes Received:
    0
    Trophy Points:
    30
    Is this going to keep turbo boost from kicking in?
     
  3. Mr Pras

    Mr Pras Notebook Deity

    Messages:
    714
    Likes Received:
    1
    Trophy Points:
    31
    No, it's only stopping win7 from parking the idle cores (which makes them sluggish to respond).

    It is making the benches run slightly higher. The mouse pointer actually moves at full frame rate too. Before it would sluggishly refresh every few frames, now it actually seems to be acting like a high performance machine.. Woohoo!
     
  4. madpenguin92

    madpenguin92 Notebook Geek

    Messages:
    94
    Likes Received:
    0
    Trophy Points:
    15
    the fix stops the touchpad from lagging?!?!
     
  5. granyte

    granyte ATI+AMD -> DAAMIT

    Messages:
    2,346
    Likes Received:
    0
    Trophy Points:
    55
    intel seem to have a lot of trouble with thier throteling tubo boost and etc feature since the core architecture -.-

    lucky for us most of the time only disabeling thoses feature solve the problem
     
  6. Mr Pras

    Mr Pras Notebook Deity

    Messages:
    714
    Likes Received:
    1
    Trophy Points:
    31

    Er, it might but I doubt it..

    It's to do with CPU core-parking guys.. It stops the machine being sluggish because of the way it shifts around threads and also parks cores.. Now, it doesn't park cores so the switching threads activity doesn't slow the machine down. Something like that.
     
  7. hitokiri1

    hitokiri1 Notebook Evangelist

    Messages:
    637
    Likes Received:
    0
    Trophy Points:
    30
    Anyone else want to test this out?
     
  8. Mr Pras

    Mr Pras Notebook Deity

    Messages:
    714
    Likes Received:
    1
    Trophy Points:
    31
    This has fixed it for me, now getting proper performance and responsiveness with EIST and Turbo still enabled.. Definitely an improvement!
     
  9. madpenguin92

    madpenguin92 Notebook Geek

    Messages:
    94
    Likes Received:
    0
    Trophy Points:
    15
    i read that as a fix for the touchpad...my bad
     
  10. Mr Pras

    Mr Pras Notebook Deity

    Messages:
    714
    Likes Received:
    1
    Trophy Points:
    31
    You can always change it back by setting the valuemax back to 100

    It might work, I don't know. Let us know if it does! I had uninstalled the synaptics driver and rarely use the TP anyway..
     
  11. inap

    inap .........................

    Messages:
    7,827
    Likes Received:
    18
    Trophy Points:
    206
    did it , thanks pras. touchpad does feel a little better but not sure cause i don't really use it that often, hahhah
     
  12. Mr Pras

    Mr Pras Notebook Deity

    Messages:
    714
    Likes Received:
    1
    Trophy Points:
    31
    aaaaaaay!! nice one, i find the whole system is more responsive, noticeable initially via the mouse pointer itself, but also getting slightly higher performance
     
  13. whitelight01

    whitelight01 Notebook Geek

    Messages:
    89
    Likes Received:
    0
    Trophy Points:
    15
    Awesome find....I'm ready to get home & test this out.
     
  14. varun nahar

    varun nahar Notebook Enthusiast

    Messages:
    19
    Likes Received:
    0
    Trophy Points:
    5
    same here...cant wait to test it....awesome tweak...
     
  15. Docsteel

    Docsteel Vast Alien Conspiracy

    Messages:
    1,555
    Likes Received:
    198
    Trophy Points:
    81
    Good find man, +1 rep!
     
  16. danp224

    danp224 Notebook Evangelist

    Messages:
    341
    Likes Received:
    0
    Trophy Points:
    30
    Nice Tip.

    Performance seems about the same for me.

    +1 for the info.
     
  17. lastcoyote

    lastcoyote Notebook Guru

    Messages:
    52
    Likes Received:
    0
    Trophy Points:
    15
    nice one.
    i found 3 places in the registry that needed changing too. though the third one which was the 'currentcontrolset' had already a 0 value. also my original value was 64...though it shows 100 in brackets.
     
  18. Mr Pras

    Mr Pras Notebook Deity

    Messages:
    714
    Likes Received:
    1
    Trophy Points:
    31
    Yes, I had the same experience..

    64 is 100 in Hexadecimal (Base 16 - google it if you are interested)
     
  19. lastcoyote

    lastcoyote Notebook Guru

    Messages:
    52
    Likes Received:
    0
    Trophy Points:
    15
    oh ok that makes sense. thanks for clearing that up.
     
  20. tuenkamen

    tuenkamen Notebook Deity

    Messages:
    1,181
    Likes Received:
    0
    Trophy Points:
    55
    Thank you Mr. Pras has made this thing snappy awesome find will rep when allowed.

    checked cpuid and the max Ghz is 3.192 and its rated to go up to 3.3 hmmmmmm
     

Share This Page