[FIX] Audio quality & crackling for Music only

Discussion in 'Alienware M15x' started by Hobgoblinpie, Jun 27, 2010.

Thread Status:
Not open for further replies.
  1. Hobgoblinpie

    Hobgoblinpie Notebook Evangelist

    Reputations:
    115
    Messages:
    369
    Likes Received:
    3
    Trophy Points:
    31
    Attention Headphone Users:
    If you intend to use these fixes, you have to set XMPlay's volume to 25. You will get terrible audio if you do not do this.



    Before you read on, you need to be aware of two things:

    1. This is not going to improve the sound of every application, game and video. It will only work for music.
    2. When using the exclusive mode of XMPlay, no other application will be allowed to output sound. In this case, you need to exit XMPlay and restart the application you were attempting to load up. With internet browsers such as Opera and Firefox, make sure that they will save tabs upon exiting, or this will give you a headache.



    1. Download XMPlay or Foobar (I personally prefer XMPlayer for the sound output, but either one is fine) from here:

    http://uk.un4seen.com/files/xmplay35.zip <- XMPlay
    Download foobar2000 and optional components <- Foobar

    XMPlay is in Zip format so will need to be extracted. All of the files in the archive need to go into the same folder (folder can be anywhere). Foobar is installed through an installer, so just leave all the settings as default.

    2. Download the appropriate WASAPI plug-in:

    XMPlay: http://us2.un4seen.com/files/xmp-wasapi.zip or http://uk.un4seen.com/files/xmp-wasapi.zip
    Foobar: foobar2000: Components Repository - WASAPI output support

    The XMPlay WASAPI plugin needs to go into the same folder as XMPlay.exe. The Foobar plugin, assuming it was installed to the default location, will be: C:program Files (x86)foobar2000components.

    3. In XMPlay, Open up the settings by clicking on the spanner icon in the main window. Then, click on the 'Output' tab in the menu on the left, and change the device to 'WASAPI - Speakers/Headphones (IDT High Definition Audio Codec)', like so:

    [​IMG]

    Then, in the selection that came from Output, click on the WASAPI tab on the left side, and enable 'Exclusive mode'. And remember to apply the changes:

    [​IMG]


    In Foobar, go to File -> Preferences -> Playback -> Output -> Output Device

    Then, in the drop down box select: WASAPI: Speakers/Headphones (IDT High definition Audio CODEC), like so:

    [​IMG]

    Remember to apply the changes.

    4. If your M15x is plugged into a power source, Turn on Alien FX. If your M15x is not, you can have it on or off (just trust me on this one).


    After these steps, the audio should sound much better. However, Foobar does not have an exclusive mode, which limits the sound quality gain.

    The reason that exclusive mode works is because it feeds audio straight to the Soundcard, not allowing signal processing or any software to interfere with the audio stream. Thus, what you get output is a bit-perfect unmixed audio stream.

    For reference: I'm using Nvidia 257.15 Graphics drivers and the M17x IDT audio drivers found here: http://forum.notebookreview.com/alienware-m15x/494095-updated-audio-driver-6261-a03-m17xr2.html

    P.S. If you want to hear the quality difference, if you have XMPlay (not sure if it works for Foobar, as I don't use it as much) you can select the default output, apply that, then switch to the WASAPI output, and apply that. You should hear a lot of difference in heavier parts (such as when guitars are played alongside drums). If you listen to mostly classical music, it is not going to make much difference.

    Also, I'm a semi-audiophile, so the results may not please you as much as they did me, or they may not please you at all. Getting perfect output gives me the ability to fine-tune my entire system to my requirements, so you might find it flat or annoying, in which case, just change the output source, and voila, all is normal.
     
    Last edited by a moderator: May 8, 2015
  2. Anyatan

    Anyatan Notebook Geek

    Reputations:
    3
    Messages:
    91
    Likes Received:
    0
    Trophy Points:
    15
    Im at work!

    Has anybody verified or tried this? Cant w8 to get home and try this out.
     
  3. tuenkamen

    tuenkamen Notebook Deity

    Reputations:
    149
    Messages:
    1,181
    Likes Received:
    0
    Trophy Points:
    55
    Yes i have and it works awesome.
     
  4. Anyatan

    Anyatan Notebook Geek

    Reputations:
    3
    Messages:
    91
    Likes Received:
    0
    Trophy Points:
    15
    wooo. Thanks tuenkamen. Will do this first thing when i get home.
    Anybody else tried this???
     
  5. tuenkamen

    tuenkamen Notebook Deity

    Reputations:
    149
    Messages:
    1,181
    Likes Received:
    0
    Trophy Points:
    55
    just fyi you can't run multiple audio programs at the same time with this playing in the back ground unless you disable the exclusive mode in the XMplayer so can play a game and listen to your music at the same time but it doesn't have the same quality but it doesn't matter when im concentrating on the game. also with the touch panel buttons for shortcuts you will need to edit those to be global and set to the touch panel buttons for them to work when in other windows.

    EDIT: also just reinstalled my favorite nvidia drivers and the sound problems are not there at all awesome fix hobgoblinpie :)
     
  6. EleJota

    EleJota Notebook Guru

    Reputations:
    1
    Messages:
    58
    Likes Received:
    0
    Trophy Points:
    15
    This run on winamp?
     
  7. Hobgoblinpie

    Hobgoblinpie Notebook Evangelist

    Reputations:
    115
    Messages:
    369
    Likes Received:
    3
    Trophy Points:
    31
    Unfortunately not. Whilst you can get WASAPI on Winamp, no-one has made a driver that enables exclusive mode, which is what really improves performance.

    The other option is ASIO, but I have tried all those drivers for Winamp, and none provide any output (to do so would possibly require a resampler) because ASIO only works with a certain setting with any given soundcard.

    You can give Maiko's WASAPI Winamp plugin a try.

    Download from here: file.qip.ru - &#1093;&#1088;&#1072;&#1085;&#1077;&#1085;&#1080;&#1077; &#1080; &#1086;&#1073;&#1084;&#1077;&#1085; &#1092;&#1072;&#1081;&#1083;&#1086;&#1074; &#1086;&#1085;&#1083;&#1072;&#1081;&#1085; - &#1089;&#1082;&#1072;&#1095;&#1072;&#1090;&#110

    (the site is in russian, but to continue to the download, click on the large blue button near the top of the page with the down arrow, then on the next page that loads up, you'll see a timer count down from 2. When the counter has finished, click on that link and the download will start).

    Then, assuming you installed Winamp in the default location, navigate to:
    C:\Program Files (x86)\Winamp\Plugins

    and just extract it to there.

    Then, open up Winamp and go to:
    Options -> Preferences -> Plug-ins -> output

    Then, select out_maiko.dll (do not click configue, Winamp will crash). Then, just select close.

    Hope this helps.
     
  8. EleJota

    EleJota Notebook Guru

    Reputations:
    1
    Messages:
    58
    Likes Received:
    0
    Trophy Points:
    15
    I try in winamp and the sound continue cracking i install asio and test in winamp and same, cracking! :(
    I have install the last IDT M17r2 driver and the last nvidia drivers.
     
  9. tuenkamen

    tuenkamen Notebook Deity

    Reputations:
    149
    Messages:
    1,181
    Likes Received:
    0
    Trophy Points:
    55
    just try the XMplayer it really works
     
  10. Hobgoblinpie

    Hobgoblinpie Notebook Evangelist

    Reputations:
    115
    Messages:
    369
    Likes Received:
    3
    Trophy Points:
    31
    Ele, Try following step 4 with Your current setup.
     
Loading...
Thread Status:
Not open for further replies.

Share This Page