Firepro M6100 into AW 17?

Discussion in 'Hardware Components and Aftermarket Upgrades' started by Grant B Gibson, Jun 25, 2018.

  1. Grant B Gibson

    Grant B Gibson Notebook Evangelist

    Reputations:
    45
    Messages:
    396
    Likes Received:
    138
    Trophy Points:
    56
    I was browsing ebay when I saw this card for $55. Naturally, I couldn't refuse, and so I bought this and the 100w heatsink (it was $21 extra) to help out, and hopefully successfully install it. I will edit this post with various updates as I proceed.

    EDIT #1 It boots perfectly fine, the usual driver issue is there, I'm going to try to download the Precision M6700 drivers and see if that works, I'll update again when ready

    EDIT #2 Yeah drivers are an issue, but other than that, it seems to be working fine

    EDIT #3 The GPU is no longer showing up in windows (Code 45)

    EDIT #4
    Wow after a few restarts, everything is working fine! I'll post some benchmarks, but I doubt it'll be much different than my 765M. I don't know how the drivers managed to install, but it may have been me opening the driver.exe file, restarting the PC, and it installing while the GPU was still "recognized" by the system
     
    Last edited: Jun 25, 2018
    sicily428 likes this.
  2. Grant B Gibson

    Grant B Gibson Notebook Evangelist

    Reputations:
    45
    Messages:
    396
    Likes Received:
    138
    Trophy Points:
    56
    Now I'm going to try and use the MUX (I/D GFX) button to see what happens lol

    EDIT#5 I wonder if I am the first to do this lol

    EDIT#6 No GPU native fan control, and it isn't spinning even with HWinfo64, and the temp is slowly going up. The MUX (I/D GFX) button didn't seem to work, oh well.

    EDIT#7 Everything seems to work fine, but my PSU doesn't seem capable of handling it, odd, considering its "180w". As well the MUX switch works nicely, seems that it not working was a AW software issue. Going to try to flash with improved vBIOS
     
    Last edited: Jul 11, 2018 at 7:00 PM
    sicily428 likes this.
  3. TheReciever

    TheReciever D! For Dragon!

    Reputations:
    238
    Messages:
    1,434
    Likes Received:
    762
    Trophy Points:
    131
    Have you tried running pre-adrenaline drivers on the consumer side?

    I didnt need Firepro drivers when I was using the m5100, it would display as m200x but that wasnt an issue.
     
  4. Grant B Gibson

    Grant B Gibson Notebook Evangelist

    Reputations:
    45
    Messages:
    396
    Likes Received:
    138
    Trophy Points:
    56
    It already recognizes it as a 8950m and auto installed the Firepro Drivers
     
Loading...

Share This Page