Firefox Blocking Sites "Your connection is not secure" when Chrome is working fine.

Discussion in 'Windows OS and Software' started by Tinderbox (UK), Jul 26, 2017.

  1. Tinderbox (UK)

    Tinderbox (UK) Sir Pumpkin Longshanks

    Reputations:
    4,350
    Messages:
    8,322
    Likes Received:
    2,028
    Trophy Points:
    331
    Since this morning i have been getting "Your connection is not secure" blocking many websites though Chrome works fine.

    I re-installed Firefox but i still get the error.

    Is anybody else getting this error?

    John.
     
    hmscott likes this.
  2. aaronne

    aaronne Notebook Evangelist

    Reputations:
    213
    Messages:
    346
    Likes Received:
    334
    Trophy Points:
    76
    Kaspersky AV or Security Suite?

    If yes try to disable secure connection things from kaspersky's settings
     
    Vasudev likes this.
  3. Tinderbox (UK)

    Tinderbox (UK) Sir Pumpkin Longshanks

    Reputations:
    4,350
    Messages:
    8,322
    Likes Received:
    2,028
    Trophy Points:
    331
    I did a full clean install of Windows 10, I was due for a wipe anyway, And everything is working fine now.:)

    I was using Avast, I totally disabled Avast but i still got the site blocking in Firefox.

    Anyway all sorted now fingers crossed.

    John.
     
    hmscott likes this.
  4. Vasudev

    Vasudev Notebook Virtuoso

    Reputations:
    925
    Messages:
    3,679
    Likes Received:
    1,842
    Trophy Points:
    231
    Is HTTPS everywhere extension installed and set to allow only HTTPS connections?
    Did you enable Extreme Privacy setting via Disconnect extension in firefox?
     
  5. StormJumper

    StormJumper Notebook Virtuoso

    Reputations:
    491
    Messages:
    3,022
    Likes Received:
    340
    Trophy Points:
    151
    Since no site or link is provided how would one expect others to know and verify with their version of Browser to confirm this even? Not telling which version doesn't help either - so one can see if it affects their version of Browser.
     
    bennni likes this.
  6. hmscott

    hmscott Notebook Nobel Laureate

    Reputations:
    3,696
    Messages:
    13,761
    Likes Received:
    16,013
    Trophy Points:
    931
    I know you say it's working now, but maybe the secure access checking got disabled :)

    What does "Your connection is not secure" mean?
    https://support.mozilla.org/en-US/kb/what-does-your-connection-is-not-secure-mean

    "When Firefox connects to a secure website (the URL begins with "https://"), it must verify that the certificate presented by the website is valid and that the encryption is strong enough to adequately protect your privacy. If the certificate cannot be validated or if the encryption is not strong enough, Firefox will stop the connection to the website and instead show an error page."

    "To troubleshoot secure connection problems with the error message Secure Connection Failed, see the Troubleshoot the "Secure Connection Failed" error message article."

    IDK which sites you were trying to connect via https, but this one in particular doesn't support https.

    If you try httpseverywhere or another extension, it should just connect via unsecure connection, but you might have had some configuration setting before that got set that wouldn't allow this option.

    When you get time maybe browse through that Firefox debugging info and see what it might have been, for next time :)
     
    Tinderbox (UK) likes this.
Loading...
Similar Threads - Firefox Blocking Sites
  1. Shawn
    Replies:
    14
    Views:
    506
  2. CastlBravo
    Replies:
    1
    Views:
    365

Share This Page