Far Cry 3 Stutter issue: Final thoughts (nvidia only)

Discussion in 'Gaming (Software and Graphics Cards)' started by umkc, Dec 7, 2012.

Thread Status:
Not open for further replies.
  1. umkc

    umkc Notebook Consultant

    Reputations:
    43
    Joined:
    Sep 11, 2012
    Messages:
    139
    Likes Received:
    0
    Trophy Points:
    30
    FINAL THOUGHTS( for Nvidia only)

    I have spent enough time messing with the game settings to get rid of stutter. Based on my experience and researching articles here, on guru3D and ubisoft forums, here are my conclusions:

    PROBLEM: The game stutters if the fps is below 60. the DX version doesn't matter. I have tested with both dx9 and 11. many people on forums report the same.

    CAUSE: unknown..the game has issues with the frame rendering time..maybe

    TESTED FIXES: I have tested almost all the fixes people posted on the internet. here are the results:

    forced adaptive V-Sync: Doesn't remove stutter, but it is a lot better than in-game vsync which has mouse lag. RECOMMENDED
    Triple buffering: it actually makes the game much smoother recommended... doesn't eliminate stutter . RECOMMENDED
    Max-Pre-Buffered frames: I did not find any improvement in performance. UNKNOWN
    MaxFps in Config file: setting it to 30 or 45 did not eliminate stutter. as i said above. anything below 60 stutters. NOT RECOMMENDED
    DX9: Game stutters even fps falls below 60 even in DX9. Same with DX11. NO DIFFERENCE
    Drivers: I have tested with 306.97, 310.54, 310.64, 310.70. none of these eliminate stutter. 310.64 may produce better fps though.
    Patch: i have tested 1.01 and 1.02. both patches will not remove stutter. I feel that 1.02 is even worse than 1.01. your experience may vary.

    MY SETUP (with forced adaptive vsync+ triple-buffering from Nvidia inspector):

    I played on DX9 lowest settings for 2 hours. I run this at low to maintain 60 fps. but fps still drops near towns and in firefights. lowest (48)
    I played DX11 for 1 hour. 2x MSAA, SSAO, enhanced foliage. lowest settings. I still get 60 in most places, but same as DX9 it drops down near towns and in firefights. lowest (44)

    shadows and PostFX are the main power hungry features here...so i put them both to LOW and rest of the settings to HIGH and tested it again in DX9 and 11 for 2 more hours. suprisingly, I still get 60 in many areas. fps drops again in towns and firefights.

    *IMP*: i know there is 4-5 fps difference between DX9 and 11 when the fps drops below 60. The catch is, it doesn't matter.....the game will look like it is running at 20 fps( due to stutter) even when it runs at 1 frame less than 60. So...55 will look 20. 44 will also look like 20.

    TEMP FIX: For people having similar problems, all i can say is: try to run the game so that your fps is always 60. So that you will not suffer from that damn stutter nausea and migraines like me :)


    YOUR DUTY!:

    I have already filed a complaint with Ubisoft. All you people having similar issues..please report the issue to Ubisoft immediately. If enough people complain about this, maybe they will fix their damn game!
    people who doesnt have stutter should also report a complaint just to help us other gamers! :D

    Peace out!



    My Specs:

    i7 3720 QM
    GTX 680M
    16 GB RAM
    512 GB SSD
     
  2. crosslimit

    crosslimit Notebook Evangelist

    Reputations:
    105
    Joined:
    Apr 26, 2012
    Messages:
    601
    Likes Received:
    5
    Trophy Points:
    31
    Hey thanks for your tests. I will try out the adaptive vsnc and triple buffering later. (finally found adaptive vsync lol)

    What you could try are the stock 302.77 drivers. I know they shouldnt really perform better than the specially "optimised +38%" value we are getting from nvidia but they suprisingly work the best for me.
     
  3. MrDJ

    MrDJ Notebook Nobel Laureate

    Reputations:
    2,580
    Joined:
    Mar 23, 2008
    Messages:
    10,699
    Likes Received:
    316
    Trophy Points:
    501
    thanks for doing the tests umkc. + rep to that man :)
     
  4. YodaGoneMad

    YodaGoneMad Notebook Deity

    Reputations:
    555
    Joined:
    Feb 1, 2010
    Messages:
    1,382
    Likes Received:
    12
    Trophy Points:
    56
    I wonder, do you have Optimus?

    It truly should not matter, but that is the only difference I have been able to think of between my machine and yours. I have an M17x R3 so to have the 680m I have Optimus disabled in the bios.

    I guess you could try flashing an unlocked bios and changing your primary display to PEG. You will probably need to install your drivers again and then see if it makes any difference.

    It is really weird that your machine which is extremely similar has issues while mine does not.

     
  5. jaug1337

    jaug1337 de_dust2

    Reputations:
    1,877
    Joined:
    Nov 2, 2011
    Messages:
    4,045
    Likes Received:
    61
    Trophy Points:
    116
    D3DOverrider should fix this.

    Also HERE is 131 pages about this particular problem. Enjoy

    Last but not least, my friend did exactly THIS and it fixed the problem.

    Good luck to all your stutters :p
     
  6. unreal25

    unreal25 Capt. Obvious

    Reputations:
    1,102
    Joined:
    May 29, 2008
    Messages:
    2,373
    Likes Received:
    0
    Trophy Points:
    55
    Thank you, I followed the settings there but also added 1-frame vsync in game and the microstutter is finally gone (it was gone even without vsync but then I got stuttering due to vertical sync). Even though it didn't really bother me that much as I think it was less than what I saw with other people (this is on a desktop GeForce 660 Ti) the game does feel smoother without it. If you switch to 2-frame vsync the microstutter shows back btw.
     
  7. moviemarketing

    moviemarketing Milk Drinker

    Reputations:
    981
    Joined:
    Apr 8, 2010
    Messages:
    3,662
    Likes Received:
    469
    Trophy Points:
    151
    Any of you guys tried using a frame rate limiter like MSI Afterburner to cap the frame rate so it doesn't go above 60?

    This was one workaround to fix the stuttering problem in Skyrim.
     
  8. unreal25

    unreal25 Capt. Obvious

    Reputations:
    1,102
    Joined:
    May 29, 2008
    Messages:
    2,373
    Likes Received:
    0
    Trophy Points:
    55
    The microstutter shows up (as noted in the original post) when the FPS drops below 60. How would limiting the FPS to <= 60 help?
     
  9. moviemarketing

    moviemarketing Milk Drinker

    Reputations:
    981
    Joined:
    Apr 8, 2010
    Messages:
    3,662
    Likes Received:
    469
    Trophy Points:
    151
    Crazy as it sounds, might be worth trying. For some reason this fixed it in Skyrim for many people. Some got a better result capping at 59 fps, someone else found it only stopped if they capped at 42fps.

    More info:

     
Loading...
Thread Status:
Not open for further replies.

Share This Page