E6530 -- possible BIOS recovery options??

Discussion in 'Dell Latitude, Vostro, and Precision' started by M18x-oldie, May 20, 2019.

  1. M18x-oldie

    M18x-oldie Notebook Evangelist

    Reputations:
    14
    Messages:
    310
    Likes Received:
    107
    Trophy Points:
    56
    Hi all,

    bought a defective one last week, problem is: it does not power up completely and shows no screen. Starts up, then turns off again right after 2, 3 seconds. I can hear the fan spinning up.

    I tried: clearing CMOS, holding "Fn", when powering up, the "Ctrl" and "Esc"-key-combo, nothing worked.

    When holding "D" and powering up, it shows plain colors on screen (red, blue and so on). So I assume the screen is alright.

    Tried to recover the BIOS with a USB-Stick, holding "Ctrl" and "Esc" and plugging in the charger. That didn't work. (On the web they called this method the "post-2015-method").

    I smwhere read there is a pre-2015 recovery method, but couldn't find anything about this on the web.

    Is there any links regarding this smwhere on the web I may have overseen?

    Thanks
     
Loading...

Share This Page