1. You may have noticed things look a little different around here - we've switched to a new platform (XenForo) and have some new forum styles and features. This how-to guide will help you find your way around. If you find anything that looks strange, post it in this thread.

Doom 3: BFG Edition Won't Start, Unable to Initialize OpenGL

Discussion in 'Gaming (Software and Graphics Cards)' started by Haloruler64, Oct 17, 2012.

  1. Haloruler64

    Haloruler64 Notebook Enthusiast

    Messages:
    16
    Likes Received:
    0
    Trophy Points:
    5
    Hey guys, I've been Googling for the past two days but I can't figure it out. I bought a retail copy of Doom 3: BFG Edition (which installs to your Steam anyway) and it won't run. I get an error saying "Unable to Initialize OpenGL" followed by this:

    QA Timing INIT: 000072ms
    D3BFG 1.1400 win-x86 Oct 5 2012 11:38:38
    1994 MHz Intel CPU with MMX & SSE & SSE2 & SSE3 & HTT
    4048 MB System Memory
    1535 MB Video Memory
    Winsock Initialized
    Found interface: {F7346918-1A36-4A84-A455-ADE14DB2A297} Intel(R) WiFi Link 1000 BGN - 192.168.1.73/255.255.255.0
    Found interface: {D52A54B1-4039-4DEA-AF75-2134680F17E2} Qualcomm Atheros AR8151 PCI-E Gigabit Ethernet Controller (NDIS 6.30) - 0.0.0.0 NULL netmask - skipped
    Sys_InitNetworking: adding loopback interface
    doom using MMX & SSE for SIMD processing
    enabled Flush-To-Zero mode
    enabled Denormals-Are-Zero mode
    ------ Initializing File System ------
    Loaded resource file _common.resources
    Loaded resource file _ordered.resources
    Loaded resource file _sound_pc.resources
    Loaded resource file _sound_pc_en.resources
    Current search path:
    C:\Program Files (x86)\Steam\steamapps\common\DOOM 3 BFG Edition/base
    C:\Users\Dima\Saved Games\id Software\DOOM 3 BFG/base
    file system initialized.
    --------------------------------------
    WARNING: Unable to open resource file maps/_startup.resources
    ----- Initializing Decls -----
    ------------------------------
    Couldn't open journal files
    execing default.cfg
    couldn't exec D3BFGConfig.cfg
    couldn't exec autoexec.cfg
    ----- R_InitOpenGL -----
    Initializing OpenGL subsystem with multisamples:0 stereo:0 fullscreen:1
    ...registered window class
    ...registered fake window class
    ...initializing QGL
    ...calling LoadLibrary( 'opengl32' ): succeeded
    ...using WGL_EXT_swap_control_tear
    Shutting down OpenGL subsystem
    ...wglMakeCurrent( NULL, NULL ): failed
    ...shutting down QGL
    ...unloading OpenGL DLL
    Initializing OpenGL subsystem with multisamples:0 stereo:0 fullscreen:1
    ...initializing QGL
    ...calling LoadLibrary( 'opengl32' ): succeeded
    ...using WGL_EXT_swap_control_tear
    Shutting down OpenGL subsystem
    ...wglMakeCurrent( NULL, NULL ): failed
    ...shutting down QGL
    ...unloading OpenGL DLL
    Unknown command 'vid_restart'
    Unable to initialize OpenGL
    Shutting down OpenGL subsystem
    ...shutting down QGL

    No matter what I do, it errors out. Not admin mode, not compatibility mode... Here are my specs:

    Alienware M14x
    Intel Core i7 2630QM
    1.5GB NVIDIA GT555M
    4GB DDR3 1600 MHz
    500GB 72000 RPM HDD
    1600x900 display
    Windows 8 RTM 64 bit

    I reinstalled the game, redownloaded the entire thing just in case. I installed the latest NVIDIA drivers, which were released on 10/10 and updated for the BFG edition. I also installed the latest Intel drivers from Windows Update. My NVIDIA Control Panel is set to select the high performance card to run the game. Any ideas what I can do?

    EDIT 10/19/12: I have found a solution! Someone on Steam forums posted part of it!

    1. Navigate to C:\Users\*your username*\Saved Games\id Software\DOOM 3 BFG\base and find file "D3BFGConfig.cfg"
    2. Open file with Notepad (I use Notepad++, great program) and edit line r_fullscreen "1" and set it to "3".
    3. Go into game and set Monitor 3 resolution to your res.

    It works for me, hope it helps!
     
  2. corona4497

    corona4497 Notebook Enthusiast

    Messages:
    21
    Likes Received:
    0
    Trophy Points:
    5
    i was thinking into buying an m18x, will this problem happen on it?
     
  3. Haloruler64

    Haloruler64 Notebook Enthusiast

    Messages:
    16
    Likes Received:
    0
    Trophy Points:
    5
    I really wouldn't know. This issue is rampant for all kinds of hardware, if you look at Steam forums. I still suggest Alienware laptops, they're amazing. This is definitely not an Alienware issue.
     
  4. failwheeldrive

    failwheeldrive Notebook Deity

    Messages:
    1,873
    Likes Received:
    9
    Trophy Points:
    56
    Yes, it will happen on the the m18x; don't buy Alienware, buy Sager, we NEVER have problems with our laptops... *cough* *cough* Enduro *cough*

    lol jk, don't worry about it, it's probably not an issue that will affect all m18x's.
     
  5. traxtext90

    traxtext90 Notebook Enthusiast

    Messages:
    31
    Likes Received:
    0
    Trophy Points:
    15
    is this game really worth if if u have played the xbox version one?
     
  6. failwheeldrive

    failwheeldrive Notebook Deity

    Messages:
    1,873
    Likes Received:
    9
    Trophy Points:
    56
    not for 30 bucks. I don't understand the difference between this version and the original pc version. They're both HD, so why make a new HD version for pc also?
     
  7. Haloruler64

    Haloruler64 Notebook Enthusiast

    Messages:
    16
    Likes Received:
    0
    Trophy Points:
    5
    It was to me, for a bit of nostalgia. Especially with the originals not inside a Win95 emulator. Anyway, that really doesn't help fix the issue...
     
  8. Haloruler64

    Haloruler64 Notebook Enthusiast

    Messages:
    16
    Likes Received:
    0
    Trophy Points:
    5
    For the record, I can play DOOM 3: BFG Edition fine now, when I'm using my Alienware M14x display. As soon as I plug in an HDMI cable (to a 1080p monitor), it starts giving me the OpenGL error. Could be an issue with HDMI? Also my display is 1600x900 if it matters.
     
  9. KCETech1

    KCETech1 Super Moderator Super Moderator

    Messages:
    3,778
    Likes Received:
    254
    Trophy Points:
    151
    ok, it is one of the the Optimus bugs. it sounds like OpenGL is going nuts trying to output to an external through the IGP, this was a common problem with CAD apps too
     
  10. Haloruler64

    Haloruler64 Notebook Enthusiast

    Messages:
    16
    Likes Received:
    0
    Trophy Points:
    5
    I think so. Since the internal display is controlled by the Intel HD graphics, it works fine. But when the GT555M takes over (for external displays), it fails. So it's either a dedicated graphics card powering the display it doesn't like, or HDMI in general. Not sure yet. Someone on a different forum confirmed that he can play on the internal display, but not the external. With a GT540M.
     
  11. Kirrr

    Kirrr Notebook Deity

    Messages:
    854
    Likes Received:
    21
    Trophy Points:
    31
    HDMI go through the intel gpu. nVidia-intel-hdmi-monitor... so this can be a problem. try update intel driver.
     
  12. Haloruler64

    Haloruler64 Notebook Enthusiast

    Messages:
    16
    Likes Received:
    0
    Trophy Points:
    5
    On my Alienware, HDMI goes through the NVIDIA card. The internal display is hooked up to the Intel card.
     
  13. Kirrr

    Kirrr Notebook Deity

    Messages:
    854
    Likes Received:
    21
    Trophy Points:
    31
    I see, so this depends on the manufacturer...
     
  14. KCETech1

    KCETech1 Super Moderator Super Moderator

    Messages:
    3,778
    Likes Received:
    254
    Trophy Points:
    151
    manufacturer and even model.
     
  15. Haloruler64

    Haloruler64 Notebook Enthusiast

    Messages:
    16
    Likes Received:
    0
    Trophy Points:
    5
    Isn't that how Optimus works? Internal display always hooked up to Intel HD, external to dedicated graphics? On any laptop using specifically Optimus tech?
     
  16. Haloruler64

    Haloruler64 Notebook Enthusiast

    Messages:
    16
    Likes Received:
    0
    Trophy Points:
    5
    Found a fix! Posted in OP
     
  17. HTWingNut

    HTWingNut Brain size of a planet...

    Messages:
    31,851
    Likes Received:
    3,957
    Trophy Points:
    681
    dedicated is wired through the Intel IGP out to the internal LCD or external. Some laptops like the M17x allow you to turn off Optimus and use the dedicated GPU only.
     
  18. Haloruler64

    Haloruler64 Notebook Enthusiast

    Messages:
    16
    Likes Received:
    0
    Trophy Points:
    5
    My M14x has the GT555M wired through the Intel HD, which is connected to the internal monitor. However the HDMI port is controlled by the GT555M, you go into Windows and check the adapter, NVIDIA one shows up. Also I cannoy turn off Optimus.
     
  19. DeadlyTiger

    DeadlyTiger Newbie

    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    5
    I would just like to say I had the same problem today. I don't know why it started acting up, game was working fine a week ago. But if you change the "1" to "3" , doesn't work, and the message says switch back to "1", try switching it to "2". Worked fine for me.
     
  20. Zymphad

    Zymphad Zymphad

    Messages:
    3,564
    Likes Received:
    60
    Trophy Points:
    116
    Don't bother with Doom 3 BFG. It looks horrible.

    Go with this instead and it's cheaper and it looks better than any game from Activision or Bethesda or Ubisoft.

    Doom 3 + Silkmod 1.2 + Wulfen Texture Pack.

    Guaranteed, this game looks better, technically more advanced than anything from Bethesda or Activision. And yeah, that includes Bethesda's failure, Rage.
     

Share This Page