1. You may have noticed things look a little different around here - we've switched to a new platform (XenForo) and have some new forum styles and features. This how-to guide will help you find your way around. If you find anything that looks strange, post it in this thread.

Does Intel Wifi Link 5100 AGN support 802.11n?

Discussion in 'Networking and Wireless' started by LapBoot, Dec 26, 2008.

Thread Status:
Not open for further replies.
  1. ws2112

    ws2112 Notebook Geek

    Reputations:
    0
    Messages:
    88
    Likes Received:
    1
    Trophy Points:
    16
    I have a dell studio xps 16 with the intel wifi link 5100 on it. And I have an Linksys WRT310N. Before I got this laptop, all myHP pavilion laptops use their wireless g card to access the router and the speed are at ~15000Kbps. But when I hook this lappy to the network, the speed on this laptop is disappointing, results in just around 3000Kbps. I have enabled all the configuration on the card. But still no change. I tried to enable N wireless on router also (disable all the b/g devices) but the speed doesn't increase. I tried to talk to dell rep and he told me that I have to turn off all the startup programs and run like that to be able to have better speed () T_T. Anyone knows if this is the issue of the card or of the configuration and please help me. Thank you
     
  2. sublime313

    sublime313 Notebook Evangelist

    Reputations:
    190
    Messages:
    563
    Likes Received:
    0
    Trophy Points:
    30
    changing my channel width for 2.4ghz to AUTO -which allows the 40mhz- finally enabled my dir-625 to hit 270Mbps from the prior 130Mbps. here's my question: with my slow 5Mbps dsl connection, does this change even make any difference to me?
     
  3. wlan_man

    wlan_man Notebook Consultant

    Reputations:
    122
    Messages:
    196
    Likes Received:
    0
    Trophy Points:
    30
    Nope

    5Mbps from a possible 270 = 2% bandwidth used :)
     
  4. Toyo

    Toyo Notebook Deity

    Reputations:
    266
    Messages:
    1,167
    Likes Received:
    3
    Trophy Points:
    56
    I have all 3 Intel cards on various laptops. 4965AG, 5100AGN, 5300AGN, and without any doubt, my 4965 runs faster and has much better reception than the others. Of course this is just my experience.
     
  5. Tippey764

    Tippey764 MLP:FIM

    Reputations:
    377
    Messages:
    1,423
    Likes Received:
    0
    Trophy Points:
    55
    It does N but it only has 2 antenna's so its not as good as the 5300 or 4965.
     
  6. tentaro

    tentaro Newbie

    Reputations:
    0
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    5

    Ok How do you turn it on? I have been working on computers for the last 18 years of my life and cannot figure out why this card is operating at 54Mbs when it should be at 270 or at least above 100 anyway but I get over 200 upstairs on my machine. Is there some other place that you need to turn this on besides in the Advanced tab under properties for the card?
     
  7. nobscot6

    nobscot6 Wise One

    Reputations:
    419
    Messages:
    1,364
    Likes Received:
    0
    Trophy Points:
    55

    hi
    try reading all the posts on page 2, if you haven't already.........

    here's 1:
    and remember that you must enable AES......
     
  8. discus

    discus Newbie

    Reputations:
    0
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    5

    in where to enable AES ??
     
  9. Shyster1

    Shyster1 Lazy as the Day is Long

    Reputations:
    6,926
    Messages:
    8,179
    Likes Received:
    0
    Trophy Points:
    205
    From the Intel Release Notes for the 12.2 version of the Intel PROSet/Wireless software for XP:

    In other words, make sure that you have either WPA-Personal or WPA2-Personal enabled as the security on your wireless network.
     
  10. Agewardel

    Agewardel Newbie

    Reputations:
    0
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    5
    I am looking at the Buffalo AirStation Wireless-N Nfniti WLI-TX4-AG300N. I'm kinda new at the wireless tech, but from what I've read the dual band is the way to go, but others run $200+. Does any one know anything, or have you any experience with this model.
     
  11. wlan_man

    wlan_man Notebook Consultant

    Reputations:
    122
    Messages:
    196
    Likes Received:
    0
    Trophy Points:
    30
    I've got the WZR-AG300HN, great product, works as it should for me.
    Buffalo don't often update their Firmware only real gripe, should a problem occur then there is a good chance that you are stuck with it.

    And yes dual band routers are the way of the future.
    Not all that far away you'll be broadcasting video on one channel and surfing on another.
    This probably won't become main stream till 450MBps (3 channel) routers come out.
    But 450Mbps in 2.4Ghz will use nearly half the available channels, so congestion will no doubt be rampant in high rise buildings.
    But then WiMAX routers may also make an appearance to alleviate this problem.
    Interesting times ahead.
     
  12. lucianmarian

    lucianmarian Newbie

    Reputations:
    0
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    5
    How do you enable the 11n from memory ?
     
  13. Exostenza

    Exostenza Notebook Evangelist

    Reputations:
    237
    Messages:
    461
    Likes Received:
    0
    Trophy Points:
    30
    AWESOME!!!
     
  14. Dzvinochok

    Dzvinochok Newbie

    Reputations:
    0
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    5
    Hello from Ukraine.

    I have Intel Wifi Link 5100, Vista Home Premium, D-link DI-655.

    My Intel Wifi Link 5100 wad worked on speed 65 Mbit. I've done some changes and now have speed 150 Mbit.
    Down is some steps:

    1. Update driver from Intel web page.
    2.Go to Device Manager, find there Intel(R) WiFi Link 5100 AGN, then properties, then Advanced. Then change Channel Width from 20 to auto. Close.
    3. Go to router setup via lan cable, click Setup > Wireles setting > Choice Mixed 11n and 11g, in point Channel Width choice auto(20-40 MHz).

    The main solution is to change channel width from 20 to 40

    Good luck
     
  15. LaptopWolf

    LaptopWolf Newbie

    Reputations:
    2
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    0
    Hi folks. OK, so I'll sum up the solution to this forum question, "Does Intel Wifi Link 5100 AGN support 802.11n?":

    Lets assume your wifi Router/Access point is a D-Link DIR-655 (like the one I use) ... you need to do this:


    Router configuration:
    1) Go to web address http://192.168.0.1/ to log into your router (or whatever address that the "ipconfig /all" command entered in the command (cmd.exe) window gives as your Default Gateway.)

    2) Set router to 11n only, use WPA2-PSK.

    3) Enable AES, not TKIP.

    4) See http://forums.dlink.com/index.php?topic=616.0 for more precise info.

    Windows configuration:
    * Make sure windows is configuring your wifi connection, not some 3rd party control panel.

    Intel Wifi Link 5100 AGN adapter configuration:
    1) Might as well update the adapter driver to version 12.4.3.9 or better, found at http://www.intel.com/network/connectivity/products/wireless/adapters/5000/

    2) In Vista, go to Control Panel-->System-->Device Manager-->Network adapters-->Intel(R) Wifi Link 5100 AGN-->Advanced-->Property

    3) Set "802.11n Channel Width for band 2.4" to "Auto"

    4) Make sure that "802.11n Mode" is set to "Enabled" (should be already defaulted this way.)

    5) "Throughput Enhancement" should be "Enabled"

    6) Set "Wireless Mode" to "3.802.11g"


    This will at least make your Intel Wifi Link 5100 AGN adapter no longer be stuck at 65Mbps and instead run at 150Mbps (and occasionally hop up to 270Mbps or down to 54Mbps.)

    The thing is, you might notice that 802.11n hardware like the D-Link XTREME N adapters (PC Card, ExpressCard, USB, PCI and PCI-E versions), as well as the Belkin N1 Wireless USB Adapter will run at 300Mbps after you configure your router as described above. Does anyone have any idea how to make the Intel Wifi Link 5100 AGN adapter run at 300Mbps instead of 150Mbps in this situation?
     
  16. darvon44

    darvon44 Newbie

    Reputations:
    0
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    5
    To help You all.

    I have A netgear wrn3500 and i get 300 mbps with my intel 5100 agn.
    here is the way to get it.

    802.11 n channel width for band 2.4 Value:Auto
    802.11n Channel width for band 5.2 Value:Auto
    802.11n Mode Value:Enabled
    Ad hoc channel 802.11b/g Value:11
    Ad Hoc Default wireless mode Value:0. 802.11b/g
    ad hoc power management Value: Disabled
    Ad hoc Qos Mode Value:WMM Disabled
    Fat Channel Intolerant Value: Disabled
    Mixed Mode Protection Value:CTS-to-self Enabled
    Roaming Aggressiveness Value:Highest
    Throughput Enhancement Value:Enabled
    Transmit Power Value:Highest
    Wireless Mode Value:802.11a/b/g

    Now that should at least give u up to 300 mbps. trust me it works.
    any question
     
Thread Status:
Not open for further replies.

Share This Page