Does anyone know about integrated vs dedicated GPUs?

Discussion in 'Dell Latitude, Vostro, and Precision' started by jack574, Jan 5, 2020.

  1. jack574

    jack574 Notebook Consultant

    Reputations:
    10
    Messages:
    191
    Likes Received:
    47
    Trophy Points:
    41
    Hi

    Would someone be kind enough to explain this to me?

    My old Precision is an M6700 with an i7-3840QM and Quadro K4000M.

    My new precision is an 7740 with i9-9980HK and RTX 4000.

    Manipulating a 3D model on the M6700, I can see that the K4000M is being used. No integrated GPU shows up at all in task manager.

    Manipulating the same 3D model in the same software on the 7740, the integrated GPU is being used almost 100% and the RTX is always at 0% usage.

    Questions are basically:

    1. Why is the M6700's i7's integrated GPU not visible in task manager?
    2. Why is the RTX not being used at all in the 7740? The software is obviously able to use a dedicated GPU as it uses the K4000M in the M6700.

    Thanks in advance!
     
  2. hertzian56

    hertzian56 Notebook Consultant

    Reputations:
    12
    Messages:
    152
    Likes Received:
    54
    Trophy Points:
    41
    I wasn't aware task manager showed gpu's? I have an m6700/980m and I don't see a gpu in the task manager. I can see it in the device manager if that's what you mean.

    If you can see both are being used in device manager then it's likely just a demand issue, easier stuff will always use the integrated and harder stuff like games will use the discrete gpu. In the k4000m case I'd think that it's the same except the the model/software you use has determined that the hd4000 is not up to the task so it switches to the k4000m. Whatever integrated gpu you have in the 7740 is probably powerful enough to skip the rtx card, saves battery and fan usage.

    If you want only the rtx to be used you will have to turn off optimus, either in the bios or maybe you have an option to do it on the fly in the 7740. I'm not sure if you can specify in your modeling software which gpu to use, might try that too.

    Edit: I missed that you probably have optimus turned OFF in your m6700 so it does not use the hd4000 only the k4000m, that's the reason there.
     
    jack574 likes this.
  3. Aaron44126

    Aaron44126 Notebook Prophet

    Reputations:
    740
    Messages:
    4,178
    Likes Received:
    1,184
    Trophy Points:
    231
    Task Manager is lying in this case. The Intel graphics driver for the Intel HD 4000 GPU in the M6700 was never seriously upgraded for Windows 10 and it does not provide the information needed for it to appear in Task Manager. It is still in use if you have graphics switching / Optimus enabled.

    As for why any particular app is using you Intel GPU when it makes more since to use the dGPU, just...
    Go to Start -> Settings -> System
    Scroll all the way to the bottom of the Graphics area and select "Graphics settings"
    Add a profile for your app and set it to use the high performance GPU
     
    alexhawker likes this.
  4. jack574

    jack574 Notebook Consultant

    Reputations:
    10
    Messages:
    191
    Likes Received:
    47
    Trophy Points:
    41
    No, it's definitely in Task Manager -
    upload_2020-1-6_20-25-0.png


    Thanks. I guess there's no reason to switch optimus off and force it to use the RTX, if it will use the RTX of its own accord when the intel graphics can't do the job?

    Thanks for the reply.
     
  5. jack574

    jack574 Notebook Consultant

    Reputations:
    10
    Messages:
    191
    Likes Received:
    47
    Trophy Points:
    41
    Thanks, that's interesting.



    I'll try that, but is there any reason to? Are there some cases where the intel graphics will not be up to the job, but the RTX won't automatically be used instead? As hertzian said, maybe in my case the intel GPU was capable of doing what needed doing, so the RTX wasn't needed.

    Thanks a lot for the reply
     
  6. Aaron44126

    Aaron44126 Notebook Prophet

    Reputations:
    740
    Messages:
    4,178
    Likes Received:
    1,184
    Trophy Points:
    231
    The NVIDIA GPU has updated drivers and will show in Task Manager. The Intel GPU will not (on the M6700).

    If everything is left in the default state, the NVIDIA driver basically decides when to engage the NVIDIA GPU or when to leave things to the Intel GPU. There are also settings for this in the NVIDIA control panel. Apps can be made multi-GPU aware and override this behavior, deciding which GPU to use, but it is rare to see cases of this actually being done.
     
    jack574 likes this.
  7. hertzian56

    hertzian56 Notebook Consultant

    Reputations:
    12
    Messages:
    152
    Likes Received:
    54
    Trophy Points:
    41
    Oh right you're on win10 I'm on win7 that's why the difference. Yeah unless you really really want to use the rtx I'd think it's better anyways to just use what the computer chooses. It's a nice option to have tbh, probably works better w multimedia etc now then it does for me, too.
     
  8. jack574

    jack574 Notebook Consultant

    Reputations:
    10
    Messages:
    191
    Likes Received:
    47
    Trophy Points:
    41
    Ok, I'll leave it all alone then. Thanks for the help
     
  9. jack574

    jack574 Notebook Consultant

    Reputations:
    10
    Messages:
    191
    Likes Received:
    47
    Trophy Points:
    41
    Yep, I'll leave it up to the PC to decide. Thanks for the replies.
     
  10. Dell-Mano_G

    Dell-Mano_G Company Representative

    Reputations:
    278
    Messages:
    522
    Likes Received:
    111
    Trophy Points:
    56
    If you only want to use the discrete GFX you can turn off switchable GFX in the BIOS. Boot into the BIOS, scroll down to video and expand that section, and then just turn off switchable GFX.
    FYI, if you decide to do this, when running on battery, your battery performance will suffer. If you are plugged in all the time then go ahead. If on battery a lot then follow the instructions provided above by @Aaron44126
     
Loading...

Share This Page