Disabling Headphone Jack Detection?

Discussion in 'Dell XPS and Studio XPS' started by Kel_Varnsen, Nov 2, 2011.

Thread Status:
Not open for further replies.
  1. Paul93

    Paul93 Newbie

    Reputations:
    0
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    5
    Can you please tell me how to do the exactly same thing on windows 8? I can't find settings in "0000".

    [​IMG]
     
  2. yabbas

    yabbas Newbie

    Reputations:
    0
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    5
    Thanks Alex

    Looks like my Dell L702X suffered the same fate (don't know if it's a coincidence or not - but I plugged in pair of Samsung hands-free headphones in the jack around the time the Audio stopped being detected - these are the ones with a Mic and a set of buttons for volume and audio select - 4 contact jack - this SHOULDN'T break things but *shrugs*.)

    Just for the record - the problem is that the Jack now constantly shows a pair of headphones inserted - i.e. sense stopped working. Using the standard Microsoft HD Audio drivers changed nothing. I didn't experiment too much with the High Definition Audio Utility to reconfigure Pins (which seemed too complicated, and only works with MS Standard Driver).

    If you were playing continual sound - and used the Realtek utility to reconfigure the jack from Headphone to Front Speaker you can hear a blip of the original audio playing back while switching occurs. Then the drivers switch back to Headphone mode ... disabling the sound entirely.

    Alex Sutcliffe's method reconfigures the Jack to show up as a Line Input.

    It's a bit of a shame that disabling Jack Detection doesn't work! I'd love to be able to force the jacks to do EXACTLY what I want, when I want it!

    Now I get Audio played through the laptop speakers. Audio does not play through the Jack at the same time. Inserting a pair of Headphones into the Jack causes it to switch back into Headphone mode all over again unless you disable Jack Auto Detection. If you disable Jack Auto Detection you can select "Headphones" or "Laptop Speakers" in the Realtek Audi app to switch the jack back to Headphone mode. To switch back to the laptop speakers requires changing the registry and restarting all over again. It's a nuisance, it's disappointing and annoying - but at least it's not an out of warranty RMA.

    I'll try changing the values of the Jack, perhaps another number instead of 2 gives dual output?


    Either way - using Alex's values if you paste the following lines in a .reg file you can just double click and it'll import it all for you.



    Windows Registry Editor Version 5.00

    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4d36e96c-e325-11ce-bfc1-08002be10318}\0007\Settings]
    "ForceDisableJD"=hex:01

    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4d36e96c-e325-11ce-bfc1-08002be10318}\0007\Settings\Drv7083_DevType_0665_SS102804b8]
    "Pin1b"=hex:00,00,00,00




     
  3. dziamdziol

    dziamdziol Newbie

    Reputations:
    0
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    5
    do you solved this problem?? I ve win 7 64 bit and i cant search pin1b (my laptop dell xps l702x)
     
  4. Problematic Jess

    Problematic Jess Newbie

    Reputations:
    0
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    5
    i can't fin

    theres no pin1b only pin1a what to do?
     
Loading...
Thread Status:
Not open for further replies.

Share This Page