Disabling CompuTrace

Discussion in 'Dell Latitude, Vostro, and Precision' started by Muggerprime, Apr 16, 2018.

  1. Muggerprime

    Muggerprime Newbie

    Reputations:
    0
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    5
    Greetings everyone,

    I refurbish computers for a living. An office in my area upgraded their laptops and sent the old ones to a recycling center in my area. The recycling center plans to scrap them for metal, because they all have Computrace active. If I can disable the Computrace, they're willing to sell them to me for cheap. They gave me one of them to play with and try to disable it. If I can't, they're going to throw these otherwise perfectly good I5 laptops in the shredder.

    They are all Dell Latitude E5430. The one I got had bios A11 on it, and I flashed it to A18 (non-vPro).

    Direct link: https://downloads.dell.com/FOLDER04135952M/1/5430A18.exe

    Computrace has 3 settings in the Bios - "Disabled", "Deactivated", and "Activated". "Deactivated" means it's ready to be set to "Disabled" or "Activated". Once set to one of those two, it can "never" be changed, and the setting in the Bios is grayed out. I want to change the setting from "Activated" to "Deactivated" so I can then go in and disable it.

    I found a video of someone doing this on a different Dell (this is exactly what I'm trying to do):


    What I've tried:
    - I tried extracting the Bios from the "5430A18.exe" file using the /writehdrfile and /writeromfile flags, but got errors and it didn't work.
    - I used "Universal BIOS Backup ToolKit 2.0" to try to backup my Bios to a file. I ended up with "DellInc.-A18.rom", which is 14MB. I'd attach it here, but there doesn't seem to be a way to attach files.
    - I then used "UEFITool_0.22.4_win" to try to edit the Rom. I found 2 Computrace modules, and a lot a Computrace references in "SetupPrep". The modules were easy enough to remove, but wasn't sure if I should remove SetupPrep or leave it. I don't know enough to edit it. I decided to leave it.
    - I got stuck when it came time to try to flash the Rom file back. Dell has no separate flash utility for Rom/Bin/HDR files; their Bios files are all EXE. I tried a few flashing programs, but they all said my Rom was an invalid file.

    Can anyone please help me?
     
  2. alexhawker

    alexhawker Spent Gladiator

    Reputations:
    462
    Messages:
    2,444
    Likes Received:
    738
    Trophy Points:
    131
    It's very likely that the forum rules will not permit discussing how to disable/circumvent this.
     
  3. Mobius 1

    Mobius 1 nͫٴiͤٴcͫٴeͤ੮Һ૯ ცɿ૭ ૭คעٴٴٴٴٴٴٴٴٴٴٴٴٴٴٴٴٴٴٴٴٴٴٴٴٴٴٴ

    Reputations:
    3,307
    Messages:
    8,958
    Likes Received:
    6,264
    Trophy Points:
    681
    computrace is botnet virus
    virus removal is allowed

    carry on



    @Muggerprime I think you need to use a hardware flasher to remove the bios computrace lock, maybe there's even multiple bios chips that you have to relfash

    Alternatively I would just call lojack customer support and explain the situation
     
    alaskajoel and alexhawker like this.
Loading...

Share This Page