1. You may have noticed things look a little different around here - we've switched to a new platform (XenForo) and have some new forum styles and features. This how-to guide will help you find your way around. If you find anything that looks strange, post it in this thread.

Disabling built-in microphone?

Discussion in 'Lenovo' started by hgjcvblk, Jul 31, 2008.

Thread Status:
Not open for further replies.
  1. hgjcvblk

    hgjcvblk Notebook Geek

    Reputations:
    0
    Messages:
    81
    Likes Received:
    0
    Trophy Points:
    15
    I have a T61p and have recently started to use headphones very frequently. I noticed that the built-in mic seems to pick up everything from typing to mouse clicks. Is there any way to disable the built-in mic? I plan on using an external one for the few times I do use mics.

    I've tried turning down the microphone recording volume in the sound properties with no success. I am currently on WinXP Pro if that helps. Thanks!
     
  2. gogo2390

    gogo2390 Notebook Consultant

    Reputations:
    0
    Messages:
    137
    Likes Received:
    0
    Trophy Points:
    30
    you should be able to go to sounds/audio devices in control panel, then go to audio and change the default sound recording device to the thing that isnt the one on the computer there should be settings for it
     
  3. hgjcvblk

    hgjcvblk Notebook Geek

    Reputations:
    0
    Messages:
    81
    Likes Received:
    0
    Trophy Points:
    15
    The only option available under recording devices is the SoundMax HD audio with or without my external mic plugged in. I can't change it to anything else. Any other ideas?
     
  4. stewie

    stewie What the deuce?

    Reputations:
    3,666
    Messages:
    2,174
    Likes Received:
    0
    Trophy Points:
    55
    Have you tried checking the "Mute" box for microphone in Volume Control?
     
  5. hgjcvblk

    hgjcvblk Notebook Geek

    Reputations:
    0
    Messages:
    81
    Likes Received:
    0
    Trophy Points:
    15
    The mute box is checked under "Microphone" in volume settings, and still no results. I'm starting to think that there's no way to disable the built-in mic. Here's what I tried so far...

    1) Muted the mic on volume settings (playback window)
    2) Turned down the mic all the way on the recording window of volume settings
    3) Tried switching to another recording device under sound properties, but no other device is available even if I have my external mic plugged in

    Any other ideas are greatly appreciated. Thanks
     
  6. webdtc

    webdtc Notebook Deity

    Reputations:
    52
    Messages:
    749
    Likes Received:
    0
    Trophy Points:
    30
    There's a built-in mic on the T61p? I didn't know that. I don't think mine works if there is one...
     
  7. Tim

    Tim Notebook Virtuoso

    Reputations:
    2,752
    Messages:
    3,142
    Likes Received:
    1
    Trophy Points:
    106
    Yep the microphone is right below the "Fn" key.
    Tim
     
  8. gogo2390

    gogo2390 Notebook Consultant

    Reputations:
    0
    Messages:
    137
    Likes Received:
    0
    Trophy Points:
    30
    open up the case and cut the wire from it :)
     
  9. miro_gt

    miro_gt Notebook Deity

    Reputations:
    433
    Messages:
    1,704
    Likes Received:
    1
    Trophy Points:
    56
    ducktape it :)
     
  10. batman5315

    batman5315 Notebook Evangelist

    Reputations:
    267
    Messages:
    373
    Likes Received:
    0
    Trophy Points:
    30
    control panel->sound max->microphone->properties->advanced

    should be somewhere in there

    or double click the sound icon on the lower right hand corner, options->properties->hit "recording" button -> select the device(s) below-> hit ok->mute/turn down the volume for whatever recording device is bothering you
     
  11. shabunsafu

    shabunsafu Newbie

    Reputations:
    0
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    5
    you can not disable built in mic but you have mute play back sound in recoding device setting
     
  12. t30power

    t30power Notebook Deity

    Reputations:
    190
    Messages:
    761
    Likes Received:
    0
    Trophy Points:
    30
    You just mute it typing sndvol32 in the run box.
    I use headphones all the type and only hear the keys when I type on them when I actually unmute the mic, maybe there's another app unmuting your mic.
     
  13. MilkyTech

    MilkyTech Newbie

    Reputations:
    0
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    5
    I have been dealing with the same problem with a Dell Inspiron 1525 and there seems to be absolutely no solution what-so-ever.
    The problem lies with the functionality of the sound card driver. in my case it is Sigmatel HD Audio. It just doesn't have any separate control of the built-in mic. with Vista or 7, you only see control for "Microphone array" which is basically the entire sound card.
    I am trying to record the Jim Rome show which airs while i am working and so never get to listen and the noise from the built-in mic is too annoying to even bother listening at all.
    I was hoping the problem would be solved when I upgraded to Windows 7. I uninstalled the soundcard through the Device Manager immediately before upgrading so that Windows 7 would detect the soundcard and install the appropriate drivers automatically. My hope was that the new drivers would have more functionality than the drivers I had previously gotten directly from Sigmatel.
    Now my Device Manager shows "Intel HD Audio HDMI" instead of Sigmatel, but the functionality is exactly the same. Just "Microphone Array". No "What You Hear" or "Wav".
    So, this leaves 2 choices. buy an external soundcard that has more functionality or...do what gogo2390 said and cut the wire from the mic.
    since I don't need the mic at all, I thought the second option might actually be a viable solution.
    NOT! :mad:
    After taking off the display bezel to get to the built-in mic I noticed the mic is actually 2 mics located on either side of the built-in webcam. There is basically a small ribbon cable with 6 tiny wires going into the webcam/mic unit with a connector similar to the connector that attaches the keyboard or display to the motherboard, just smaller. Now I am thinking "GREAT!" all I have to do is disconnect this cable and the mic will be disabled (the webcam also, but for now I just want to be able to record my show) and what-do-you-know, when that cable is diconnected the entire "Microphone Array" is disabled the same as if I muted it. Sound still comes from the speakers, but nothing at all can be recorded.
    UNBELIEVABLE! :mad:
    Maybe I can just cut a tiny wire right at the mic's base?
    NEGATIVE!:mad:
    both mics and the webcam are all attached directly to a tiny circuit board (NO WIRES!)

    So, I believe I have exhausted all options here short of buying an external soundcard and that's not gonna happen!
     
  14. Renee

    Renee Notebook Virtuoso

    Reputations:
    610
    Messages:
    2,645
    Likes Received:
    0
    Trophy Points:
    55
    If the machine is under waranty and even if it isn't, call up lenovo and have a tech send you a portion of the skematic the covers the mic.
    Renee
     
  15. MilkyTech

    MilkyTech Newbie

    Reputations:
    0
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    5
    Unfortunately its not a Thinkpad. Its a Dell Inspiron 1525.
    you can't even get through to Dell tech support anymore without a valid Service Tag that is still under warranty. Even if I did get through with a phony Service Tag, I have no doubt the novices that work in tech support won't even know what a schematic is let alone be able to send it to me. Even if I got the schematic, what good would it do me? I would then have to somehow sever the connection to the mic on the circuit board without destroying the entire thing (which is only about 1/4" X 3").
    Although I don't need the mic, I would still like to keep the webcam. I wouldn't want to chance ruining the whole thing without being absolutely certain that disabling the mic in this fashion wouldn't also disable the entire "Microphone Array" just as disconnecting the cable did.

    But thanks for your input Renee :)
     
  16. elfer

    elfer Newbie

    Reputations:
    0
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    5
    physically remove it. unscrew the screws on the bottom of the notebook. open up the laptop and use a pair a pliers to remove the microphone.
     
  17. MilkyTech

    MilkyTech Newbie

    Reputations:
    0
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    5
    are you serious elfer?
    is this really what you want your first post to be?
    try reading the entire thread before putting your ONE cent in.
     
  18. capnpip

    capnpip Newbie

    Reputations:
    0
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    5
    It's something to do with the digital audio settings vs AC97, I know how to separate them with Realtek HD audio, but it should be similar with your setup...

    Go to Control Panel, then open your HD audio control panel (should be easier to find in Classic View), in Realtek's case there is an option for Device Advanced Settings... it gives an option to "Tie up same types of inputs as one input device" or "Separate all input jacks as independent input devices" Check that one and Windows should now show separate listings for the built-in and the front panel inputs. Again, the path to get there will probably be different, so you'll have to feel it out, but this should let you mute the built-in mic without affecting any other input jacks/devices.
     
  19. borkey

    borkey Notebook Geek

    Reputations:
    24
    Messages:
    80
    Likes Received:
    0
    Trophy Points:
    15
    It's a perfectly reasonable suggestion, though suggested previously. He happened to give more detail about it though, which makes it a reasonable first post. About as reasonable as posting about a Dell in a Lenovo forum, anyway.

    Now then, mini-modding the mini-modder aside, does increasing the volume of the Mic section on the volume control have any effect at all? If not, it's likely the wrong slider.
     
  20. TheHayteeboy

    TheHayteeboy Newbie

    Reputations:
    0
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    5
    to disable microphone control panel>sound highlight "speakers" the "properties" button should then be highlighted then click on it click on "levels" tab then you should see your microphone volume level and mute button you should then be able to enable/disable your microphone by the way im using windows 7 32bit version i dont know if it will work for any other windows version
     

Thread Status:
Not open for further replies.

Share This Page