1. You may have noticed things look a little different around here - we've switched to a new platform (XenForo) and have some new forum styles and features. This how-to guide will help you find your way around. If you find anything that looks strange, post it in this thread.

Disabling awful power cord beep?

Discussion in 'Acer' started by aoeud, Jan 29, 2010.

  1. aoeud

    aoeud Newbie

    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    5
    Yesterday I purchased an Acer Aspire 5740 laptop, which I quite like except for the awful beep it makes when the power cord is plugged in or removed from the laptop. Is there any way to disable this beeping sound?
     
  2. Mooly

    Mooly Notebook Evangelist

    Messages:
    353
    Likes Received:
    0
    Trophy Points:
    30
    Lol... now how often do you keep connecting and disconnecting with it powered :)

    It's a good reminder anyway, what if you were on battery, plugged in and had forgotten to have the adapter connected to the mains... you wouldn't know 'till the laptop shutdown that there was a problem.

    I'm guessing if there is a way it will either be in "sounds" (right click the speaker icon in the tray) or the BIOS perhaps ?

    Never known anyone want to turn it off before.
     
  3. aoeud

    aoeud Newbie

    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    5
    It's not in either place.
     
  4. Mooly

    Mooly Notebook Evangelist

    Messages:
    353
    Likes Received:
    0
    Trophy Points:
    30
    Hmmm, in that case I've no idea, sorry.
    Be very interesting to know if it can be done though :)
     
  5. prikolchik

    prikolchik Notebook Evangelist

    Messages:
    362
    Likes Received:
    0
    Trophy Points:
    30
    This is in XP, but should be pretty similar in Vista/7.
    Open "Device Manager" and go "View"->"Show hidden devices" then scrolls down to "Non-Plug and Pllay Drivers" click on the "+" and rightclick on the item that says "Beep". Then select "Disable" and restart your computer. Beep should be permanently disabled :D
    [​IMG]

    If you do not see the beep there, or it doesn't disable it, then you will have to check Acer ePowermanagement (or whatever it is called) and see if there is something like "beep when power disconnected".

    Anyway, good luck!
     
  6. aoeud

    aoeud Newbie

    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    5
    I appreciate the help, prikolchik; however, I didn't get any love from that. I e-mailed Acer and hopefully they'll help (not sure why I didn't do this first)
     
  7. Mooly

    Mooly Notebook Evangelist

    Messages:
    353
    Likes Received:
    0
    Trophy Points:
    30
    Let us know what the outcome is :)
     
  8. regulator207

    regulator207 Newbie

    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    5
    ok so i've been down this path and have emailed and called acer about this. They state there is no way to disable the sound as "it is enabled by default." lame excuse but that's what they say.

    I did notice that if you dont install the realtek audio drivers, then the beep doesnt happen. Also the disable beep in device manager doesnt work in win7 and the "levels" option in the sound is nonexistant in win7.

    The audio beep goes away when you mute the system. easiest way would be fn+f8
     
  9. woody189

    woody189 Newbie

    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    5
    I subscribed to find to this forum to solve this very problem, but decided to do a search first. I think it's ridiculous that you can't turn the sound off. It's not that serious, but it's annoying, and pretty damn loud.

    I don't get how you can adjust basically every other sound, but they would omit an adjustment for this one.

    Mooly, I don't unplug it all constantly, but I tend to plug/unplug it every couple hours because I don't like to overcharge my battery. Whenever it maxes out, I unplug the chord. Then when it's gonna die again, I plug it back in. I never leave it plugged in when I"m not using it. I heard years ago that overcharging stuff kills the battery. IDK if it's true anymore, but I still do it.

    ANyway, back to the topic... Acer's stupid for not allowing us to disable the sound.
     
  10. Mooly

    Mooly Notebook Evangelist

    Messages:
    353
    Likes Received:
    0
    Trophy Points:
    30
    Just a quick point on the battery... you won't overcharge it leaving it connected and on.
    LiOn cells are destroyed quickly by trickle charging, so as soon as 100% is reached the charge is terminated. If you don't use the battery it will be perhaps 2 to 5 days before the charger again "tops off" the battery to replace charge lost by natural chemical processes in the cells. THis usually happens when the battery is around the 96% full mark.

    You are best just ocasionally using the battery... perhaps every two to three weeks or so with occasional fairly deep discharges.

    Using the battery constantly "wears" it out :) They have a fairly well defined and limited number of charge/discharge cycles from new.
     
  11. woody189

    woody189 Newbie

    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    5
    Thanks for the info. I guess I was doing more harm then good by unplugging it regularly.

    aoeud, did you get any new info from ACER??
     
  12. aoeud

    aoeud Newbie

    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    5
    Yes. I have discovered that they're useless. "It can't be disabled because it is the manufacturer's design." That's really quite frustrating, makes me want to return this, but barring that it's the best laptop for my needs... It wouldn't be so bad except the power cord is designed to slide out with the slightest force; I rarely intentionally unplug it.
     
  13. woody189

    woody189 Newbie

    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    5
    I was just telling my g/f how annoying that is like 5 minutes ago.

    I didn't know it was designed that way, but I guess it makes sense. I would much rather have it stay in all the time. It constantly falls out when I move the my laptop the slightest bit.

    Thanks for the info. It's pretty stupid if you ask me.
     
  14. Oddemann

    Oddemann Newbie

    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    5
    This noise is one of the most annoying noises i have ever heard on a pc. Its very irritating to hear the sound when the cord disconnects suddenly. I dont really need the computer to tell me that the cord fell out as windows will give me a battery warning if battery gets low. Also i am unplugging the computer all the time using it in different areas of the house, and this battery sound really irritates me.

    ALSO we have to small childrens, and they are sleeping close to the living room. VERY nice to wake them up just because the powerchord fell out ?

    Most stupid thing ever i have seen on a notebook.

    ALSO: Battery just stopped charging today, so this computer will be returned.

    Regards
    Oddd
     
  15. chaoscreater

    chaoscreater Newbie

    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    5
    OMFG i need help with this too!! I just joined this forum for the sole purpose of getting this damn annoying problem solved. I bought an ACER Aspire 5740G laptop yesterday and it's my very first Acer laptop, and i'm already pissed off with the loud beelping sound!!

    I go to university so don't use AC power all the time, and that's what a laptop is suppose to be for anyway, you carry it around and rely on maybe 1 or 2 hours of battery life. Unplugging the AC power is inevitable for me sometimes and it just pisses me off whenever it makes that loud beep, i tried all the options on this topic already, have checked options in ePower Management but found none useful, no options in BIOS has the option to disable beep either, and i have disabled the beep driver itself and it's still BEEPING!! AHH!!
     
  16. chewietobbacca

    chewietobbacca Notebook Evangelist

    Messages:
    449
    Likes Received:
    0
    Trophy Points:
    30
    Hands down the most annoying/stupid thing Acer has ever done
     
  17. jbud

    jbud Newbie

    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    5
    Solution!

    I have a solution, believe it or not it is the REALTEK AUDIO DRIVERS

    1) Uninstall your audio driver.
    2) Reboot.
    3) Let windows replace them with generic HD audio drivers.
    4) Enjoy never hearing the awful beep again.

    -JBud
     
  18. Mooly

    Mooly Notebook Evangelist

    Messages:
    353
    Likes Received:
    0
    Trophy Points:
    30
    Does doing that not cause a lot of functionality to disappear, such as the SPDIF output etc ?
     
  19. killacat

    killacat Notebook Enthusiast

    Messages:
    30
    Likes Received:
    0
    Trophy Points:
    15
    Usually it is output via the pc speaker. It usually helps to disable or mute the pc speaker in Windows.
     
  20. FotoFan1

    FotoFan1 Newbie

    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    5
    I have a Lenovo N500 with the exact same problem...trying the Beep fix in device manager as we speak...
     

Share This Page