Deus Ex: Mankind divided

Discussion in 'Gaming (Software and Graphics Cards)' started by mtness, Aug 25, 2016.

Thread Status:
Not open for further replies.
  1. Carrot Top

    Carrot Top Notebook Evangelist

    Reputations:
    74
    Messages:
    319
    Likes Received:
    274
    Trophy Points:
    76
    How are you getting such good FPS? I am running lower settings (I think) and only average 45 FPS in the benchmark.

    [​IMG]

    My settings:
    [​IMG] [​IMG]

    980M is overclocked by 15% as well.
     
    Last edited: Oct 7, 2016
  2. mtness

    mtness loitering

    Reputations:
    367
    Messages:
    1,841
    Likes Received:
    111
    Trophy Points:
    81
    im only running 4x anisotropic texture filtering, everything else seems similar to my settings, funnily enough as they have released patches the performance has deteriorated slightly im closer to your 45 fps average at this stage.
     
  3. Carrot Top

    Carrot Top Notebook Evangelist

    Reputations:
    74
    Messages:
    319
    Likes Received:
    274
    Trophy Points:
    76
    16x AF should be free though. Mind sharing your exact settings? Just curious is all. Still trying to tweak this game for a good balance of performance and visuals.

    Have you tried DX12 yet? It's out of beta and officially released now.
     
  4. mtness

    mtness loitering

    Reputations:
    367
    Messages:
    1,841
    Likes Received:
    111
    Trophy Points:
    81
    yes ive tried dx12 i found it slower load times overall, here are my settings http://imgur.com/a/ajS3i

    quite similar to yours, but not exact
     
  5. Carrot Top

    Carrot Top Notebook Evangelist

    Reputations:
    74
    Messages:
    319
    Likes Received:
    274
    Trophy Points:
    76
    Thanks.

    Yeah I'm definitely underperforming for some reason. CHS is one of the most demanding settings in the game. You have it on Ultra and get 49 FPS, I have it off and only get 45 FPS. Must be running a high GPU overclock or something.
     
  6. saturnotaku

    saturnotaku Notebook Nobel Laureate

    Reputations:
    4,305
    Messages:
    7,838
    Likes Received:
    3,351
    Trophy Points:
    431
    Finally finished the main campaign, which resulted in the mother of all non-endings. Hopefully this gets fleshed out a bit more with DLC, rather than waiting another 4-5 years for the next sequel. Speaking of DLC, I played and completed System Rift, which although not very lengthy, was highly enjoyable. The infiltration missions in this game are far more fun than faffing about with sidequests in the over world.
     
    Prototime likes this.
  7. Niaphim

    Niaphim Notebook Consultant

    Reputations:
    11
    Messages:
    196
    Likes Received:
    91
    Trophy Points:
    41
    Good news for SLI users: recent dx12 patch (still beta on steam, but works fine for me) provided a solid boost to fps. Before I played on high preset with 40-60 fps (default Nvidia bits) or 50-70 fps (custom bits with a bit of flickering). Now it's 70+(solid 75 most of the time, up to 100 w/o vsync) with default bits on very high preset (basically ultra with shadows turned down one step). Also default bits now give the best performance (dx12, from what I've tested).
     
    Last edited: Oct 18, 2016
    Prototime and hmscott like this.
  8. sykozylot

    sykozylot Notebook Guru

    Reputations:
    0
    Messages:
    58
    Likes Received:
    15
    Trophy Points:
    16
    Need help with setting this game up. When I have vsync (double or triple buffering) turned on in the game, the input lag is terrible. Runs smoothly with all vsync turned off in-game.

    Now when I try to force vsync through the Nvidia control panel, there's still screen tearing. Is there a way around this? I want to not have screen tearing, but it looks like I can't use the in-game settings.

    970m Optimus system if that makes a difference.
     
  9. Niaphim

    Niaphim Notebook Consultant

    Reputations:
    11
    Messages:
    196
    Likes Received:
    91
    Trophy Points:
    41
    I also had an issue with vsync, don't remember if it was exactly the same, but if you see tearing with vsync on make sure that you are running fullscreen and not borderless windowed (in the latter case vsync options do nothing or even make things worse).
     
  10. sykozylot

    sykozylot Notebook Guru

    Reputations:
    0
    Messages:
    58
    Likes Received:
    15
    Trophy Points:
    16
    Yup, already running fullscreen.
     
Loading...
Thread Status:
Not open for further replies.

Share This Page