DellFanManagement & DellFanKeepAlive – Tools for managing the fan speed in Dell laptops

Discussion in 'Dell' started by Aaron44126, Jun 18, 2020.

  1. Aaron44126

    Aaron44126 Notebook Prophet

    Reputations:
    779
    Messages:
    4,545
    Likes Received:
    1,398
    Trophy Points:
    231
    If you got that from the BIOS then I think that there is a hardware issue of some sort. I'd check for a replacement fan on eBay, hopefully that is all that is needed to take care of it.
     
  2. maj3091

    maj3091 Newbie

    Reputations:
    0
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    5
    Hi,

    Recently came across this post whilst trying to solve a random shutdown issue on my Dell Inspiron 5579 ( i7-8550U @ 1.8Ghz, 16Gb RAM, Win10 (x64) ), which by googling, I'd determined was a thermal shutdown, as there was nothing graceful about it, it was just off and wouldn't power on again for a good few minutes sometimes, albeit, there wasn't a great deal of heat (from what I could tell).

    Firstly, I want to say thanks to @Aaron44126 for the effort in putting this together, as this is definitely looking like a step in the right direction in resolving my issue.

    Just to provide some feedback. I ran the dellfancmd test option and got the following output on my setup.


    Loading SMM I/O driver...
    ...Success.
    Disabling EC fan control...
    Looks like fan 2 is not present, system only has one fan?
    Measuring: Fan 1, level 0...
    Measuring: Fan 1, level 1...
    Measuring: Fan 1, level 2...
    Enabling EC fan control...
    Test procedure is finished.


    Fan 1 initial speed: 0

    Fan 1 level 0 speed: 0
    Fan 1 level 1 speed: 2527
    Fan 1 level 2 speed: 5080

    Unloading SMM I/O driver...
    ...Done.


    Not sure if the line in red above is a normal thing, I suspect not, and that may well explain my issue. In the BIOS logs, I do have a fan controller error, which appears to be stopping the fan being controlled by the BIOS, yet it can quite happily be controlled by this tool.

    I did try to use the ThermalSetting tool to see if I could force manage the fan (If I understood it's usage correctly), but that failed to work for me on any setting, giving the below:

    Thermal setting, before change: Error
    Failed to apply the new thermal setting.


    I'm running the dellfancmd tool with the fan1-level1 option and it was stable all day yesterday. It is early days yet, as sometimes my laptop has gone days without an issue, yet on other days it can shutdown 4 times in an hour, then be stable for the rest of the day.

    I know there is a BIOS update available (I'm currently running 1.11.0), but I didn't see anything about addressing fan issues. To be honest, I've been nervous about doing it for fear of a shutdown mid flashing.

    At the moment, i'm happy to have the fan at 50% constantly and live with the noise, if it means it not randomly turning off, although I'd rather it get to a more controlled fan setting at some point.

    Anyway, apologies for the long winded message, I just want to say thanks and provide some feedback on potentially a different setup.
     
  3. Aaron44126

    Aaron44126 Notebook Prophet

    Reputations:
    779
    Messages:
    4,545
    Likes Received:
    1,398
    Trophy Points:
    231
    Not unusual for the initial speed to show 0. It is unusual if the fan speed does not ramp up in response to temperature/load. In this case I would recommend that the motherboard be replaced if the system is under warranty (which it should be if you got a three-year), but otherwise, you'll have to use third-party tools like this to manage the fan.

    You can use HWiNFO or SpeedFan to have the fan respond to temperature, but, only the three that can be set here can be used (off/medium/high), not a more granular set of speeds which is supposed to be what you get with the EC managing the fan.

    I wouldn't be too worried about flashing the BIOS. You can set the fan speed to max and then run the flash. The fan speed change will "stick", even if Windows is shut down, until the system is fully shut down or another program makes an EC adjustment (which the BIOS flasher might do at the very end).
     
  4. maj3091

    maj3091 Newbie

    Reputations:
    0
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    5
    Thanks for the reply. Unfortunately it wasn't on a three year warranty, so don't want to go there, albeit I'm due an upgrade through work soon.

    Thanks for tips, I'll give it another few days running as it is, before I attempt the flash, just to be sure that I've found the issue for sure.

    Appreciate the help.
     
  5. Aaron44126

    Aaron44126 Notebook Prophet

    Reputations:
    779
    Messages:
    4,545
    Likes Received:
    1,398
    Trophy Points:
    231
    Couple things to mention.

    I don't really expect updating the BIOS to actually help with this issue (although it might).

    Also regarding the failure to switch thermal modes, have you tried Dell Power Manager? (You can download this program directly from Dell.) You can also switch the thermal mode in there under "Thermal Management". I'm sort of surprised if it works in there but not through the command-line app (assuming that you were running the command-line app "as administrator") because they do basically the same thing in the background.
     
  6. maj3091

    maj3091 Newbie

    Reputations:
    0
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    5
    I did try the Dell Power Manager, prior to finding this thread and there is no thermal management option under there.

    The Dell site does suggest that if there's been a fan failure, then it won't appear. This does tie in with the error I had in the BIOS, but still seems strange to me that I can control it directly.

    Using the fancmd tool, I can now see the fans under HWinfo (but not speedfan), so I may have go at setting that up at somepoint.

    At the moment, things seem to be running OK at 50% constant fan.

    I want to try using the alt switch from tomorrow though, as I've noticed things lag sometimes, but not sure if it's related.

    Thanks again for your assistance, much appreciated.
     
  7. Aaron44126

    Aaron44126 Notebook Prophet

    Reputations:
    779
    Messages:
    4,545
    Likes Received:
    1,398
    Trophy Points:
    231
    In SpeedFan, you have to go to settings and specifically enable some checkbox for Dell fan control. I have some details on how I used to have it set up in the first post in this thread.
    Ok, so it makes sense that if Dell Power Manager won't let you see/adjust the thermal setting, then it wouldn't work with my command-line tool either. The EC/BIOS must be tossing back an error there.
     
  8. LaptopFan99

    LaptopFan99 Newbie

    Reputations:
    0
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    5
    Thank you so much for making this software! It seems like exactly what I need, but unfortunately it is not working for me. I suspect this may be due to my laptop's BIOS version, which was 1.19 and then I updated to 1.20, but it still did not work. Was the software designed for use with an older version of the BIOS?

    I am on a Dell XPS 9560. I've seen an old post on the previous thread where someone said it worked for their 9560 in March 2019. Do you think an older BIOS from around that time would be more likely to work? (I'm just trying to avoid a rollback if it's not necessary)

    Here are more details about my problem:

    When I run DellFanCmd test, the fan control only sometimes works. It always sets the fan speeds properly for fan 1, but for fan 2 it is usually operating at max (~6000 RPM) and the test does not lower this number at all. Sometimes when I run the test, it does lower both fan speeds.

    It seems that the EC takes control again only seconds after running the "ec-disable" or "ec-disable-alt" commands. After running either of these commands, I'm not able to manually set the fan speeds with either DellFanCmd or HWInfo.

    The odd thing is that my system is just idling around 42-47C for both CPU and GPU, so it is very weird that I'm at 6000 RPM at all. I'm on a Balanced profile and Dell Power Manager is set to quiet. It seems that my system runs fan #2 at max speeds for a LONG time recently, like 1 hour or more, while the temps are very low (mid 40s C). Then it randomly decides to slow down to 2500-3000 rpm, with random bursts up/down... so frustrating! Any ideas or suggestions are very welcome. Thanks so much for your hard work on this!
     
  9. Aaron44126

    Aaron44126 Notebook Prophet

    Reputations:
    779
    Messages:
    4,545
    Likes Received:
    1,398
    Trophy Points:
    231
    Support broke with a BIOS update to the XPS 9570, there is some information in this post. Looks like this might be the case for the 9560 as well. I added a note to the supported systems list (second post in this thread).
    http://forum.notebookreview.com/thr...ps-under-windows.805317/page-16#post-10851726

    Unfortunately, I don't really have any idea how a workaround might be produced :-\
    I also don't have a system that I could even run some tests with.

    [Edit]
    Maybe try running in "Optimized" mode instead of "Quiet" mode. On my 7530, "Quiet" is definitely louder than "Optimized" for some reason. This can be measured... In "Optimized" the lowest fan speed is around 2300 and the next highest is around 2700. But in "Quiet", the lowest is also 2300, but then the next one up is 3000, and the system likes to alternate between those under a modest office workload.

    Also try limiting the max CPU speed (I have details about this in the first post — you don't have to use DellFanKeepAlive, just look at my Windows power settings setup). That can help keep the fans under control.
     
    Last edited: Sep 16, 2020
    LaptopFan99 and cfe like this.
  10. LaptopFan99

    LaptopFan99 Newbie

    Reputations:
    0
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    5
    Thanks very much for your reply, and for linking that post. I already limited the CPU to 99% and set the system cooling policy to "passive" rather than "active". I've also been using Throttlestop to disable Turbo and slightly downvolt my processor (since some games were causing periodic overheating). So far it seems that the system is very loud (fan #2 at 6000 rpm) in either Quiet or Optimized modes. It is hard to understand why my system is running the fan so high with my CPU at 47C and even with clock at ~1 GHz (way below the max speed). I feel like the noise issues were not this bad in the past, perhaps the new BIOS versions have made things worse.

    I'm thinking about downgrading to BIOS 1.6, just a little hesitant since it is from back in December 2017. I'll keep experimenting with settings for now, and will post again if I find any solution!

    Update: I found a solution! (for the most part)

    Fan #2 was running at max speed because the Nvidia Control Panel was set to use the "High Performance GPU" (GTX 1050) to run my web browser and some other common applications. It seems this caused the EC to force fan #2 to maximum speeds whenever these applications were open. After changing the settings in Nvidia Control Panel (Manage 3D Settings -> Program Settings) to use Internal Graphics for these programs, my fan speeds reduced to idling at ~3500 RPM in Quiet mode. When changing to Optimized mode, both fans went to ~3800 RPM.

    So my situation is much improved now, as running at 6000 RPM sounded like I was working on a drone rather than a laptop. Anyway, thanks again for your reply. If the fans cause any more trouble I can always roll back the BIOS and give DellFanKeepAlive a try!

    Update #2: It seems that DellFanCmd is working now that I've disabled the "High Performance GPU" for all of my running applications in Nvidia Control Panel, even with the latest bios version 1.20! I was able to reduce my idle fan speeds from 3500 to 2500 rpm, which is very quiet! The system now runs around 57 C, but I think that's a nice trade-off, and it is great to be able to control the fans.
     
    Last edited: Sep 16, 2020

Share This Page