Dell XPS Speed Shift

Discussion in 'Dell XPS and Studio XPS' started by pressing, Oct 8, 2016.

  1. GoNz0

    GoNz0 Notebook Prophet

    Reputations:
    254
    Messages:
    4,063
    Likes Received:
    1,391
    Trophy Points:
    231
    50 & 65% and yeah the 9550 :)
     
    pressing likes this.
  2. Rockstar75

    Rockstar75 Notebook Geek

    Reputations:
    12
    Messages:
    99
    Likes Received:
    71
    Trophy Points:
    26
    On my 9560 the max. Turbo (3,8GHz) is hit with EPP set to 25, 40, 45, 50, 60 and 75 (0%-100% scale). So no problem with the i7 7700HQ.
     
    Last edited: Feb 5, 2017
  3. goodwin_c

    goodwin_c Notebook Enthusiast

    Reputations:
    23
    Messages:
    27
    Likes Received:
    38
    Trophy Points:
    16
    Did you try to enable SST? Is it working as expected?
     
  4. Rockstar75

    Rockstar75 Notebook Geek

    Reputations:
    12
    Messages:
    99
    Likes Received:
    71
    Trophy Points:
    26
    Jipp, I enabled it via BIOS by setting "your" variable to 0x1. It works perfectly. The settings I mentioned above are made via the dropdown menus in the powerplan options of windows. Throttlestops realtime monitoring of the EPP values works fine, too. The only downside will be repeating the process if a new BIOS by Dell shows up (like on the 9550). As I said, you´re the man :)
     
    FluffyDroid likes this.
  5. GoNz0

    GoNz0 Notebook Prophet

    Reputations:
    254
    Messages:
    4,063
    Likes Received:
    1,391
    Trophy Points:
    231
    I thought it followed BIOS updates on the 9550 so it shouldn't need doing again on your 9560?
    Will find out in the next few weeks no doubt :)
     
    pressing, FluffyDroid and Rockstar75 like this.
  6. Rockstar75

    Rockstar75 Notebook Geek

    Reputations:
    12
    Messages:
    99
    Likes Received:
    71
    Trophy Points:
    26
    Ok, then I remember it wrong and thought you had to repeat on the 9550. I had to return mine shortly after enabling it for the refund because of SpeedShift not working ;) and thought somebody wrote the value was overwritten. But it´s true, we´ll find out!
     
    pressing likes this.
  7. Rockstar75

    Rockstar75 Notebook Geek

    Reputations:
    12
    Messages:
    99
    Likes Received:
    71
    Trophy Points:
    26
    So, after being quite happy with SpeedShift enabled via Bios (Thanks goodwin again :)) I would like to give something back to this forum by writing my steps to get it working on my 9560.

    But: Please keep in mind that this method could easily brick your laptop and there will no easy way to get it back working! Everything you do is on your own risk. I`ll just describe how I got there but cannot give any guarantee that it will work with your machines, too!

    The goal is getting SpeedShift enabled in BIOS. You won´t have any "switch" in the GUI, but SpeedShift will be active after every reboot/wake up etc. It´s just enabled and you don´t need any kind of third party software.

    Here you go (after you made up your mind if you really want to do this :)) :

    This is for the XPS 15 9560 only!!! For the 9550 go to http://forum.notebookreview.com/threads/dell-xps-speed-shift.796891/page-5#post-10400525

    1: Format a flash drive with FAT32 filesystem
    2: Download that archive https://www.firewolf.science/wp-content/uploads/2015/04/EFI-shell.zip
    3: Extract the files into /Boot/bootx64.efi on your flash drive
    4: Go into your BIOS by pressing F2 and disable secure boot in BIOS. You could activate it afterwards again.
    5: Boot from flash drive. If it is not booting - go to bios, boot sequence - and add custom entry pointing to that efi file. Then reboot, F12 and choose your custom entry.
    6: If everything works you got UEFI Shell running in a small GRUB environment.
    7: Type
    Code:
    setup_var 0x4BC
    8: It should return the value 0x00. Disregard some little warnings from UEFI regarding the size.
    9: Modify the value by typing
    Code:
    setup_var 0x4BC 0x1
    Disregard the little warnings again.

    10: Now you could control your work by typing
    Code:
    setup_var 0x4BC
    and it should return the value 0x1

    11: Leave UEFI Shell by typing
    Code:
    exit
    Reboot and don´t forget to enable Secure Boot in BIOS again.



    Now SpeedShift is enabled. You could check by running Throttlestop or HWiNFO64. To get rid of this BIOS entry just repeat everything but set the variable back to 0x0.

    Now it´s worth checking unclewebbs post http://forum.notebookreview.com/threads/dell-xps-speed-shift.796891/#post-10361703 to enable the powerplan options in Windows. It works flawlessly (at least for me).

    All the credits for this should go to goodwin as I just took his instructions and put it right for the 9560 (with his help).
     
    Last edited: Feb 6, 2017
    tachlio, 917er, ghegde and 2 others like this.
  8. GoNz0

    GoNz0 Notebook Prophet

    Reputations:
    254
    Messages:
    4,063
    Likes Received:
    1,391
    Trophy Points:
    231
    I stuck up a similar guide on the 9560 page I started with links back to the power plan options as well :)
     
    917er and pressing like this.
  9. Rockstar75

    Rockstar75 Notebook Geek

    Reputations:
    12
    Messages:
    99
    Likes Received:
    71
    Trophy Points:
    26
    :) Damnit, I didn´t see it there. But fortunately we wrote the same :)
     
    GoNz0 and pressing like this.
  10. pressing

    pressing Notebook Deity

    Reputations:
    273
    Messages:
    1,801
    Likes Received:
    894
    Trophy Points:
    131
    Shoot - I forgot about that. I was waiting for someone to confirm it worked on a 9560 before linking it to the guide.

    Regardless, both are now linked to the first page
     
Loading...

Share This Page