Dell XPS 13 CPU Stuck!

Discussion in 'Dell' started by runordie226, Nov 7, 2017.

  1. runordie226

    runordie226 Notebook Enthusiast

    Reputations:
    0
    Messages:
    29
    Likes Received:
    1
    Trophy Points:
    6
    Hi everyone,

    I have a Dell XPS 13 laptop model 9360 with 16gb RAM and 512gb SSD @ Intel I7-7500u with max speed of 2.70GHz and Turbo Boost to 3.50GHz.

    I don't know why the processor maxes out at 2.18GHz and the utilization rate never passes 75% (I checked from Device Manager and also from Speccy)...I already confirmed that Intel Turbo Boost is enabled in my BIOS and my maximum processor state is 100% under Power Options. Furthermore, my BIOS is the most updated @ 2.3.1

    I am very confused and stumped at why this happens..Any suggestions or comments?

    Thanks in advance!
     
  2. Maleko48

    Maleko48 Notebook Enthusiast

    Reputations:
    2
    Messages:
    16
    Likes Received:
    4
    Trophy Points:
    6
    This doesn't exactly sound like your situation, but you could try forcing a hard power cycle like this thread suggests:

    https://www.reddit.com/r/Dell/comments/5uh6wo/fixing_your_dell_xps_cpu_stuck_at_minimum/

    1.) Are you sure your BIOS settings are correct? Have you tried going into your BIOS and triggering the "RESTORE DEFAULT SETTINGS" option?

    2.)
    Also, have you checked your Windows CPU thresholds in your power profile settings to make sure they aren't set arbitrarily low for some reason?

    3.)
    Does it act the same way on Linux or another operating system besides your current one?

    4.) Have you had a BSOD or major thermal event prior to this behavior?

    5.) Are your BIOS up to date?

    6.) Have you tried disabling cores in Windows/BIOS and then re-enabling them in an effort to toggle CPU critical settings to "reset" the settings?
     
    Last edited: Nov 18, 2017 at 8:18 PM
Loading...

Share This Page