Dell XPS 13 2015 Broadwell Infinity Display Owners Thread

Discussion in 'Dell XPS and Studio XPS' started by tassadar898, Jan 16, 2015.

Thread Status:
Not open for further replies.
  1. cipsaz

    cipsaz Notebook Guru

    Reputations:
    0
    Messages:
    71
    Likes Received:
    1
    Trophy Points:
    16
    Good comparison since I drive the Prius, lol.
    Well, the 2500k is four years old, so my question wasn't really out of the water..
    Does the XPS get hot?
     
  2. Dellienware

    Dellienware Workstations & Ultrabooks

    Reputations:
    215
    Messages:
    1,588
    Likes Received:
    61
    Trophy Points:
    66
    Running prime 95 max, I think 85c is about the highest it gets. Temporary throttle under 2.5GHz from time to time to reduce the temps, but that's it.

    Under normal use, just bottom getting warm, no complaints. I don't think anyone ever complained about the temps itself.
     
  3. Derek712

    Derek712 Notebook Virtuoso

    Reputations:
    460
    Messages:
    2,562
    Likes Received:
    992
    Trophy Points:
    131
    He's right, it's subtle but there. What's happening is the Intel drivers have a power saving technology that is always on for some reason. The option to turn it off in the advanced tab of the power option in Intel graphics settings has been removed. It's a feature that I find annoying and usually shut it off right away. It's also the reason I have only been getting 200 nits of brightness even with the laptop plugged in.

    The only way I could tell it was the culprit was to use a colorimeter and run the brightness utility on a separate laptop. In the UEFI settings I was able to measure 300 nits of brightness. I then went back into Windows and got 200 again. Then, while playing with some of the windows, I mysteriously got 300 out of nowhere. Turns out, I had a white window maximized, so it forced the backlight to be on full power. That's where this missing Intel option comes into play. When it's enabled(like it permanently is now) it subtly adjusts the backlight to save power when it thinks you won't notice. The problem is, if you want to edit pictures, you can and will notice. It's also quite obvious in well lit offices that the screen is incredible dim when windows aren't maximized.

    I really hope this option gets re-enabled and it's just the result of a premature Intel 5500 graphics driver. I'm just about to try Windows 10 and see if the option is there. I doubt it but it's worth a shot. I'm mainly trying Windows 10 because I read an article that it will support and standardize three and four finger swiping for the precision touchpads. We shall see..
     
  4. Digital Moe

    Digital Moe Notebook Enthusiast

    Reputations:
    0
    Messages:
    30
    Likes Received:
    0
    Trophy Points:
    15
    Is anyone having issues with IE crashing a lot. I.switched from Chrome due to all the posts on here advising that it is a resource hog and battery drainer. It's strange as I haven't changed any settings in IE ad's am puzzled how an out the box laptop can develop such a issue.
     
  5. Johnmcl7

    Johnmcl7 Notebook Consultant

    Reputations:
    52
    Messages:
    194
    Likes Received:
    7
    Trophy Points:
    31
    No, not the touch version anyway - it's a bit unpredictable when swiping to go back as it frequently shows the right page, then back to the wrong page and just stops at the wrong page which I found a bit irritating but no instability.

    John
     
  6. wigthepolitics

    wigthepolitics Newbie

    Reputations:
    0
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    5
    just ordered the i5, 8gb ram, 128 ssd with one year accident protection.

    i was able to get a 10% discount, $105.90, by becoming a free dell advantage member. and then i did a student discount and saved 2%, $19.06, in addition. so only paid

    [​IMG]
     
  7. Derek712

    Derek712 Notebook Virtuoso

    Reputations:
    460
    Messages:
    2,562
    Likes Received:
    992
    Trophy Points:
    131
    Here's my update on the brightness issue and the trackpad. I've installed Windows 10. It runs well so far but I had to find a special Intel driver to get the graphics set up properly. While it was using the generic display driver, I took the time to check the screen brightness and see if it was caused by the intel driver or not. It's not. I was still getting variable brightness issues ranging from 200-300 nits, depending on how white the screen was and depending on if windows were full screen or not. So it's pretty much a firmware issue at this point, and it may never go away as it's part of the display design.

    As for the trackpad, Windows 10 is supposed to have more options for "Precision touchpads" This release only has one, which allows 3 finger swiping to do two things. Side to side swiping will switch between apps/windows. It's pretty much the same as right edge swiping in Windows 8 except now you can go in both directions. Swiping down with 3 fingers will minimize all windows and swiping back up will restore them. Swipe up again with three fingers and you get to choose between all open apps(VERY similar to OS/X and Asus touchpad drivers which allow quick switching). You also get to add a second or third desktop, which is also similar to OS/X and Linux. It's pretty cool and I can see how it will be useful. There's no option to make 3 finger swipes go forward and backward in web pages, however there is a drop down in the setting, indicating there will be future choices hopefully.

    I think I'll keep Win 10 installed for a few days and see just how far I can take it. I'm a little happier with the trackpad, although scrolling in Chrome still sucks. If anyone has any questions about Win 10 while I have it up, let me know.
     
  8. Derek712

    Derek712 Notebook Virtuoso

    Reputations:
    460
    Messages:
    2,562
    Likes Received:
    992
    Trophy Points:
    131
    For a smoother trackpad experience in Chrome:

    I installed Chromium Wheel Smooth Scroller. It made the trackpad operate a lot better in Chrome, although there is still some lag nad my settings need a little more tweaking. Here are my settings:
    In mouse settings: Make sure wheel vertical scroll is 3 lines
    In Chromium Wheel Smooth Scroller settings:
    -Step size 40
    -Smoothness(Forepart) 3.77(or close to it)
    -Smoothness 87.16
    -Acceleration Sensitivity 28

    I also set the touchpad delay to no delay in the touchpad settings. This is a double edged sword because it makes accidental taps easier, which can be frustrating when typing. Also note that I'm using the QHD screen, which will act differently than FHD I imagine.
     
  9. huai

    huai Notebook Consultant

    Reputations:
    5
    Messages:
    238
    Likes Received:
    2
    Trophy Points:
    31
    What are the 10% and 5% discounts?
     
  10. bamaster

    bamaster Notebook Consultant

    Reputations:
    164
    Messages:
    237
    Likes Received:
    8
    Trophy Points:
    31

    I'd also consider some performance tweaks, like these
    http://digiwonk.wonderhowto.com/how...le-chrome-blazing-fast-your-computer-0155989/

    It helps in some areas, for sure!
     
Loading...
Thread Status:
Not open for further replies.

Share This Page