Dell Precision 7540 and 7740 Owner's Thread

Discussion in 'Dell Latitude, Vostro, and Precision' started by djdigitalhi, Aug 13, 2019.

  1. Ionising_Radiation

    Ionising_Radiation ?v = ve*ln(m0/m1)

    Reputations:
    690
    Messages:
    2,929
    Likes Received:
    2,464
    Trophy Points:
    181
    This is the key, and more detail is needed here—exactly where does the boot process halt? Does your notebook enter the Windows recovery environment, or does it emit some other error that appears to be firmware-level (white text on top left on black screen kind of thing)?
     
  2. Aaron44126

    Aaron44126 Notebook Prophet

    Reputations:
    774
    Messages:
    4,448
    Likes Received:
    1,357
    Trophy Points:
    231
    1. With both devices connected/enabled, press F12 at boot time (the Dell logo) to get to the boot device selection menu. If you specifically select the SSD, does it boot fine?
    2. Instead of formatting the HDD, delete all partitions on it. You should do this with bootable USB media (gparted on Linux works, or you can use diskpart from a bootable Windows install media command prompt). Removing the EFI partition is key here so that the BIOS doesn't see this as a bootable drive. After the drive is empty with no partitions and you are able to boot Windows normally from the SSD, you can use Disk Management in Windows to create a new partition and format it.
     
  3. jack574

    jack574 Notebook Consultant

    Reputations:
    10
    Messages:
    209
    Likes Received:
    47
    Trophy Points:
    41
    My 7740 gets REALLY hot around the vents on the side of the casing. So hot it hurts to keep my hand there for more than a few seconds. It does it when the computer doesn't seem to be doing a lot - just been on a Zoom call with the CPU running at about 15%.

    i9-9980HK
    RTX4000
    4 x M.2 drives
    128GB RAM

    Now I've finished the call, the CPU's sitting at around 4% and the PC is still hot, but probably not as hot as it was during the call...

    Is this normal?

    Thanks
     
  4. TunaDog

    TunaDog Notebook Enthusiast

    Reputations:
    0
    Messages:
    27
    Likes Received:
    2
    Trophy Points:
    6
    I did the same on Sunday. Well, just one SN750 :) But I haven't manually installed a single driver, just what comes from install media and whatever Windows pulls down on its own. I might install additional drivers after I compare Windows driver versions to what Dell/NVidia has.

    I have to say that I really appreciate the ability to disable a drive in the BIOS. I still have the original boot drive installed but disabled, and it's nice to be able to toggle the visibility of the two drives to boot into either "new" or "old" system.
     
  5. htfan

    htfan Notebook Guru

    Reputations:
    1
    Messages:
    51
    Likes Received:
    1
    Trophy Points:
    16
    Yes, it does enter Windows Recovery - after trying to boot a couple times and automatically restarting in between tries.
     
  6. htfan

    htfan Notebook Guru

    Reputations:
    1
    Messages:
    51
    Likes Received:
    1
    Trophy Points:
    16
    1. Before I formatted the HDD - If I used the F12 one-time boot menu and selected the SSD the system would boot from the HDD anyway, isn't that strange?
    After I formatted the HDD - using the boot menu and selecting the SSD, the system won't boot (this with both drives enabled). It enters Windows Recovery after a couple tries.

    2. I used gparted from bootable USB and deleted all partitions (that it could see) on the HDD then created a new primary partition using the whole disk and formatted it ntfs.
    After this, with both drives enabled, the system does not boot - it enters Windows recovery. The only way I can get the system to boot is to disable the HDD.

    What the heck is going on here? Frustrating...
     
    Last edited: Jun 2, 2020
  7. Aaron44126

    Aaron44126 Notebook Prophet

    Reputations:
    774
    Messages:
    4,448
    Likes Received:
    1,357
    Trophy Points:
    231
    So strange.
    Next suggestion:
    With both drives connected/enabled, boot Windows install/recovery media and get to a command prompt. Use the command:
    bootrec /scanos
    This will display a list of Windows installations it was able to find (there should only be one -- STOP if this is not the case).

    Then use the command:
    bootrec /fixmbr
    This should re-write the EFI boot loader and point it to the right partition.
     
    htfan likes this.
  8. htfan

    htfan Notebook Guru

    Reputations:
    1
    Messages:
    51
    Likes Received:
    1
    Trophy Points:
    16
    Thanks, will try that as soon as I'm back in front of the system!
     
  9. coxhaus

    coxhaus Newbie

    Reputations:
    0
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    5
    I removed my old hard drive in my 7740 to help keep the heat down when I installed my 2 WD black 750 M2 NVMe drives. The WD drives are so much quicker than my old hard drive I would not want to use it again. I feel a little more warm on the part above the keyboard but barely warm just more than the hard drive.

    Installing Windows 10 2004 was easy. I just built a USB drive and downloaded the latest Windows 10 on it.
    I then set the NVMe drives in bios and set secure boot. I then booted pushing the F12 key and told it to boot off the USB. Windows 10 installed fine with all the right drivers.
     
  10. htfan

    htfan Notebook Guru

    Reputations:
    1
    Messages:
    51
    Likes Received:
    1
    Trophy Points:
    16
    Ok, finally did this. Windows was found and bootrec /fixmbr completed without problem.

    Still didn't boot, at first.
    'Your PC ran into a problem and needs to restart. We'll restart for you,' with stopcode INACCESSIBLE_BOOT_DEVICE. Same as before, I Think - this time I took pictures :D.
    After a couple tries it next booted to Dell SupportAssist OS recovery (instead of Windows Recovery as before) and said it needed to do a repair. It checked three things: Partition Table, Boot files, and Windows Health. Boot files failed, the other two passed. It asked to try a second time - same results. Next it said 'Repair failed but don't worry' and offered Reset Options. I decided not to reset and clicked Windows Recovery - Next thing I know Windows booted from the SSD with the HDD also available. Tried a couple reboots and so far so good I guess. In Disk Management the HDD is Disk 0 and the SSD is Disk 1, don't know if that's normal? Hopefully things are fine now.

    BTW, I had no idea how long it took to make a Windows Recovery Drive. The first usb stick i tried failed an hour and a half into the process, the second completed the process after two hours. :( Wow
     
Loading...

Share This Page