Dell Precision 5510 Owner's Lounge

Discussion in 'Dell Latitude, Vostro, and Precision' started by Bokeh, Nov 24, 2015.

  1. Aaron44126

    Aaron44126 Notebook Virtuoso

    Reputations:
    578
    Messages:
    2,404
    Likes Received:
    398
    Trophy Points:
    101
    I've also been having USB issues on and off with the TB16 dock attached to a 7510. Sometimes it works fine (for days, weeks at a time) and then sometimes it goes and acts weird. In the end, though, I removed all USB connections from the TB16 dock and hooking them up to the ePort dock instead. I don't have any issues with displays running through the dock.

    We do have five or six 5510's with TB16 deployed at my organization, though, and I haven't heard any recent complaints about them. So, it seems like there are cases where it works fine.

    Might be worth just grabbing a USB hub to hook your USB stuff up to, and then plugging that directly into the laptop... Two things to connect instead of one, but not that bad.
     
    John Ratsey likes this.
  2. Strichards

    Strichards Notebook Enthusiast

    Reputations:
    0
    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    5
  3. John Ratsey

    John Ratsey Moderately inquisitive Super Moderator

    Reputations:
    6,819
    Messages:
    28,612
    Likes Received:
    1,584
    Trophy Points:
    581
    Debugging of the BIOS continues: BIOS 1.4.0 dated 25th September 2017:

    Fixes & Enhancements
    1. Fixes system defense with wireless parameter will cause ME failure
    2. System stability enhancements
    3. To prevent user update ME Firmware to blacklist 11.6 ME firmware
    4. Correct error message in Excalibur
    5. Fix Bitlocker issue on Win7 ultimate/enterprise

    John
     
Loading...

Share This Page