Dell 1720 - Slow Internet and sluggish performance

Discussion in 'Dell' started by irfands, Sep 22, 2007.

Thread Status:
Not open for further replies.
  1. irfands

    irfands Newbie

    Reputations:
    0
    Joined:
    Sep 20, 2007
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    5
    Hey everyone,

    just got my 1720 3 days back. Love the screen and the build of the laptop. I got a C2D 1.8 GHz with 2 GB RAM, 8600m GT.

    FIrst thing i did when i got it was to do a clean install of vista home premium (I followed these instructions - http://forum.notebookreview.com/showthread.php?t=157838)

    Well, i'm having 2 problems now

    1. Internet is acting weird. I have a 6 Mbps connection and download works fine. I checked my sped at www.speedtest.net and the download speed is fine but upload is much slower than my desktop, abt 300 kbps which is almost half of what it usually is. Download is around 6000 kbps. Problem is that pages take long to load up.but i dont have any problems when playing warrock online, no lag at all.

    2. also, the boot up takes pretty long, almost 2 min, and overall vista seems slugigish. But games work pretty nice. FAR CRY at max settings works perfectly. and FEAR at everything high except AA (2x), and shadows off works nice too, abt 40-50 fps. but vista itself and other applications seem slow.

    hope you guys have some suggestions. thanks
     
  2. 000111

    000111 Atari Master

    Reputations:
    125
    Joined:
    Aug 8, 2007
    Messages:
    804
    Likes Received:
    2
    Trophy Points:
    31

Thread Status:
Not open for further replies.

Share This Page