Dead Video card? P755DM-3

Discussion in 'Sager and Clevo' started by EKcore, Apr 13, 2019.

Tags:
  1. EKcore

    EKcore Notebook Enthusiast

    Reputations:
    0
    Messages:
    29
    Likes Received:
    4
    Trophy Points:
    6
    The screen doesn't turn on when powering on the laptop, there is also no signal when plug in a TV through HDMI. The laptop boots(I think) Then after about 2 mins the fans go to top speed the same when the system crashes. Is there a way to use the onboard graphics of the 6700k?

    Anyone have the same issues or advice to troubleshoot?

    If it is a dead card I will be parting out the system as I cannot afford to replace the card, New systems are comparable price to a 1070 card.
     
  2. Dr. AMK

    Dr. AMK Living with Hope

    Reputations:
    2,792
    Messages:
    1,860
    Likes Received:
    3,939
    Trophy Points:
    281
    Did you try to reset your BIOS/ CPU/ RAM? in not you have to try.
     
    Vasudev likes this.
  3. EKcore

    EKcore Notebook Enthusiast

    Reputations:
    0
    Messages:
    29
    Likes Received:
    4
    Trophy Points:
    6
    Is that Removing the CMOS battery?
     
  4. Dr. AMK

    Dr. AMK Living with Hope

    Reputations:
    2,792
    Messages:
    1,860
    Likes Received:
    3,939
    Trophy Points:
    281
  5. symy17

    symy17 Notebook Enthusiast

    Reputations:
    0
    Messages:
    17
    Likes Received:
    0
    Trophy Points:
    5
    What graphics card u have?

    Enviado do meu MI 8 através do Tapatalk
     
  6. EKcore

    EKcore Notebook Enthusiast

    Reputations:
    0
    Messages:
    29
    Likes Received:
    4
    Trophy Points:
    6
    1070
     
  7. Meaker@Sager

    Meaker@Sager Company Representative

    Reputations:
    8,108
    Messages:
    51,291
    Likes Received:
    14,625
    Trophy Points:
    931
    The IGP is not even powered so no way of using it.
     
Loading...

Share This Page