Dead P370EM; I really Need Help!

Discussion in 'Sager and Clevo' started by metlmania1, Dec 18, 2020.

  1. metlmania1

    metlmania1 Notebook Enthusiast

    Reputations:
    0
    Messages:
    28
    Likes Received:
    4
    Trophy Points:
    6
    I really need some help..

    I recently purchased a p370em very cheap on ebay and when i try to power it all it gives me is a yellow light???

    THAT'S ALL IT DOES!
    A solid yellow light... no matter what..

    I have removed EVERYTHING from the board and it still gives me the yellow light so i know it still works i just for the life of me cannot figure out how to make it POST...

    Can ANYONE help me please???
    I have tried everything...Literally... i even took my working gtx 970m i have in my currently working p370EM and still nothing just a yellow light!??

    It's making me insane lol

    Thank You!
     
    Last edited: Dec 18, 2020
  2. metlmania1

    metlmania1 Notebook Enthusiast

    Reputations:
    0
    Messages:
    28
    Likes Received:
    4
    Trophy Points:
    6

    Also, when i press the power button nothing happens..
     
  3. Meaker@Sager

    Meaker@Sager Company Representative

    Reputations:
    9,076
    Messages:
    56,268
    Likes Received:
    16,707
    Trophy Points:
    931
    Start removing bits (GPU and CPU) and see if you get a different response.

    However I would return it since it's a non functioning machine.
     
  4. metlmania1

    metlmania1 Notebook Enthusiast

    Reputations:
    0
    Messages:
    28
    Likes Received:
    4
    Trophy Points:
    6
    I have tried everything and i don't want to return it i really want to revive it..
    I tried placing my cpu i have in there and another gpu but still nothing.. =/

    Is there anything that can be done maybe??

    Because from what i know it is a working board..
     
  5. metlmania1

    metlmania1 Notebook Enthusiast

    Reputations:
    0
    Messages:
    28
    Likes Received:
    4
    Trophy Points:
    6
    Also, is there a certain sequence in which i should follow to get it to work??

    For example removing the gpu or cpu??
     
  6. Meaker@Sager

    Meaker@Sager Company Representative

    Reputations:
    9,076
    Messages:
    56,268
    Likes Received:
    16,707
    Trophy Points:
    931
    Just remove one bit at a time and see if the behaviour changes at all.
     
  7. metlmania1

    metlmania1 Notebook Enthusiast

    Reputations:
    0
    Messages:
    28
    Likes Received:
    4
    Trophy Points:
    6
    Hi and thanks for getting in touch,
    I have but to no avail... =/
    I even took apart everything off that was ever connected to the board and still nothing..

    Strange thing is the board still shows yellow power light????
     
    Last edited: Dec 19, 2020
  8. Meaker@Sager

    Meaker@Sager Company Representative

    Reputations:
    9,076
    Messages:
    56,268
    Likes Received:
    16,707
    Trophy Points:
    931
    Could be the switch, tried shorting the contacts?
     
  9. metlmania1

    metlmania1 Notebook Enthusiast

    Reputations:
    0
    Messages:
    28
    Likes Received:
    4
    Trophy Points:
    6
    How do i do that?

    Thanks again!
     
  10. Meaker@Sager

    Meaker@Sager Company Representative

    Reputations:
    9,076
    Messages:
    56,268
    Likes Received:
    16,707
    Trophy Points:
    931
    Need to find the pins that the button on the PCB go to.
     
Loading...

Share This Page