Dead m15x "r2"

Discussion in 'Alienware M15x' started by Shaden, Mar 9, 2018.

  1. Shaden

    Shaden Notebook Deity

    Reputations:
    827
    Messages:
    1,333
    Likes Received:
    7
    Trophy Points:
    56
    hey all, so I have no idea what's going on here.

    Turned off my m15x, put it in my bag, took it to work. Pulled it out and hit the power .... nothing.

    Thought, hrm, wonder if it didn't fully shut off or something, drained the battery, or maybe battery wasn't charging when plugged in.

    Came home, plugged it in, nothing. Power button, nothing.

    I followed steps below, Disconnected battery (so stupid you have to open the damn thing up to get to the battery) held power button down for 20. Plugged it in. Nothing. reconnected battery, hit power. nothing. Plugged it in with battery connected, nothing. Checked to make sure the power button cable was properly in, it is ...

    Any suggestions ? Should I order a new battery or DC jack and try that ?

    I have been using it with the AGA with my 1080ti and I have been loving the system, don't want to waste the money on buying something new after getting the 1080ti.

    Thanks all ...
     
  2. Raidriar

    Raidriar Notebook Prophet

    Reputations:
    1,121
    Messages:
    4,530
    Likes Received:
    2,848
    Trophy Points:
    231
    King of Interns and ssj92 like this.
  3. Shaden

    Shaden Notebook Deity

    Reputations:
    827
    Messages:
    1,333
    Likes Received:
    7
    Trophy Points:
    56
Loading...

Share This Page