Darksiders III - fluctuating performance

Discussion in 'Gaming (Software and Graphics Cards)' started by Deks, Nov 30, 2018.

  1. Deks

    Deks Notebook Prophet

    Reputations:
    1,105
    Messages:
    4,654
    Likes Received:
    1,834
    Trophy Points:
    231
    Hey guys

    Last night I installed Darksiders III on my GL702ZC, but the game's performance fluctuates like mad regardless of the settings used (maxed out, high, low, foliage or shadow reduction, etc.).
    I noticed my GPU core and memory clocks oscillate wildly from their resting state to maxed out state every second (up and down, up and down, up and down, every single second - or half a second).
    This is most noticeable in open-space areas, or enclosed areas with bosses... in closed space it seems to run normal (if you're in a tunnel, etc.)... but 99% of the game causes my GPU clocks to fluctuate wildly.

    Darksiders III is the only game on my system that behaves like this for unknown reason (it could be because the game might favour NV hardware).

    I tried running it with and without an undervolt to the GPU and CPU, I tried re-installing the game, I tried a clean driver install (previous version and latest)....
    Nothing changes.
    The game causes my GPU clocks (core and VRAM) to jump up and down like this: /\/\/\/\/\/\/\/\/\/\/\/\ ..... etc (you get the idea).
     
  2. saturnotaku

    saturnotaku Notebook Nobel Laureate

    Reputations:
    3,997
    Messages:
    7,366
    Likes Received:
    2,898
    Trophy Points:
    331
    Can you disable SMT and run the game only on the eight physical cores? I know you said your problem is with the GPU, but sometimes high core/thread counts can be a cause.
     
  3. Deks

    Deks Notebook Prophet

    Reputations:
    1,105
    Messages:
    4,654
    Likes Received:
    1,834
    Trophy Points:
    231
    My BIOS is locked, so I cannot affect that.
    Even Ryzen Master tool doesn't have the option to disable Simultaneous Multithreading (its greyed out).

    But, I'm not sure how SMT would affect the GPU.
    I know the game is demanding on a single core, but stock Ryzen 1700 (with single core boosting to 3.7GhZ) should be more than enough for it.

    Also, wouldn't this be more a driver related problem?
    Then again, I was looking at other people's youtube videos of Darksiders III playthrough on rx 580 (mine is also desktop hardware, just downclocked to 1077 MhZ - and before you mention that could be the problem, nope... those clocks should be more than adequate).
     
  4. yrekabakery

    yrekabakery Notebook Virtuoso

    Reputations:
    790
    Messages:
    2,459
    Likes Received:
    2,324
    Trophy Points:
    181
    Try setting process affinity for the game's executable to every other core in the Task Manager or using Process Lasso. I believe this is a way to effectively disable HT/SMT for an application. This game is single-thread heavy, so HT/SMT actually reduces performance on CPUs with 4 or more cores.

    [​IMG]
     
    jaug1337 and Falkentyne like this.
  5. Deks

    Deks Notebook Prophet

    Reputations:
    1,105
    Messages:
    4,654
    Likes Received:
    1,834
    Trophy Points:
    231
    EDIT (final) :

    I have been able to locate affinity settings in Task Manager.
    Didn't know I had to click 'details' for that to show up.
    I set the game's process affinity to 4 cores... and that seemed to have mostly solved the problem.
    However, the game's performance leaves something to be desired as it still 'breaks' on occasion (namely, its not consistent) and my RX 580 should be able to play it smoothly at 'high' settings without a sweat at least (I've seen open space areas in the game that run perfectly smooth even with enemies running around).
    And it seems as if the game's affinity in task manager keeps changing (it gets reset to Core 0 mid-gaming for some reason - any way to set it up before it loads?).

    I think the game might suffer from bad coding issues (considering the steps I need to take to get 'reasonable' performance out of it).
    Might be better if I wait for a potential patch to address the problems (if it does), or AMD to release drivers?

    The fact Asus locked pretty much everything up in GL702ZC doesn't help... but I don't think my downclocked GPU is the issue as it should have more than enough power to run the game smoothly.

    I'll try a few more things to see if I can improve performance.
     
    Last edited: Dec 5, 2018
  6. Deks

    Deks Notebook Prophet

    Reputations:
    1,105
    Messages:
    4,654
    Likes Received:
    1,834
    Trophy Points:
    231
    Spoke too soon... while limiting the game to 3 or 4 cores helps, the gpu clocks still fluctuate.
    I tried limiting it to 2 cores, but that causes issues...
     

Share This Page