D900F/NP9280 Freezing, Flashing, HELP!!!

Discussion in 'Sager and Clevo' started by FlameHaze, Jul 31, 2016.

  1. FlameHaze

    FlameHaze Notebook Geek

    Reputations:
    5
    Messages:
    95
    Likes Received:
    9
    Trophy Points:
    16
    Making a separate reply because this doesn't look right... I spent hours on google... Isn't there supposed to be a part here, the solder joints look busted and on google, all the D900F's have one... 1470134205770768296688.jpg
     
  2. sirana

    sirana Notebook Deity

    Reputations:
    267
    Messages:
    737
    Likes Received:
    329
    Trophy Points:
    76
    I think you could try both cards, given that the 680M also works. Just make sure you have the latest BIOS *and* EC flashed. I don't think you need to flash a vbios though, modifying the driver inf should be enough! I could help you with that, also wrote a quick guide on that. As long as you don't stress it in games it should not exceed your PSU capacity I guess!

    Also, for that soldered connection I'm not sure how it's supposed to look like as my x7200 is slightly different.

    Edit: According to Eurocom you just need the latest bios for the 680m to work, so this counts probably also for the 580m, while I couldn't find information on people who did that before (in contrast to quite a few people who ran a 680M).
     
    Last edited: Aug 2, 2016
  3. FlameHaze

    FlameHaze Notebook Geek

    Reputations:
    5
    Messages:
    95
    Likes Received:
    9
    Trophy Points:
    16
    I have the latest bios and EC from Prema, but I have only the 75W heatsink.

    Also I can mod the driver inf :) its how I made it work in the other laptop.

    I do have a uhhh... Problem.... My D900F is... Not working now. I took the 285m out of my other laptop, popped it back in the D900F, pressed power and now I have no image... Is it dead now? I can't even think of what went wrong. I reseated the ram, and CPU, and GPU with Jo change, no beeps, no flashing lights, just the Bluetooth/WiFi light is lit orange(Bluetooth)
     
  4. sirana

    sirana Notebook Deity

    Reputations:
    267
    Messages:
    737
    Likes Received:
    329
    Trophy Points:
    76
    Does the card still boot in your other laptop?

    When my 680m was 100% dead it also showed me a black screen without beeps.
     
  5. Meaker@Sager

    Meaker@Sager Company Representative

    Reputations:
    6,889
    Messages:
    42,710
    Likes Received:
    10,489
    Trophy Points:
    931
    It could be a static charge or a solder joint finally giving way, it's hard to say.
     
  6. FlameHaze

    FlameHaze Notebook Geek

    Reputations:
    5
    Messages:
    95
    Likes Received:
    9
    Trophy Points:
    16
    Card posts in the other laptop perfectly fine

    The D900F doesn't react to anything, just power light comes on, fans go to normal speed, FN+1 still maxes the fans, but it never posts, the CPU isn't even producing heat, popped the W3520 back in, no change, swapped ram, no change, idk what else to test... I think the main board died... I smell burned electronics now too... I think something shorted

    Prior to all of this happening, my D900F wouldn't power up on battery unless I held power down, pushing power momentarily would cause the powerlight to come on for a 1/10th of a second and then turn back off... I assume something shorted or something on the board... I mean I kinda have to replace it now right?

    I only see eurocom carrying it for a nice affordable 595 USD... Ouch...
     
  7. sirana

    sirana Notebook Deity

    Reputations:
    267
    Messages:
    737
    Likes Received:
    329
    Trophy Points:
    76
    Bake/reflow it, no harm done if it's already dead, you can't make it 'deader'. Preheat an oven to 385F (close to 200°C) and leave the board in there for around 8-10 minutes, remove all plastic before and mount the card on some crumbled tin foil pillars. I believe in your baking skills ;)

    All is not lost yet.
     
    Last edited: Aug 3, 2016
  8. FlameHaze

    FlameHaze Notebook Geek

    Reputations:
    5
    Messages:
    95
    Likes Received:
    9
    Trophy Points:
    16
    I've reflowed before, I'm doing it as we speak, will post results when done!!!

    I was supposed to add olive oil and some salt n basil leaves right?
     
  9. FlameHaze

    FlameHaze Notebook Geek

    Reputations:
    5
    Messages:
    95
    Likes Received:
    9
    Trophy Points:
    16
    Baked the board, no changes at all. System won't post. I'm digging my mPCI-E post card out maybe it will say something but I am 100% sure the motherboard is shot... Now need help sourcing one, I was gonna buy it from eurocom seeing they are the only ones carrying it but the price is unreal...
     
  10. sirana

    sirana Notebook Deity

    Reputations:
    267
    Messages:
    737
    Likes Received:
    329
    Trophy Points:
    76
    For that outrageous price it's already worth saving for a new Pascal based Laptop... Sorry you couldn't make it work, maybe try again? Some said it took them three turns of baking/reflowing, you might try turning the board upside down.
     
Loading...

Share This Page