1. You may have noticed things look a little different around here - we've switched to a new platform (XenForo) and have some new forum styles and features. This how-to guide will help you find your way around. If you find anything that looks strange, post it in this thread.

Cursor jumping around

Discussion in 'Averatec' started by BaroqueJim, Sep 25, 2005.

  1. BaroqueJim

    BaroqueJim Notebook Geek

    Reputations:
    46
    Messages:
    80
    Likes Received:
    0
    Trophy Points:
    15
    Has anyone else experienced this? You're typing and suddenly the cursor jumps to another position, usually a few lines above and all of a sudden you're typing in between lines you've already written.

    Someone told me it has to do with my Logitech mouse and XP's generic drivers, but I just updated them with Logitechs own and it still happens. It's definitely not me touching the touchpad while typing as someone else suggested - I don't touch it and besides that wouldn't move the cursor.
     
  2. Brian

    Brian Working at 486 Speed NBR Reviewer

    Reputations:
    750
    Messages:
    8,970
    Likes Received:
    0
    Trophy Points:
    205
    I've seen that before and honestly, I don't know if there's a solution. It's probably just a buggy driver or its interaction with your machine. How often does it happen?
     
  3. Chutsman

    Chutsman Notebook Evangelist

    Reputations:
    6
    Messages:
    609
    Likes Received:
    1
    Trophy Points:
    31
    Could be that the palm of your hand is touching the touch pad as you type. Try covering the touchpad with something like a credit card and see if it helps.
     
  4. BaroqueJim

    BaroqueJim Notebook Geek

    Reputations:
    46
    Messages:
    80
    Likes Received:
    0
    Trophy Points:
    15
    It happens very often. I really don't think it's the touchpad, since that moves the mouse pointer around and not the text cursor. And the position of my hands when I type means I don't really ever touch the touchpad.

    Someone told me it was because I was using a Logitech optical mouse with XP's generic mouse driver, and suggested I install the proper Logitech ones. No luck, it still happens. I did find some mention of it in relation to Logitech mice though.
     
  5. lowlymarine

    lowlymarine Notebook Deity

    Reputations:
    401
    Messages:
    1,425
    Likes Received:
    0
    Trophy Points:
    55
    My 3270 did that on occasion under Windows, but it does it all the time under Linux. I think it is related to the touchpad...if I disable the touchpad, it stops happening.
     
  6. Chutsman

    Chutsman Notebook Evangelist

    Reputations:
    6
    Messages:
    609
    Likes Received:
    1
    Trophy Points:
    31
    Well, let's try the easy things first. Remove the Logitech mouse and see if the problem goes away.
     
  7. jedisolo

    jedisolo Notebook Deity

    Reputations:
    155
    Messages:
    897
    Likes Received:
    0
    Trophy Points:
    30
    You can disable the touch pad and your wandering curser problem will go away.
    Here's how to disable it:
    1. go to control panel
    2. click on mouse icon
    3. go to the device settings tab and disable the touchpad.
    It worked for me and now I don't have the wondering curser problem.
    -Andrew
     
  8. ezxit

    ezxit Notebook Enthusiast

    Reputations:
    0
    Messages:
    11
    Likes Received:
    0
    Trophy Points:
    5
    under the mouse pad settings you can check a box to HIDE the curser while typing .. when finished typing just touch the pad ..also you can check box that = hit ctrl and the curser will return ...
     
  9. w0kie

    w0kie Newbie

    Reputations:
    0
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    5
    My Dell Inspiron 600m with XP home has two mouse hardware listings. One called HID compliant mouse which appears to be my Dell external optical mouse and the other is called PS/2 compatible mouse. I can disable the HID compliant (external) mouse but I can't find anywhere in the Mouse control panel where to disable the (presumed internal) mouse pad.
     
  10. w0kie

    w0kie Newbie

    Reputations:
    0
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    5
    Never mind. I rebooted my Dell using the F2 key for setup. Then Alt-P until I found the mouse toggle. There I switched to "Serial" for my USB only mouse and saved.

    Finally the cursed mouse pad is turned OFF. :D
     
  11. BaroqueJim

    BaroqueJim Notebook Geek

    Reputations:
    46
    Messages:
    80
    Likes Received:
    0
    Trophy Points:
    15
    I too have a PS/1 compliant mouse or something listed along with the USB mouse. I have no idea what it means.

    Funny thing is, since I installed my Logitech mouse drivers, I no longer have any touchpad options anywhere. The Logitech software basically took over the whole "mouse" options.
     
  12. peterbra

    peterbra Newbie

    Reputations:
    0
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    5
    I have the same problem with my cursor. I'm using a 2 year old SONY Vaio notebook running XP. No matter which app I am using I can be typing when the cursor will switch up to a previous place inserting the text I am typing. very frustrating to say the least! It makes me want to avoid the SONY and use my Dell PC which has it's own unique problems as well. They all have one problem or another!! :eek:
    I have carefully watched and my hand is not near the touchpad and it happens with or without my usb MOUSE plugged in.

    If anyone can help me I will foreber be in debted to you.
    :confused:
    Thanks Peter my email is peterbra@optonline.net
     
  13. nkb

    nkb Newbie

    Reputations:
    0
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    5
    I'm so glad to hear others are having the same problem - this is driving me crazy. I didn't have this problem with my Thinkpad 40, but my 2 month old Averatec, which I love, is often rendered useless because of this stupid cursor. I've uninstalled the optical mouse - still the same problem, in all applications, different times, jumping erratic lines/spaces. I've tried a USB mouse, I've tried w/out any mouse - all to no avail. I agree - it s NOT accidental touching of the pad...PLEASE PLEASE HELP!!!! (I take it this isn't an AVERATEC isolated problem? I'm about to throw my notebook out the window!)
     
  14. Susan

    Susan Notebook Guru

    Reputations:
    26
    Messages:
    67
    Likes Received:
    0
    Trophy Points:
    15
    Averatec repair finally replaced the motherboard and toudhpad on my 1020. The cursor is very stable now. All functions are there as far as if know.

    Still would stay far away from this brand. too many issues.

    susan
     
  15. joshyjosh

    joshyjosh Notebook Guru

    Reputations:
    1
    Messages:
    68
    Likes Received:
    0
    Trophy Points:
    15
    hate to bump an old thread but my sisters laptop does the same exact thing, and I tried everything and NOTHING fixes it, its a dell e1505, and she is not touching the touch pad by accident. has anyone found a solution other then having the internal parts replaced?
     
  16. Gophn

    Gophn NBR Resident Assistant

    Reputations:
    4,843
    Messages:
    15,710
    Likes Received:
    0
    Trophy Points:
    455
    Ahem....

    If your cursor is randomly jumping :
    (especially if you are using an optical mouse)
    - Look at your mouse pad
    --- Does it have the color red on it?
    ------ RED will cause the optical mouse to have inaccurate reading, which will cause the "jumps"
    ------ RED is the standard spectrum for most optical mouses.
    - Go use something else as mousepad WITHOUT red on it.

    Its is extremely improbable that a touchpad would cause this problem.

    -Gophn
     
  17. stamar

    stamar Notebook Prophet

    Reputations:
    443
    Messages:
    5,802
    Likes Received:
    1
    Trophy Points:
    206
    this is a mousepad setting.

    I recently revisited this problem when i switched to vista and i used the microsoft touchpad drivers.

    Find the drivers from the manufacturer of your touchpad and likely they will have the settings correct so a small brush doesnt change your cursor position.

    Do you have a clean install of your os? Thats likely the problem
     
  18. ISleepy1

    ISleepy1 Notebook Enthusiast

    Reputations:
    0
    Messages:
    11
    Likes Received:
    0
    Trophy Points:
    5
  19. kenwinston caine

    kenwinston caine Notebook Enthusiast

    Reputations:
    0
    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    5
    TouchFreeze is no longer at that link. I found it here:

    http://code.google.com/p/touchfreeze/downloads/list

    This download solved it for me on two notebooks.

    Hope that helps.

    What it does is disable the touchpad while you are typing. I type at about 200 wpm and this was driving me crazy until I found Touchfreeze. Soon as you quit tapping keys, the touchpad works fine.

    Best,
    kwc
     
  20. pjdevitt67

    pjdevitt67 Newbie

    Reputations:
    0
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    5
    The TouchFreeze utility also worked for me. I had the same problem described in thread - cursor randomly jumping while typing. While several people have mentioned they do not think it is a touchpad problem because they are not "touching" the pad while typing, I recommend trying this utility anyway -- it definitely fixed the problem for me, and I didn't think I was brushing or touching my touchpad either. I forwarded it to a friend who has had the same problem for 6+ months, it also fixed it for him. He runs Ubuntu and had to make a few changes to utility, but it worked.

    Thanks kwc for TouchFreeze link:
    http://code.google.com/p/touchfreeze/downloads/list
     

Share This Page