crysis stuttering

Discussion in 'Sager and Clevo' started by ARGH, Apr 25, 2008.

Thread Status:
Not open for further replies.
  1. Shyster1

    Shyster1 Lazy as the Day is Long

    Reputations:
    6,926
    Messages:
    8,179
    Likes Received:
    0
    Trophy Points:
    205
    Did you find any good white-papers on the subject? I've found papers that discuss issues related to the additional latency created on current multiple-core systems, but nothing that expressly discusses GPU stuttering, or micro-stuttering.

    However, it will be interesting to see if the next generation of Intel quadcores (not the Q9xxx CPUs, but the ones to come in 2009) which will have Intel's new Quickpath point-to-point communications system (the replacement for the current FSB, which has grown whiskers on its whiskers).
     
  2. eleron911

    eleron911 HighSpeedFreak

    Reputations:
    3,886
    Messages:
    11,105
    Likes Received:
    7
    Trophy Points:
    456
    Your problem has a name, and it`s called CRYSIS.
    It stutters even on tri SLI 8800M GTXs...
     
  3. ARGH

    ARGH Notebook Deity

    Reputations:
    391
    Messages:
    1,864
    Likes Received:
    15
    Trophy Points:
    56
    oh look everyone, i brought an old thread back from the dead! lol....j/k

    seriously though, i believe i have found the culprit to the sli micro stutter with crysis. it is because the 512 megs of video ram is not enough to run the game in all high or very high settings as the video ram gets saturated and stutters. from my testing you need the 1 gig card to avoid micro stutter. i will simply post my reply from another forum that helped me figure out that i was running out of video ram with this game;

    i loaded up the original crysis to a saved game state that i know micro stutters. the original crysis plays better than crysis warhead at the same settings on my rig. they said warhead was better oprimized but i found that to not be true at all. anyway, i played crysis on 1920x1200 all high settings. i dropped some settings to low while keeping the critical settings (shaders, shadows, object quality) to high and lo and behold the micro stuttering all but dissapeared. i made sure that i was almost getting a constant 30fps and strafing as normal and there was no microstutter. it played like a single gpu! with all high settings it was 100% assured to have it micro stutter at around 26-40fps. i would guess that all high settings or a combination of settings in the game overloads the video ram.

    i built the desktop rig for comparison. the desktop rig consisted of a 780i motherboard, c2d 1.86 overclocked to 2.3 ghz via FSB and dual 8800GTS 640 cards. the gpu's were also overclocked a little as well. i believe the desktop system experienced a cpu bottleneck in sli mode because switching from high to very high to medium settings did not show much of a difference in fps, but this does not matter. what matters is the micro stutter, and i can honestly say that the desktop cards did not exhibit micro stutter, or if they did it was barely noticable. even though my laptop was crushing the desktop in terms of fps (20fps vs. 35fps at one point in a side by side comparison, for example) the desktop had a smoother gameplay experience because it did not exhibit micro stutter. i believe the 640 megs of video ram on the cards was what it took for the game to play smoothly while the 512 megs of ram on the laptop gpu's were insuficiant for playing crysis on all high or all very high settings.
     
  4. magickraut

    magickraut Notebook Enthusiast

    Reputations:
    0
    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    5
    I get a micro stutter in Crysis every 5 seconds on my laptop. I'm fairly sure this is due a battery/wireless check the game does every 5 seconds, where it calls a dll called IntelLaptopGaming.dll
    I haven't found a way to disable this check though :(
     
  5. Ovreagr

    Ovreagr Notebook Consultant

    Reputations:
    70
    Messages:
    250
    Likes Received:
    0
    Trophy Points:
    30
    I would be interested to hear if that turns out to be the actual culprit and if so, how it can be fixed! Keep us posted!!

    :p
     
  6. LaptopNut

    LaptopNut Notebook Virtuoso

    Reputations:
    1,603
    Messages:
    3,700
    Likes Received:
    54
    Trophy Points:
    116
    Crysis is one of the few games that micro stutters on my NP8662 (GTX 260M, 3GB RAM, Q9000), it also stuttered back when I ran a 2.4 Ghz Core2Duo. Otherwise I get about 50+ fps on high at 1680 X 1050. Other demanding games I play have no micro stutter!
     
  7. magickraut

    magickraut Notebook Enthusiast

    Reputations:
    0
    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    5
    I've got a similar rig (np 8662, gtx 260m, 2 gb ddr3, p9600 @2.66ghz) and Crysis is the only game that stutters for me as well.
    Try timing your stutters. I think you'll find that they're always 5-6 seconds apart, even when you're at a menu or staring at the ground. If anybody knows how one might go about disabling the battery/wireless monitor in Crysis, speak up! All I know about it is that it calls IntelLaptopGaming.dll every 5-6 seconds. I've heard of people disabling their wireless and taking their batteries out, and fixing their microstutters.
     
  8. magickraut

    magickraut Notebook Enthusiast

    Reputations:
    0
    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    5
    I just took my battery out/turned off my wifi, and all the stuttering has all but vanished. I get a random tiny stutter every now and then, but I attribute that to my rig (I only get between 20-30 fps normally) Anyway, if your having stuttering on a laptop, try taking out your battery and turning off your wifi, this will at least name Crysis' annoying system monitor as the culprit.
     
  9. LaptopNut

    LaptopNut Notebook Virtuoso

    Reputations:
    1,603
    Messages:
    3,700
    Likes Received:
    54
    Trophy Points:
    116
    I also took out my battery, disabled wifi and plugged into the mains and the stuttering disappeared almost completely. Consider that I was running a defrag of a virtual Vmware disk in the background while playing Crysis and it is obvious that this :mad: IntelLaptopGaming.dll is the main cause of stuttering.

    What a shame that such a ''feature'' has managed to ruin the smoothness and enjoyability of the game flow.

    There must be a solution to this.
     
  10. LaptopNut

    LaptopNut Notebook Virtuoso

    Reputations:
    1,603
    Messages:
    3,700
    Likes Received:
    54
    Trophy Points:
    116
    I contacted Crysis devs about this and surprisingly, I got a response. I have just sent them details about the problem and have also directed them to this thread.
     
Similar Threads: crysis stuttering
Forum Title Date
Sager and Clevo Crysis 3 on NP9370 Mar 2, 2013
Sager and Clevo p370em with 7970m cfx and crysis 3 - 45 - 60 fps , yet seems sloooow Mar 1, 2013
Sager and Clevo Giving away ONE Free Crysis Game (original) to a lucky Sager / Clevo Owner Feb 26, 2013
Sager and Clevo Crysis 3 - Clevo Discussion Feb 16, 2013
Sager and Clevo Anyone have freezes or crashing in Crysis with the 7970M? Jan 2, 2013

Thread Status:
Not open for further replies.

Share This Page