Creative X-Fi Go

Discussion in 'Accessories' started by jrwingate6, Feb 20, 2012.

  1. jrwingate6

    jrwingate6 Notebook Evangelist

    Reputations:
    404
    Joined:
    Sep 29, 2009
    Messages:
    632
    Likes Received:
    2
    Trophy Points:
    31
    I just purchased a Creative X-Fi Go USB sound card to use when gaming. The problem however is that I don't see a gaming setting within any of the provided software. I see the EAX settings but the only options there are ones like Theater and Hall. I guess what I thought this was going to give me was simulated 5.1 surround just like if I wee to purchase a USB gaming headset that uses software to simulate it's surround sound.

    Does anyone else have this and if so, how do you enable the 3D surround or the EAX 5.0 HD surround mode?
     
  2. kent1146

    kent1146 Notebook Virtuoso

    Reputations:
    2,197
    Joined:
    Sep 1, 2007
    Messages:
    3,484
    Likes Received:
    85
    Trophy Points:
    116
    Flash Demo

    1) Go to the Creative Audio Control Panel/
    2) Go to Speakers (tab). Set speakers to "Headphone".
    3) Go to CMSS-3D (tab). Set MacroFX and Elevation to "Auto".
    4) Go into Windows Control Panel --> Sound. Right-click on the Creative X-Fi sound device --> Configure Speakers. Set speakers to 5.1 or 7.1. Run a test.
    5) In all of your games that allow it, be sure your settings are on "5.1 / 7.1" or "Windows Default."

    The point is for the game to output 5.1 / 7.1 sound. The Creative X-Fi USB will intercept that 5-channel / 7-channel sound, and downmix that into 2.0-channel virtual surround sound through its driver software.
     
  3. jrwingate6

    jrwingate6 Notebook Evangelist

    Reputations:
    404
    Joined:
    Sep 29, 2009
    Messages:
    632
    Likes Received:
    2
    Trophy Points:
    31
    Sorry. I'm using Headphones.
     
  4. jrwingate6

    jrwingate6 Notebook Evangelist

    Reputations:
    404
    Joined:
    Sep 29, 2009
    Messages:
    632
    Likes Received:
    2
    Trophy Points:
    31
    Thank you for the reply. When I go into the Creative Audio Control Panel, I do see the speaker tab and I checked the Headphone box but I do not see the CMSS-3D tab. Is that tab supposed to be under the Audio Control Panel as well? Also, when I go into the Windows Sound Panel and try to configure the Creative device, it is only giving me a "Stereo" option.
     
  5. kent1146

    kent1146 Notebook Virtuoso

    Reputations:
    2,197
    Joined:
    Sep 1, 2007
    Messages:
    3,484
    Likes Received:
    85
    Trophy Points:
    116
    I would try uninstalling and re-installing the drivers for your sound card.

    I've checked multiple places, and the specs on the Creative X-Fi Go USB (stick) sound card does support CMSS3D Headphone mode.
     
  6. jrwingate6

    jrwingate6 Notebook Evangelist

    Reputations:
    404
    Joined:
    Sep 29, 2009
    Messages:
    632
    Likes Received:
    2
    Trophy Points:
    31
    I returned this POS today. I found out that this USB sound card does not support CMSS3D anymore. It now uses some THX crap that is useless.
     
Similar Threads: Creative X-Fi
Forum Title Date
Accessories Creative SB X-Fi Surround 5.1 PRO ? Dec 17, 2011
Accessories Creative X-Fi HD USB May 1, 2011
Accessories Roccat Kave + Creative Sound Blaster X-Fi Sep 19, 2010
Accessories Creative X-Fi USB 5.1 Surround Sound Card (Mini Review/Unboxing) Jul 19, 2009
Accessories Problem with a creative X-fi notebook on my dell c-840 May 14, 2009

Share This Page