CPU is always 100% up and computer slow like snail :(

Discussion in 'Microsoft Windows XP and Vista' started by decaPODA, Nov 15, 2014.

Thread Status:
Not open for further replies.
  1. decaPODA

    decaPODA Notebook Evangelist

    Reputations:
    12
    Messages:
    323
    Likes Received:
    0
    Trophy Points:
    30
    for a while my computer has been acting very slow and performing at really frustrating rate. My Avast and Malwarebytes shows no infection, while chrome add-ons protects from any harmful sites. Task manager shows 90-100% CPU usages and 2.5+gb RAM all the time. This is when I have nothing running on my pc. Juts a task manager open.

    Can not figure out any solution. would appreciate if I get any help from you folks :)
     
  2. sasuke256

    sasuke256 Notebook Deity

    Reputations:
    495
    Messages:
    1,439
    Likes Received:
    446
    Trophy Points:
    101
    what process uses that amount of cpu time :eek: ?
     
  3. John Ratsey

    John Ratsey Moderately inquisitive Super Moderator

    Reputations:
    6,819
    Messages:
    28,612
    Likes Received:
    1,583
    Trophy Points:
    581
    Remember to click on the Show processes from all users button on Task Manager's Processes page then click on the CPU column heading to sort by CPU usage.

    You can right click on a process to get options such as Open file location. This can help you identify what the process belongs to if the description in Task Manager doesn't give a good enough clue.

    (This advice is based on Windows 7 and not all the features may be there in older version of Windows in which case try running Process Explorer.)

    John
     
  4. Primes

    Primes Chrome OS Wizard

    Reputations:
    584
    Messages:
    1,470
    Likes Received:
    360
    Trophy Points:
    101
    Malwarebytes is good but may not be enough. I recommend using these programs in addition to Malwarebytes:

    Combofix
    ADWcleaner
    Rkill

    get them from here: Windows Downloads
     
Loading...
Thread Status:
Not open for further replies.

Share This Page