Connection issues...MSI GT75 TITAN

Discussion in 'MSI' started by Ginerashon, Jul 25, 2019.

  1. Ginerashon

    Ginerashon Notebook Enthusiast

    Reputations:
    15
    Messages:
    37
    Likes Received:
    32
    Trophy Points:
    26
    Hello all,

    Just to start I'm currently running the following drivers.

    Aquantia Aqtion 10gb: 2.1.5.0

    Killer wireless: 12.0.0.722

    The connection on my laptop is significantly worse I feel than my Desktop. Whether there is something sketch on the laptop, I'm not sure. But I feel like sites load a bit slower, and definitely if I use my laptop to stream with Plex to a TV in the house, it buffers like crazy. I never had this experience with my Desktop.

    Also when gaming for example: If I were to play league of legends, sometimes during the game whilst I have an endless ping to google running. I will get time outs....Very weird. Although I think I've seen this without playing games. ---I think it's a lot worse wired vs wireless in that regard.

    I did change my DNS to the google dns as well to see if that would help. Any better ways to check my connection speed ? (Should be 300 down.) More than often I sit 300-350 on the Desktop.

    Running speed tests I do fairly well, http://speedtest.xfinity.com/ I get 300+ on the laptop. But I know speedtests aren't everything and wouldn't explain the timeouts as connections can be fine for a bit and then randomly drop for a few seconds.

    Any suggestions on running trace routes to potentially find an issue? Or any other thoughts that may help will be greatly appreciated.
     
  2. Falkentyne

    Falkentyne Notebook Prophet

    Reputations:
    7,147
    Messages:
    5,428
    Likes Received:
    7,513
    Trophy Points:
    681
    Are you talking about wifi or wired connections. They act differently and may cause different problems. You didn't specify.
    If it's wireless you can try ditching the Killer suite completely and only use the basic drivers, if windows built in drivers works, you can use that. If not, only use the killer basic drivers.
    Don't know about the Aquantia.
    Or you can just buy an Intel AX200 from Amazon and ditch the killer card completely.
     
  3. Ginerashon

    Ginerashon Notebook Enthusiast

    Reputations:
    15
    Messages:
    37
    Likes Received:
    32
    Trophy Points:
    26
    Just wanted to confirm again. Definitely something funky with this laptop. The speed is at 30MB ethernet plugged in on laptop, same test on desktop is 300MB +

    Any ideas? I've updated all drivers that I can think of
     
  4. Kevin@GenTechPC

    Kevin@GenTechPC Company Representative

    Reputations:
    954
    Messages:
    8,086
    Likes Received:
    1,979
    Trophy Points:
    331
    Can you show your network connection screenshot from the task manager while running the benchmark? See below.
    upload_2019-8-6_19-52-29.png
     

    Attached Files:

  5. Ginerashon

    Ginerashon Notebook Enthusiast

    Reputations:
    15
    Messages:
    37
    Likes Received:
    32
    Trophy Points:
    26
    Hello Kevin,

    Hope you're doing well. I think I may have fixed the issue the other night with a different driver/reboot/reconnect combo. Here is the file though in case I'm wrong. Was using...
    testmy.net Download test
     

    Attached Files:

    Kevin@GenTechPC likes this.
  6. Kevin@GenTechPC

    Kevin@GenTechPC Company Representative

    Reputations:
    954
    Messages:
    8,086
    Likes Received:
    1,979
    Trophy Points:
    331
    Very nice. :)
     
Loading...

Share This Page