Clevo/Prema 980m installed but Internal screen not working

Discussion in 'Alienware M15x' started by LodestarRising, Apr 27, 2018.

  1. LodestarRising

    LodestarRising Notebook Enthusiast

    Reputations:
    0
    Messages:
    42
    Likes Received:
    5
    Trophy Points:
    16
    I just got a Clevo 980m with the Prema vbios and it is awesome but my internal screen no longer works and I have to use an external display, Has anyone overcome this?
     
  2. Danishblunt

    Danishblunt Notebook Prophet

    Reputations:
    592
    Messages:
    4,033
    Likes Received:
    1,611
    Trophy Points:
    231
  3. Raidriar

    Raidriar ლ(ಠ益ಠლ)

    Reputations:
    1,269
    Messages:
    4,990
    Likes Received:
    3,282
    Trophy Points:
    331
    Probably bought a gsync card
     
  4. LodestarRising

    LodestarRising Notebook Enthusiast

    Reputations:
    0
    Messages:
    42
    Likes Received:
    5
    Trophy Points:
    16
    It was taken out of a P750ZM (Non-GSYNC) and it outputs on a 1440p dp non gsync screen

    I am trying to replace the prema vbios with the svl7 vbios but it says "This program cannot be run in DOS mode"?
     
  5. Raidriar

    Raidriar ლ(ಠ益ಠლ)

    Reputations:
    1,269
    Messages:
    4,990
    Likes Received:
    3,282
    Trophy Points:
    331
    I've yet to find maxwell NVflash dos version. I just flash through windows. Since you can use external display this shouldn't be a problem for you. Try a standard Clevo 13d7 vBIOS and if that doesn't work there is something else going on. If your device ID is 1617 you are out of luck.
     
  6. Danishblunt

    Danishblunt Notebook Prophet

    Reputations:
    592
    Messages:
    4,033
    Likes Received:
    1,611
    Trophy Points:
    231
    Dos NVFLASH doesn't exist anymore, just get a windows version.
     
  7. LodestarRising

    LodestarRising Notebook Enthusiast

    Reputations:
    0
    Messages:
    42
    Likes Received:
    5
    Trophy Points:
    16
    After a bit of messing around I finally got the stock Clevo 13d7 vBIOS working, and the card is a 13d7 However the internal screen is still not working, I will now try to completely rebuild the system with a different motherboard and try the old 460m to isolate the problem.

    Thank you guys for the help with this, Otherwise I would be completely lost! Good to see the community on a 10 year old laptop going strong :p
     
    ole!!! likes this.
  8. Raidriar

    Raidriar ლ(ಠ益ಠლ)

    Reputations:
    1,269
    Messages:
    4,990
    Likes Received:
    3,282
    Trophy Points:
    331
    Then I'm completely lost unless your LCD magiaclly died or wasn't plugged in right. I've run the same 13d7 card in my M15x.
     
  9. LodestarRising

    LodestarRising Notebook Enthusiast

    Reputations:
    0
    Messages:
    42
    Likes Received:
    5
    Trophy Points:
    16
    The internal display works on the 460m, so it’s only on the 980m that it doesn’t work, The monitor is overclocked to 120hz through NVIDIA control panel but I don't think that will make a difference upon boot.
     
    Last edited: Apr 28, 2018
  10. Raidriar

    Raidriar ლ(ಠ益ಠლ)

    Reputations:
    1,269
    Messages:
    4,990
    Likes Received:
    3,282
    Trophy Points:
    331
    It shouldn’t because that’s how I have mine set up with the 970M. Something is wonky with your card.
     
Loading...

Share This Page