Clevo P650SG - 3440x1440 @ 100Hz possible?

Discussion in 'Sager and Clevo' started by ipwn3r456, Sep 17, 2020.

  1. ipwn3r456

    ipwn3r456 Notebook Evangelist

    Reputations:
    22
    Messages:
    472
    Likes Received:
    126
    Trophy Points:
    56
    Hey all,

    Does anyone still use the Clevo P650SG (or other brands equivlant)? Just recently got an ultrawide monitor, the AOC Cu34g2x to be exact, a 3440x1440 monitor at 144hz.

    From what I researched, my laptop supports DP 1.2, which should be fine running at 3440x1440 at 100 Hz, not 144 Hz since that will require DP 1.4, which I understand. When I plugged in the monitor from the laptop, the max I can do is 60 Hz. I am using a mini displayport to full sized displayport cable.

    When I tried setting it up at the intel graphics settings, the refresh rate doesn't have 100 Hz option. When I opened up CRU however, the list shows 3440x1440 at 100 Hz as an option. I did the restart option on CRU and restarting the laptop, it doesn't work.

    Does anyone know what might be happening here? Thanks all.
     
  2. Tech Junky

    Tech Junky Notebook Consultant

    Reputations:
    30
    Messages:
    113
    Likes Received:
    30
    Trophy Points:
    41
    Like anything else in this realm it could be the cable or driver causing the issue.

    Doing a fresh install of the drivers could remedy the issue or using the dGPU instead of the Intel iGPU.

    When in doubt change the cable to something spec'd at DP 1.4. It reminds me of USB cables, especially C cables varying in speeds and charging rates based on the cables internals being different due to needs. 1 cable might be able to deliver 8K and 100W but another is just a charging cable that does 25W and 480mbps. Also, the cabling sometimes varies by being active or passive which dramatically change the options for the end devices. HDMI has the same issue depending on where you get them and the specs they support.
     
Loading...

Share This Page