Clevo P650RE Running Ubuntu 16.06 - Stuck NVIDIA GeForce GTX 970M

Discussion in 'Sager and Clevo' started by Tulio Vargas, Aug 8, 2016.

Thread Status:
Not open for further replies.
  1. Tulio Vargas

    Tulio Vargas Newbie

    Reputations:
    0
    Messages:
    6
    Likes Received:
    1
    Trophy Points:
    6
    Hi everyone,

    I'm facing a problem with installing a NVIDIA driver on Ubuntu 16.04. I've been reading whelming of forum and blog, although, nothing help me yet.

    I'm using a Clevo P650RE laptop, which the bellow configuration:

    NVIDIA GeForce GTX 970M 3GB
    Core i7-6700HQ Processor (6M Cache up to 3.50 GHz)
    32GB DDR4 2400MHZ Memory


    After installation of Ubuntu 16.04, a popup is showed with the follow message: "Installation is complete, You need to restart the computer in order to use the new installation"

    Thus, I click on the button "Restart Now", then the laptop get stuck and I'm obligated to hold the button power and force the restart.

    When I get the Login Screen and type my password then the Ubuntu gets stuck,then once again I have to hold the power button.

    I saw the bellow procedure:

    To start Ubuntu into safe mode (Recovery Mode) and remove the NVIDIA driver type at terminal:

    $ apt-get remove --purge nvidia*

    After it, I could pass the login screen and I got able to use some application such as Firefox, however, when I click on System Settings, then the Ubuntu stuck again and the only way I have is holding the power bottom.

    I tried to install the NVIDIA driver (NVIDIA-Linux-x86_64-367.35.run):
    LINUX X64 (AMD64/EM64T) DISPLAY DRIVER
    Version: 367.35
    Release Date: 2016.7.15
    Operating System: Linux 64-bit
    Language: English (US)
    File Size: 72.1 MB


    Unfortunately, it doesn't work as well.

    Does someone has an idea for this issue?

    Thank you in advanced.
     
  2. Stooj

    Stooj Notebook Deity

    Reputations:
    177
    Messages:
    821
    Likes Received:
    654
    Trophy Points:
    106
    Are you running in Hybrid or dGPU mode?

    Either way, I recommend installing the Xorg Driver Team PPA from here: https://launchpad.net/~graphics-drivers/+archive/ubuntu/ppa
    You'll also want to remove nouveau

    Commands are:
    sudo add-apt-repository ppa:graphics-drivers/ppa
    sudo apt-get update
    sudo apt-get purge xserver-xorg-video-nouveau-lts-vivid
    sudo apt-get install nvidia-settings nvidia-prime nvidia-prime-applet nvidia-367

    If you're in Hybrid mode you'll be able to use the Prime applet to swap GPUs. If in dGPU mode it'll just work standalone.

    You'll likely have to change your grub settings as well to "nosplash".
    Edit (as root) /etc/default/grub and modify the following line to:
    GRUB_CMDLINE_LINUX_DEFAULT="quiet nosplash"

    EDIT: Just forgot, after modifying the grub file make sure you run "sudo update-grub"
     
    Last edited: Aug 9, 2016
  3. Tulio Vargas

    Tulio Vargas Newbie

    Reputations:
    0
    Messages:
    6
    Likes Received:
    1
    Trophy Points:
    6
    Hi @Stooj,

    It's running as MSHYBRID mode.
    The link you shared is broken.

    [​IMG]
     
  4. Stooj

    Stooj Notebook Deity

    Reputations:
    177
    Messages:
    821
    Likes Received:
    654
    Trophy Points:
    106
    Not here..

    Besides, you can just use the commands to install the PPA anyway. That link is just the launchpad url.
     
    i_pk_pjers_i likes this.
  5. Tulio Vargas

    Tulio Vargas Newbie

    Reputations:
    0
    Messages:
    6
    Likes Received:
    1
    Trophy Points:
    6
    Thank you so much @Stooj.

    I did the configuration and now it's working very well.

    Cheers
     
    i_pk_pjers_i likes this.
  6. kbraun12

    kbraun12 Newbie

    Reputations:
    0
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    5
    I have a similar computer setup, and am having a similar problem. However, I am using debian (stretch). Is there a way that I can make this solution work?
    Thanks in advance.
     
  7. vova88

    vova88 Newbie

    Reputations:
    0
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    5
  8. Meaker@Sager

    Meaker@Sager Company Representative

    Reputations:
    8,238
    Messages:
    52,055
    Likes Received:
    14,884
    Trophy Points:
    931
    Running in discrete mode switches off optimus which does tend to help Linux.
     
  9. tonybeckett1950

    tonybeckett1950 Newbie

    Reputations:
    0
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    5
    I had exactly the same problem. The only way that I could run was by putting nomodeset in the grub loader.

    After reading this thread, I set the BIOS to discrete mode, and now everything runs great. I didn't need to do any of the steps suggested by stooj.
     
  10. Meaker@Sager

    Meaker@Sager Company Representative

    Reputations:
    8,238
    Messages:
    52,055
    Likes Received:
    14,884
    Trophy Points:
    931
    The IGP is disabled in that mode so no optimus to worry about driver wise.
     
Loading...
Thread Status:
Not open for further replies.

Share This Page