Clevo P650HP6 webcam hardware issues

Discussion in 'Sager and Clevo' started by Legoboy0215, Oct 10, 2017.

  1. Legoboy0215

    Legoboy0215 Notebook Enthusiast

    Reputations:
    10
    Messages:
    28
    Likes Received:
    15
    Trophy Points:
    6
    Hello! I have been using my P650HP6 purchased from HIDevolution for about 5 months. However, recently I have been trying to use my webcam, which did not work for some reason (it previously did). I did some research and went on Device Manager, which showed this (I even had to turn on the show Hidden Devices option in View):
    upload_2017-10-10_20-46-48.png

    Is this really a hardware problem, or is it a driver problem? If it is a driver problem, where would I get the proper drivers for my webcam?

    Thanks!
     
  2. gunemalli

    gunemalli Notebook Guru

    Reputations:
    5
    Messages:
    53
    Likes Received:
    3
    Trophy Points:
    16
    Check if you've disabled the Webcam from the Clevo Control Center application.

    Sent from my SM-G930F using Tapatalk
     
    Legoboy0215 likes this.
  3. Meaker@Sager

    Meaker@Sager Company Representative

    Reputations:
    6,975
    Messages:
    43,439
    Likes Received:
    10,864
    Trophy Points:
    931
    Also check you have toggled the FN + F10 combo to on.
     
    Legoboy0215 likes this.
  4. Legoboy0215

    Legoboy0215 Notebook Enthusiast

    Reputations:
    10
    Messages:
    28
    Likes Received:
    15
    Trophy Points:
    6
    I feel dumb now. How did I not see that camera icon :p

    Thanks a lot!
     
  5. Meaker@Sager

    Meaker@Sager Company Representative

    Reputations:
    6,975
    Messages:
    43,439
    Likes Received:
    10,864
    Trophy Points:
    931
    Like I say every time, you are not the first and wont be the last ;)
     
Loading...

Share This Page