CLEVO Drivers Update Utility by OBSIDIAN-PC

Discussion in 'Sager and Clevo' started by Ultra Male, Feb 13, 2017.

  1. joluke

    joluke Notebook Evangelist

    Reputations:
    83
    Messages:
    689
    Likes Received:
    268
    Trophy Points:
    76
    Totally unrelated to this software but a clean install is always recommended between each major update release.
     
  2. anytimer

    anytimer Notebook Deity

    Reputations:
    176
    Messages:
    1,931
    Likes Received:
    168
    Trophy Points:
    81
    Have you tested it yet? Does it break anything for us Clevo guys? Do we need different drivers? Does the usual clean install method still work (install OS, run Windows Update several times, then install and run Updater)?

    Also, could you give us a suggested list of things to disable in the critical mode list in the DPC Fix thingy?
     
    joluke likes this.
  3. John@OBSIDIAN-PC

    John@OBSIDIAN-PC Company Representative

    Reputations:
    701
    Messages:
    2,205
    Likes Received:
    2,720
    Trophy Points:
    181
    I think i will just remove that option to be honest!
    As i said a lot of times.... it causes really high DPC, not the type of quality i want in my products to be honest.


    Not sure, need to try it first :D


    PS. Updater updated to 2.6.2:
    - Added NH55 & NH70 support
     
    anytimer and joluke like this.
  4. joluke

    joluke Notebook Evangelist

    Reputations:
    83
    Messages:
    689
    Likes Received:
    268
    Trophy Points:
    76
    Have been running it since yesterday and everything is working great! Updated from 1809 to 1903 though. All good so far :)
     
    anytimer likes this.
  5. joluke

    joluke Notebook Evangelist

    Reputations:
    83
    Messages:
    689
    Likes Received:
    268
    Trophy Points:
    76
    Can anyone please explain to me how to tweak the latency fixer? Never understood how these work!

    Thanks in advance
     
    anytimer likes this.
  6. Chastity

    Chastity Company Representative

    Reputations:
    1,201
    Messages:
    6,357
    Likes Received:
    203
    Trophy Points:
    231
    Lost my Wifi Device Control, replaced by DPC Fixer
     
  7. John@OBSIDIAN-PC

    John@OBSIDIAN-PC Company Representative

    Reputations:
    701
    Messages:
    2,205
    Likes Received:
    2,720
    Trophy Points:
    181
    Well at the moment it's not really a "DPC Fixer", it's just the start of it... at the moment its just a list of all your devices, and you can select which devices you want to be disabled when you toggle the "Critical Mode".

    The logic behind this tab is that the less active devices you have the lower your DPC Values usually are, the less "communication" between drivers and devices the better, so create your own list and disable all the hardware that you dont need.
    For example, a critical mode for Gaming would be:
    - If you use Wifi then disable the LAN / If you use LAN then disable the Wifi
    - If you use external mouse then disable the touchpad
    - Disable everything else you dont use during games like, Card Reader, IME, Fingerprint, APCI devices (which only output the battery), etc
    - If you use external LCD and your Audio is going out through the NVIDIA HDMI Out then you can disable the Realtek Audio.
    And so on...

    Got it? Basically create your own Critical Mode where only the needed hardware will be enabled.

    Yes, in reality the Disable Wifi was never actually a "Disable Wifi", it was a Airplane mode toggle.
    This ALWAYS needs to be done by the BIOS, which was what i was doing. Disabling the WIFI adapter in most cases is NOT airplane mode, the BIOS needs to disable communications and antennas.
    Since all models have the Airplane shortcut in the Keyboard (which actually works) thats a better solution then the one i was using.
    It was getting really hard to keep compatibility with all the models, so i just removed it since it was a waste of space.
     
    joluke and anytimer like this.
  8. acekard

    acekard Notebook Enthusiast

    Reputations:
    0
    Messages:
    38
    Likes Received:
    2
    Trophy Points:
    16
    Well I had 0 issues with auto-dimming before the update.
     
  9. Zomeguy

    Zomeguy Newbie

    Reputations:
    0
    Messages:
    6
    Likes Received:
    3
    Trophy Points:
    6
    Hello @John@OBSIDIAN-PC,

    I have been installing my new PA71ES-G during the last days, including your software tools that I bought the weekend and I am encountering the following issues:

    I am running Windows 10 on a limited standard account with full UAC active. ClevoService.exe is starting fine.

    - Control Station (1.3.5) does not start with Windows (I have all checkboxes set in the Settings in all the tools). The Scheduled Task is there and set up correctly, but I get the error 0x800702E4 "The requested operation requires elevation." on startup. Needless to say that this is my biggest problem.

    - When the PC comes back from sleep or when the screen was dim, I have to enable (double click) Control Center from the tray for the brightness to work correctly again (including hotkeys). I have the "brightness fix" checkbox selected.

    - Fan Control (2.4.0) does not start with Windows. I checked the registry and the "Run" key entry is on the elevated admin user (when clicking the checkbox the app asks for elevation), but not on the standard user that I am actually using. I added the registry key manually and now it starts.

    - Updater (2.6.2), "Storage" tab reports "Intel Rapid Storage" as "None Detected" although it is installed. Installing again does not change the status.

    Thank you very much.

    Edit: Forgot to mention that I do not have the Clevo tools installed.
     
  10. John@OBSIDIAN-PC

    John@OBSIDIAN-PC Company Representative

    Reputations:
    701
    Messages:
    2,205
    Likes Received:
    2,720
    Trophy Points:
    181
    Something is really weird with your system.
    On a fresh windows install it should start out of the box.
    Did you install any AV software?
    Did you use the latest installer packages (in my signature)?
     
Loading...

Share This Page