CLEVO Drivers Update Utility by OBSIDIAN-PC

Discussion in 'Sager and Clevo' started by Spartan, Feb 13, 2017.

  1. anytimer

    anytimer Notebook Virtuoso

    Reputations:
    201
    Messages:
    2,021
    Likes Received:
    188
    Trophy Points:
    81
    Hmm... does Fan Control get a callback from the EC that it has processed the request to hand control back to the EC? Something might have been getting lost there. I noticed the noise from the GPU fan several minutes after going back to EC Automatic setting, and then I tested multiple times - the fault condition was repeatable - waited for 5 minutes each time and still the fan speed would be stuck at high. Not only that, when I exited Fan Control, all the fans became silent, and I noticed after some time that the CPU temperature had gone up to 62C and the area to the left of the touchpad was also warmer than normal.

    EDIT: it is stuck again. It seems to be the same issue as the brightness thing I reported a few weeks ago - this is happening after waking the display after it has gone black after idle timeout. Worked fine immediately after a fresh start.

    Let me reboot and check again.

    Now it is not recovering, tried after a restart and again after a full shutdown and start. GPU fan speed remains high until I launch some application that actually uses the GPU.

    If you'd like to build a debug version that shows the current fan speed instead of simply Automatic, that could clear things up.
     
    Last edited: May 2, 2019
  2. John@OBSIDIAN-PC

    John@OBSIDIAN-PC Company Representative

    Reputations:
    742
    Messages:
    2,255
    Likes Received:
    2,823
    Trophy Points:
    181
    Nop no call back, but it´s almost impossible for the Auto Fan Duty to fail, never seen it happen. Once it goes out the EC is taking over...

    Try this:

    - CTR+ALT+DELETE
    - Go to Service Tab
    - Stop "ClevoService" -> Don´t close the window yet
    - Get his one: https://johnkeelnas.com/files/BETAS/ClevoService.zip
    - Extract it
    - Use that one to replace the one at C:\Program Files\FanControl\monitor\ClevoService.exe
    - Start ClevoService again

    Let me know if you like that behavior better.
     
    anytimer likes this.
  3. John@OBSIDIAN-PC

    John@OBSIDIAN-PC Company Representative

    Reputations:
    742
    Messages:
    2,255
    Likes Received:
    2,823
    Trophy Points:
    181
    Control Station updated to 1.3.2
    Anyone with apps that are not starting with Windows please go to > Settings Tab > "Make sure suite apps are started on boot"
    That should solve your problem (PS. it will only start apps which have the "Start with Windows options checked")
    Other small changes have been made here and there....
     
  4. anytimer

    anytimer Notebook Virtuoso

    Reputations:
    201
    Messages:
    2,021
    Likes Received:
    188
    Trophy Points:
    81
    Awesome! Yes, this works for me. TYVM.

    Fan Control 2.3.7 with beta ClevoService EC Automatic and Max speed working as expected for unlicensed user.

    Also, the brightness issue is fixed with Control Station 1.3.2 The brightness now properly dims just before it goes to black, with the brightness slider in the Control Station tracking it in real time. On waking, 100% brightness momentarily, then it reverts to the earlier setting. Perfect.
    EDIT: No, happened only once. Now back to 100% brightness on waking - have to click the slider to reapply fix.

    Today is a good day for me. Thanks again.
     
    Last edited: May 2, 2019
    John@OBSIDIAN-PC likes this.
  5. John@OBSIDIAN-PC

    John@OBSIDIAN-PC Company Representative

    Reputations:
    742
    Messages:
    2,255
    Likes Received:
    2,823
    Trophy Points:
    181
    Nice...
    I´ll add that service to next update.
    -------------------------------------------------------
    PS:
    TO ANYONE THAT NEEDS HELP with anything, either updating BIOS / Configuring Software / Whatever... IF YOUR LAPTOP was not bought from OBSIDIAN-PC, do NOT use the online chat or emails, please everyone, we can´t be flooded with requests from non-clients, just PM me and i will try to help as soon as i can!!!
    80% of our contacts are users requesting help when they did not buy the laptop from us, this is making our support life really hard!
    So NON-OBSIDIAN laptops -> PM me, do not use chat or email! If you bought software then you can email or use the chat if it´s 100% related to the software, nothing else!!
     
    FTW_260, anytimer and sicily428 like this.
  6. bk109

    bk109 Notebook Guru

    Reputations:
    1
    Messages:
    66
    Likes Received:
    9
    Trophy Points:
    16
    Anyone else experiencing a weird fan behaviour in the P650HS-G after the latest fan controller updates at idle loads and low temps? I've noticed that after the latest update to the fan control, the fallback to EC Automatic profile doesn't seem to work anymore, but to make this even more fun - even after restarting the system (including hard reset with the fan controller disabled), Automatic mode fails as soon as the system hits ~43C and even when manually selected (via the fallback Fn+1 key combo), the system fans go out completely and stay that way until the system heats up all the way to 85C when the fans kick in at full blast?

    Edit: Yeah, nuking the whole suite and recovering from backup fixed things, so... perhaps the clevo service was acting up? By the way, perhaps it will be possible eventually get a roll-back to a previous version (or better yet, to a designated known good configuration) feature?
     
    Last edited: May 2, 2019
  7. John@OBSIDIAN-PC

    John@OBSIDIAN-PC Company Representative

    Reputations:
    742
    Messages:
    2,255
    Likes Received:
    2,823
    Trophy Points:
    181
    Please update to the latest version.
    We made some changes to how the fans transition to Automatic.
     
  8. John@OBSIDIAN-PC

    John@OBSIDIAN-PC Company Representative

    Reputations:
    742
    Messages:
    2,255
    Likes Received:
    2,823
    Trophy Points:
    181
    UPDATER updated to 2.5.6

    - The Updater Software now includes a new function which i can enable or disable according to each driver to UNINSTALL a device and then re-scan hardware before installing the new driver.
    This seems to be needed in cases like installing the new Intel VGA DCH driver.

    This is still new, seems to be working fine and i might add this function to other drivers when needed (it´s a nice gun to have in the arsenal).
    Please try updating the Intel VGA and tell me if it works. (not sure if that´s the only thing needed for all models tough).

    - The Intel Chipset driver is more then it meets the eye, our package now includes:
    Intel Chipset
    Intel MEI
    Intel ANX
    Intel DPTF
    Intel I/O
    (Don´t worry drivers that are not needed in your system DO NOT get installed)

    - There is now a new ACPI driver showing up on some models, this is a modded driver that identifies the two ACPI devices that newer models use (these devices are used by Clevo Control Center only), so for those of you who do not use CCC this device clears up the two unkown devices from device manager without having to install CCC.
     
    TheChosen0ne likes this.
  9. bk109

    bk109 Notebook Guru

    Reputations:
    1
    Messages:
    66
    Likes Received:
    9
    Trophy Points:
    16
    This is the latest version, I tried a reinstall to cover my bases, but it still causes issues (either disabling the fans outright, or keeping their RPMs very low with a really sluggish ramp-up rate).
     
  10. John@OBSIDIAN-PC

    John@OBSIDIAN-PC Company Representative

    Reputations:
    742
    Messages:
    2,255
    Likes Received:
    2,823
    Trophy Points:
    181
    OK do this....

    - Update to 2.3.9

    Now whats really at steak here is: "When you go from any mode to EC Automatic, or When you exit Fan Control, does the EC take over and Fan Control is doing nothing??"
    Well there is a REALLY EASY way of testing this....

    Switch from Max (or any other mode) to EC Automatic.... now press FN+1, it will put the fans at max.... wait to see if it gets changed! Why is this a good test? Because if it´s not in Automatic Mode and if indeed Fan Control is doing anything, the second Fan Control does any change to fans the FN+1 (Max Speed) goes away.

    Now do the same after exiting Fan Control.... Exit Fan Control and press FN+1.... does it get changed ?

    If the answer is NO it does not get changed then i´m 101% sure the EC took over and Fan Control is doing ZERO!
     
Loading...

Share This Page