CLEVO Drivers Update Utility by OBSIDIAN-PC

Discussion in 'Sager and Clevo' started by Spartan, Feb 13, 2017.

  1. dm477

    dm477 Notebook Evangelist

    Reputations:
    56
    Messages:
    341
    Likes Received:
    219
    Trophy Points:
    56
    It worked! Many thanks.
     
  2. John@OBSIDIAN-PC

    John@OBSIDIAN-PC Company Representative

    Reputations:
    727
    Messages:
    2,243
    Likes Received:
    2,773
    Trophy Points:
    181
    No problem, there´s no way i can keep the app working 100% unless i get feedback, so thank you.
    Im sorry that it might have caused you any kind of trouble.
     
  3. dm477

    dm477 Notebook Evangelist

    Reputations:
    56
    Messages:
    341
    Likes Received:
    219
    Trophy Points:
    56
    @John@OBSIDIAN-PC please don't apologise. You are providing this rather wonderful utility for free to everyone irrespective of whether they bought their machines from Obsidian or not. I think we should thank you, not the other way round!

    And as far as feedback is concerned, always happy to oblige :D
     
    Last edited: Feb 15, 2017
    Rynaus likes this.
  4. John@OBSIDIAN-PC

    John@OBSIDIAN-PC Company Representative

    Reputations:
    727
    Messages:
    2,243
    Likes Received:
    2,773
    Trophy Points:
    181
    Re-Uploaded Audio and SBX drivers just to be sure, these have to work on the P775DM3.
    When i get to work tomorrow i will try them in my own system.
     
    Dede76, Rynaus and Spartan like this.
  5. saturnotaku

    saturnotaku Notebook Nobel Laureate

    Reputations:
    3,997
    Messages:
    7,362
    Likes Received:
    2,884
    Trophy Points:
    331
    Hi @John@OBSIDIAN-PC

    Neat little utility you made. I found a possible bug. I have the version of Clevo Control Center installed that's appropriate for my system. However, your program is reporting it differently and gives the option to update. And apparently there are a couple instances of the program running even though I only have one window. See the following screenshot, including the system tray:

    [​IMG]
     
  6. Rynaus

    Rynaus Notebook Consultant

    Reputations:
    37
    Messages:
    298
    Likes Received:
    156
    Trophy Points:
    56
    Regarding the SBX app - it was not working for me, even after a reinstall. It gave an error message on start and then closed. Here is how I fixed it.

    Delete the "avatar" folder and start the SBX app, it will re-create the folder and all the .pngs inside it. The problem was that the .png files inside were corrupt.
    C:\Users\{insert your user here}\AppData\Local\Creative\Sound Blaster X-Fi MB5\avatar
     
  7. John@OBSIDIAN-PC

    John@OBSIDIAN-PC Company Representative

    Reputations:
    727
    Messages:
    2,243
    Likes Received:
    2,773
    Trophy Points:
    181
    You are running clevo version with xtu service.
    Force update with the app and it will remove that version and install the modded version without xtu.
    Use throttlestop if you need to undervolt.
     
  8. Rynaus

    Rynaus Notebook Consultant

    Reputations:
    37
    Messages:
    298
    Likes Received:
    156
    Trophy Points:
    56
    I don't know if this is a bug or a feature. I had my LAN devices disabled and the Obsidian app reports that the drivers are not installed.

    Btw, look at the temps at stock settings ;) Blue ones are GPU temps and green one is CPU.

    upload_2017-2-16_0-55-11.png
     
  9. John@OBSIDIAN-PC

    John@OBSIDIAN-PC Company Representative

    Reputations:
    727
    Messages:
    2,243
    Likes Received:
    2,773
    Trophy Points:
    181
    Awesome find.
    I will add a extra step in Next APP update to check if that files exist before installing any SBX version.
    That was valuable feedback, thank you!!!
     
    Dede76 and Rynaus like this.
  10. Dede76

    Dede76 Notebook Enthusiast

    Reputations:
    0
    Messages:
    17
    Likes Received:
    2
    Trophy Points:
    6
    I reinstalled minutes ago the audio driver with the older version from the app and SBX works again :)

    But somehow it says its the recent version .but anyway it works ,thank you again for your fabulous work .

    And big thanks at the forum with tips like undervolting ,cpu delidding and most updated Bios versions.Even my Reseller didn´t have them.My Laptop is finally after 6 months quite and cool and without throttling.
     

    Attached Files:

    Last edited: Feb 15, 2017
Loading...

Share This Page