CLEVO Drivers Update Utility by OBSIDIAN-PC

Discussion in 'Sager and Clevo' started by Spartan, Feb 13, 2017.

  1. CM_11

    CM_11 Notebook Enthusiast

    Reputations:
    2
    Messages:
    48
    Likes Received:
    3
    Trophy Points:
    16
    Noticed that under the CPU Tuner on a system with a 7700HQ, the 1 core setting has gone down to 28. I want to say this was 30 something before, using the recommended button.

    Am I imagining this or is something else possibly going on?

    Also, I'm prompted that there are updates for the Touchpad as well as Soundblaster SBX, and both seem to install successfully, but upon recheck/restart, the same prompt to install is given.
     
  2. mert3232

    mert3232 Newbie

    Reputations:
    0
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    5
    Hey. I'm using Monster notebook which is based on Clevo(like Saber etc.).

    My model is: Abra A5 9.2.2
    My notebook specs are i7 7700HQ, 1050ti, 16gb of ram

    My first question is, can I use this Control Station without any problem? Because I'm using clevo control center v5.0001.1.88 and I dont like it.
    My second question is, which model should I choose to update drivers via the Update Utility? I see that there are only Clevo models. So, which one is equivalent to mine according to my specs?

    Thanks.
     
  3. John@OBSIDIAN-PC

    John@OBSIDIAN-PC Company Representative

    Reputations:
    732
    Messages:
    2,253
    Likes Received:
    2,811
    Trophy Points:
    181
    As for CPU Tuning, sometimes the "recommended" is bellow stock clocks if it´s known to overheat.
    Probably not the case for the 7700HQ so just set the values you want to use and click the "Re-Apply On Start"

    For the SBX thing:
    - Check for Windows updates, make sure your Windows is up to date please, if not install them
    - Open Control Panel / Add Remove Programs and Uninstall everything related to Sound Blaster / Creative
    - Reboot
    - To make sure nothing is blocking our uninstallers you can even disabled any Antivirus software for the next steps
    - Install the SBX driver using the Updater
    - Install Reaktek Audio using the Updater (even if already installed please install it again after installing SBX)
    - Reboot (finish the realktek install and reboot again if needed)
    - Check for Windows updates again, check for Windows Store updates too (it updates Realtek and Connect if needed)


    You can use Control Station... as for the Updater i really dont know what a Abra A5 is, you will need to find out the CLEVO model reference.


    NEW STUFF:


    Fan Control - Remote Monitor for Android:
    [​IMG]

    Only need to finish the UI, code to get values over LAP/Internet is done ;)
    This will be a part-time work :D
     
    ExMM, joluke, bennyg and 2 others like this.
  4. MiSJAH

    MiSJAH Notebook Deity

    Reputations:
    134
    Messages:
    1,336
    Likes Received:
    1,000
    Trophy Points:
    181
    Where's the dl link for the android app?

    Any chance you could add a "Apply NumLock on Start" option to Control Centre?

    Many thanks.
     
    Last edited: Mar 6, 2019
  5. John@OBSIDIAN-PC

    John@OBSIDIAN-PC Company Representative

    Reputations:
    732
    Messages:
    2,253
    Likes Received:
    2,811
    Trophy Points:
    181
    Not released yet.
    Give me some more time.
    Will be on my signature when ready.

    Sent from my MI Note 2 using Tapatalk
     
    ExMM and joluke like this.
  6. MiSJAH

    MiSJAH Notebook Deity

    Reputations:
    134
    Messages:
    1,336
    Likes Received:
    1,000
    Trophy Points:
    181

    Thanks.

    Did you see the edit?
     
  7. John@OBSIDIAN-PC

    John@OBSIDIAN-PC Company Representative

    Reputations:
    732
    Messages:
    2,253
    Likes Received:
    2,811
    Trophy Points:
    181
    Doesn't num lock state survive a reboot, it does on mine. What's your model?

    Sent from my MI Note 2 using Tapatalk
     
  8. djsubtronic

    djsubtronic Notebook Evangelist

    Reputations:
    83
    Messages:
    334
    Likes Received:
    29
    Trophy Points:
    41
    It doesn't on mine - P950HR. In fact its always off when I reboot and there's no BIOS switch for startup state. So annoying.
     
  9. Svargod

    Svargod Newbie

    Reputations:
    0
    Messages:
    7
    Likes Received:
    2
    Trophy Points:
    6
    Hi John@Obsidian-PC,

    I bought a laptop from you guys model P775TM1 in September last year.

    I have a few questions:

    1) I noticed that no matter the setting in Control Center, it simply refuses to start with Windows ( both options are activated/start in Tray/start with Windows). To further clarify I think I found the issue as well. I noticed in CCleaner the other day that the path name has a misspelling: ''ConStrol station'' which might make it not activate the startup command properly. Other applications run fine on system start.

    2) When clicking Recommended settings in Control station for CPU Tuning it sets the Undervolt to -95mV, I was 100% sure it was on -100mV when I first received the laptop. However after one of the updates all of the presets were reset and I was forced to click Recommended settings to apply OC again. I am aware this might not make a huge difference and it depends on the processor, however whatever helps with heat means a lot.

    I have 8600k, Gtx 1070

    3) The infamous SoundBlaster is acting up, sometimes when I turn on the laptop all the settings are recognized, sometimes it tells me there is no Sound Card detected in it's settings. I have read one of the recent posts from you on how to fix it, and haven't tried it yet, but wish to say it is a pain in the a** occasionally.

    4) Please if it will be ever possible again, add the keyboard LED temperature settings again. I know it was causing latency issues, however I found that to be extremely useful.

    Thank you in advance!
     
  10. codral

    codral Notebook Guru

    Reputations:
    0
    Messages:
    53
    Likes Received:
    9
    Trophy Points:
    16
    To the guy above with a 7700hq, i've got a 7700hq in a p950HR and my recommended is 38 for 1 core so you might be bugging out.

    To obsidian:
    Bought the fan control and am absolutely loving it!

    Control Station (unpaid for the moment) i'm having issues with though, any help much appreciated:
    Since installing i've lost brightness control with my hardware keys (uninstalling, reinstalling and going back to control center as well as reinstalling original and new Intel drivers) and also with windows 10 (so hardware related presumably). Problem is present on internal and external monitors, also can't change from Intel control panel. - No longer an issue, for anyone else out there, i fixed it using Vipers post on this thread
    http://forum.notebookreview.com/threads/p150em-brightness-not-changing.700812/

    I'm noticing that the hissing from Audio isn't stopping in high performance mode (i've lost entertainment mode obviously but balance isn't working either) , i've tried the volume sync and headphone fix options but i still get the crackling and popping that used to only happen with Control Center when I was in low power modes (line filter or something presumably), any thoughts? I had some updated drivers, went back to original realtek and Creative ones and still present... Some presets in creative help but that's only because they're dropping the volume.

    Keyboard backlight controls, sound controls and all other Fn keys work i should add.

    Cheers,

    Cod
     
    Last edited: Mar 7, 2019
Loading...

Share This Page