Clevo BIOS Thread

Discussion in 'Sager and Clevo' started by Blacky, Sep 11, 2009.

  1. p0och

    p0och Notebook Enthusiast

    Reputations:
    4
    Messages:
    19
    Likes Received:
    1
    Trophy Points:
    6
    download via ms auto update in RS4
     
  2. codral

    codral Notebook Enthusiast

    Reputations:
    0
    Messages:
    29
    Likes Received:
    2
    Trophy Points:
    6
    I know this is an an old post to bring up but in all the pages here this is the only mention of metabox and Prema... I've got a P950HR (shame there's no specific thread but the P950HP thread has been good) which I absolutely couldn't recommend more and have been reading a fair bit about the Prema BIOS; I want it! Does anyone know if Metabox and @Prema are currently developing?
     
    Last edited: Jun 16, 2018 at 3:51 AM
    anytimer likes this.
  3. anytimer

    anytimer Notebook Deity

    Reputations:
    171
    Messages:
    1,796
    Likes Received:
    140
    Trophy Points:
    81
    Me too. I have a P957HR. Btw. which BIOS and EC versions are you running?
     
  4. codral

    codral Notebook Enthusiast

    Reputations:
    0
    Messages:
    29
    Likes Received:
    2
    Trophy Points:
    6
    Ah, specs wise that looks pretty close to mine, is the chassis different?

    BIOS is 1.05.05TMB and EC is 1.05.06, not sure if they're ancient or what, I got this about 3 or 4 months ago when they started trying to move them to get the new stock of CPU's into em so hopefully they don't drop support straight away, Aus is usually a bit behind with this stuff
     
  5. anytimer

    anytimer Notebook Deity

    Reputations:
    171
    Messages:
    1,796
    Likes Received:
    140
    Trophy Points:
    81
    AFAIK just the lid (lit up logo) and the bottom cover are different. Maybe the touchpad position is different too.
     
  6. Hossbando

    Hossbando Notebook Enthusiast

    Reputations:
    0
    Messages:
    18
    Likes Received:
    1
    Trophy Points:
    6
    I'm running 1.05.01 BIOS/EC on a P650SG, having keyboard buffer issues with the "gaming keys." (Key repeat after release of key). A reflash of the EC fixed everything but the W key. Anyone with experience with this issue?

    Edit:
    Anyone with SVOD or SPI programming experience or is that beyond the scope of this forum?
     
    Last edited: Jun 18, 2018 at 10:52 AM
Loading...

Share This Page