Clevo Bios older models (released in/after 2012)

Discussion in 'Sager and Clevo' started by Blacky, Dec 18, 2013.

  1. Zix

    Zix Notebook Enthusiast

    Reputations:
    5
    Messages:
    45
    Likes Received:
    3
    Trophy Points:
    16
    There is a modified bios that enable gtx9xx detection without driver mods, it's made by Prema for Eurocom and distributed to customers that buy VGA upgrades from their shop (which are pre-flashed with a special vbios).

    The flash procedure is very simple and straightforward (like prema mod v2), that's why I think he should try another boot disk image. :)
     
  2. nesvara

    nesvara Notebook Enthusiast

    Reputations:
    0
    Messages:
    16
    Likes Received:
    0
    Trophy Points:
    5
    You're right that's exactly the reason.
     
  3. nesvara

    nesvara Notebook Enthusiast

    Reputations:
    0
    Messages:
    16
    Likes Received:
    0
    Trophy Points:
    5

    Yes, the latest Eurocom BIOS, should be able to detect the 970M, or at least I could boot OS (as it the case when prema_mod installed). But now with my actual BIOS, I am not able to boot OS and to install any other bios.
     
  4. Blacky

    Blacky Notebook Prophet

    Reputations:
    1,681
    Messages:
    4,410
    Likes Received:
    562
    Trophy Points:
    181
    Yeah, I think in your case you definitely need to contact Prema. We could help you, but I fear there a chance we could end up bricking your laptop.
     
  5. nesvara

    nesvara Notebook Enthusiast

    Reputations:
    0
    Messages:
    16
    Likes Received:
    0
    Trophy Points:
    5
    The original problem (cursor was blinking in the lower corner) still persists with pure msdos (Rufus) and even with different the Afudos version. Any other idea?
     
  6. Zix

    Zix Notebook Enthusiast

    Reputations:
    5
    Messages:
    45
    Likes Received:
    3
    Trophy Points:
    16
    Is Uefi and Secure boot disabled?
    You could also try another boot media (cdrom)
     
  7. nesvara

    nesvara Notebook Enthusiast

    Reputations:
    0
    Messages:
    16
    Likes Received:
    0
    Trophy Points:
    5
    Yes, UEFI and Secure boot are disabled. Another boot media (cdrom) - same result :-(
     
  8. nesvara

    nesvara Notebook Enthusiast

    Reputations:
    0
    Messages:
    16
    Likes Received:
    0
    Trophy Points:
    5
    Is this behavior due to possible a damaged BIOS chip?
     
  9. Zix

    Zix Notebook Enthusiast

    Reputations:
    5
    Messages:
    45
    Likes Received:
    3
    Trophy Points:
    16
    Maybe something happened during the first flash, in this case you can restore it only with a flash programmer or by replacing it with a new one.
     
  10. Keicchan

    Keicchan Newbie

    Reputations:
    0
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    5
    hello guys, i've a eurocom motherboard on my p170em (dont ask why, long story),
    my current bios informations are:
    Motherboard manufacturer: eurocom
    model: P170EMx
    Bios rev. 1.02.16 (cant find it in this post)
    ec firmware rev: 1.02.12

    i was thinking about changing my 7970m to a geforce 9xxm series but i'm bit confused about what i need to do, i've to change my bios to prema or not? it's normal that i can't find my 1.02.16 bios in the list?.. something change with my eurocom motherboard instead of the original clevo equipped?!

    someone know what happens to Nesvara user, he manage to make his laptop work with eurocom bios and the 970m?

    thanks for help

    Regards
     
Loading...

Share This Page