CF-54, getting GPS to work properly under Windows 10

Discussion in 'Panasonic' started by Ramma2, Sep 13, 2018 at 4:58 PM.

  1. Ramma2

    Ramma2 Notebook Enthusiast

    Reputations:
    3
    Messages:
    10
    Likes Received:
    1
    Trophy Points:
    5
    Trying to put together a Windows 10 image for our CF-54s, and can't for the life of me get the GPS to work properly. I have the gobi driver package installed and Windows recognizes the cell connection but the GPS Comm port doesn't show in device manager.

    Any thoughts?
     
  2. Shawn

    Shawn Crackpot Search Ninja and Options Whore

    Reputations:
    1,462
    Messages:
    7,358
    Likes Received:
    1,348
    Trophy Points:
    331
    Is the gps on the wwan/gobi card or is it a dedicated module?
     
  3. Ramma2

    Ramma2 Notebook Enthusiast

    Reputations:
    3
    Messages:
    10
    Likes Received:
    1
    Trophy Points:
    5
    Part of the wwan/gobi card. Works fine in Windows 7, GPS shows up as an NMEA Comm port and I can use it for location sensing.
     
  4. Shawn

    Shawn Crackpot Search Ninja and Options Whore

    Reputations:
    1,462
    Messages:
    7,358
    Likes Received:
    1,348
    Trophy Points:
    331
    W10 clean install or upgrade from W7?
     
  5. Shawn

    Shawn Crackpot Search Ninja and Options Whore

    Reputations:
    1,462
    Messages:
    7,358
    Likes Received:
    1,348
    Trophy Points:
    331
    Look to enable location sensor
     
  6. SHEEPMAN!

    SHEEPMAN! Freelance

    Reputations:
    836
    Messages:
    2,526
    Likes Received:
    332
    Trophy Points:
    101
    CF-54! Ummm always do a battery pull reset when adding cards.

    Look at keywords ...location, sensor for W10. Help stops here I don't use W10.

    Did you enable the card in the bios? Optional kit configuration on Main page. Use search for keyword toughkit, WWAN You might have to try different numbers. 04, and some others. I'm using 13 on my 54. WWAN is pulled out right now.

    Hey Shawn, I thought of a couple more things since we talked. :)
     
  7. BaRRmaley

    BaRRmaley Notebook Deity

    Reputations:
    182
    Messages:
    1,068
    Likes Received:
    203
    Trophy Points:
    81
    Ok, if you install the same (win7) drivers package for your sierra modem, so we don't have to check for USBCOMP=8 string in Configuration.ini, you just have to install and run Skylight connection manager. It will switch your modem to MBIM mode with ports.
     
    Ramma2 and Shawn like this.
  8. Ramma2

    Ramma2 Notebook Enthusiast

    Reputations:
    3
    Messages:
    10
    Likes Received:
    1
    Trophy Points:
    5
    Hmm I didn't have Skylight installed, I will give that a shot and report back!
     
  9. Ramma2

    Ramma2 Notebook Enthusiast

    Reputations:
    3
    Messages:
    10
    Likes Received:
    1
    Trophy Points:
    5
    Coming back with success! In preparation for installing the Skylight client I re-downloaded both drivers package and Skylight package. When I extracted the driver package I saw there was a Port_install bat file along with the usual Pinstall.bat file. I checked the Port_install file and it was just the executable for the driver package followed with the USBCOMP=8 switch only, not the whole config file. So I ran that bat and sure enough it enabled the GPS comm ports in the Device manager and my app is happy again.

    Thank you for your help!
     
    toughasnails likes this.
Loading...

Share This Page