CF-53S LED Backlight went out.

Discussion in 'Panasonic' started by Psychowolff, May 5, 2018.

  1. Psychowolff

    Psychowolff Notebook Consultant

    Reputations:
    0
    Messages:
    106
    Likes Received:
    13
    Trophy Points:
    31
    I picked up a CF-53S but the LED Back light isnt working. It does boot to the setup screen and you can see it but there is no Backlight. Since it is the LED the chances of them going out is slim, so Im thinking the board maybe?? Anyone have input or experience with this issue or replacing the Lighting? Any help would be appreciated!! Thanks!
     
  2. Shawn

    Shawn Crackpot Search Ninja and Options Whore

    Reputations:
    1,457
    Messages:
    7,267
    Likes Received:
    1,317
    Trophy Points:
    331
    Early 53's are kind of known to have video/backlight issues.
    Touchscreen models seem more prone to problems.
    Sometime you get lucky and the cable is the issue.
    Mine was the motherboard. I parted the whole thing out.
     
  3. Psychowolff

    Psychowolff Notebook Consultant

    Reputations:
    0
    Messages:
    106
    Likes Received:
    13
    Trophy Points:
    31
    Well, thats not what I was hoping to hear! LOL I'll tear into it when I get home and see whats there to see...

    It is the touch screen model and it has the same i5 as my 31W, was hoping it might be a simple fix. Well, Im still hoping that it is.
    Thanks Shawn, hope everything is going well with you!
     
  4. Shawn

    Shawn Crackpot Search Ninja and Options Whore

    Reputations:
    1,457
    Messages:
    7,267
    Likes Received:
    1,317
    Trophy Points:
    331
    day by day for me.

    Keep us posted
     
  5. safn1949

    safn1949 I'm sure I'm on the wrong planet

    Reputations:
    133
    Messages:
    1,062
    Likes Received:
    288
    Trophy Points:
    101
    I hate to agree but...bad motherboard I'm betting. Shawn, either you or Larry had the photos of the burned spot on a 53 motherboard didn't you?

    I seem to remember that, blown fuse I think.
     
  6. Shawn

    Shawn Crackpot Search Ninja and Options Whore

    Reputations:
    1,457
    Messages:
    7,267
    Likes Received:
    1,317
    Trophy Points:
    331
    yes, I have photos somewhere
     
  7. toughasnails

    toughasnails Toughbook Moderator Moderator

    Reputations:
    2,014
    Messages:
    5,886
    Likes Received:
    965
    Trophy Points:
    281
    Did you try connecting it to a flat screen TV to see if it works ?
     
  8. Shawn

    Shawn Crackpot Search Ninja and Options Whore

    Reputations:
    1,457
    Messages:
    7,267
    Likes Received:
    1,317
    Trophy Points:
    331
  9. safn1949

    safn1949 I'm sure I'm on the wrong planet

    Reputations:
    133
    Messages:
    1,062
    Likes Received:
    288
    Trophy Points:
    101
    Ouch.:D

    I tossed one that did the same thing if I remember correctly,after I stripped it of course.
     
  10. Psychowolff

    Psychowolff Notebook Consultant

    Reputations:
    0
    Messages:
    106
    Likes Received:
    13
    Trophy Points:
    31
    I haven't tried to connect it to an external screen yet, I know the screen works as you can see the setup screen if you hold it at the right angle but it doesn't brighten up when you hit the FnF12.

    Those pics make it look like You can't put a penny in place of the Fuse like I do at Home. LOL

    Shawn FYI, My CF31W is running fine with 12GB of memory. Only had the one 8GB card I swiped from my brothers gaming system. Still going to be a while before I can afford a pair of 8G chips for myself, but 8G is plenty anyways.
     
    Shawn likes this.
Loading...

Share This Page