CF-31 Windows 10 Fingerprint Sensor issues

Discussion in 'Panasonic' started by Jarhead PhrogJockey, Feb 3, 2019.

  1. Jarhead PhrogJockey

    Jarhead PhrogJockey Newbie

    Reputations:
    0
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    5
    I have been running 64bit Windows 10 Pro on a CF-31 Mk1 (CF-31ACBGA3M)for nearly a year now with no problems (current build 1809). Everything works fine including the MC7550 and fingerprint scanner (though there was some serious hoop jumping and a rumored chicken sacrifice getting there). So I bought a CF-31 Mk3 (CF-31SBLHB1M) and sold the Mk1 to a friend. Everything works fine except the fingerprint scanner will not work. It shows in device manager and says it's fine but neither windows nor the scanner software can find it!
    Both have the same chip, driver (version 1.7.0.402) and software (Lenovo Thinkvantage 6.0.0 build 8102 for Win 8.1 64bit), The only difference I can find is the location. The Mk1 is at port_#001.Hub_#003 and works fine. The Mk3 is at port_#001.Hub_#004. This doesn't seem to be something I can change. I have changed the windows group settings, uninstalled and reinstalled everything, deleted user accounts, and did a clean reinstall of windows. In short, I've done everything the wags on line suggest with no joy.. I'd sacrifice a chicken but I don't have one around and my dog is in hiding. I'm beginning to think the sensor may be bad but the event log seems to say it's ok, I could sure use some input here.
     
  2. Shawn

    Shawn Crackpot Search Ninja and Options Whore

    Reputations:
    1,473
    Messages:
    7,632
    Likes Received:
    1,452
    Trophy Points:
    331
    Did you try Panasonic software instead of the Lenovo package?
     
  3. toughasnails

    toughasnails Toughbook Moderator Moderator

    Reputations:
    2,790
    Messages:
    5,982
    Likes Received:
    1,166
    Trophy Points:
    331
    Description : WIN7, INTEL CORE I5-3320M 2.60GHZ, VPRO, 13.1" XGA TOUCH, 500GB(7200RPM), 4GB, INTEL WIFI A/B/G/N, TPM, BLUETOOTH, DUAL PASS (UPPER:WWAN/LOWER:SELECTABLE), SMARTCARD, VERIZON 4G LTE, GPS, FINGERPRINT, EMISSIVE BACKLIT KEYBOARD, NO DRIVE, TOUGHBOOK PREFERRED

    What I would do is install W7 and see what happens since when new that's what came with it. W10 is not very friendly when it comes to finger print readers. Did you need to setup a password for the BIOS on the MK1 and MK2 ?
     
    custom90gt and katalin_2003 like this.
  4. mattpayne

    mattpayne Notebook Consultant

    Reputations:
    117
    Messages:
    167
    Likes Received:
    2
    Trophy Points:
    31
    Im not sure if its the same part, but my MK2 CF-31K had some fun and games with its fingerprint scanner - im running on the insider preview builds with this machine....

    early win10 build was fine (with the windows 10 built in drivers) then one of the later builds broke the fingerprint reader - i thought it was a fault with the scanner module. then one of the newer builds, not sure which one, but the one that blurs out the lock screen background - fingerprint scanner works again! I have not seen any issues with the latest insider preview on my 31, so it could be worth joining the program and seeing if that makes a difference...

    another issue - if you are running on a domain, default win10 GPO behaviour is to disable windows hello - so you need to add a GPO to enable biometrics.

    The GPO's, just for reference -
    Computer config - Admin Templates - system/login/ - Turn on Convenience PIN
    Computer config - Admin Templates - Windows Components/Biometrics - allow domain users to Computer config - Admin Templates - Windows Components/Biometrics - log in using biometrics
    Computer config - Admin Templates - Windows Components/Biometrics - allow the use of biometrics
    Computer config - Admin Templates - Windows Components/Biometrics - allow users to log on using biometrics
     
    Last edited: Feb 8, 2019
  5. Psychowolff

    Psychowolff Notebook Consultant

    Reputations:
    0
    Messages:
    109
    Likes Received:
    15
    Trophy Points:
    31
    I have a CF31Q & W that are Both running 'Protector Suite 2011' software for the Scanner chips and haven't had a single issue... I'm also running Win7 Pro 64Bit...
     
    toughasnails likes this.
Loading...

Share This Page