CF-31 Linux

Discussion in 'Panasonic' started by kode-niner, Jan 11, 2019.

  1. kode-niner

    kode-niner Notebook Consultant

    Reputations:
    34
    Messages:
    260
    Likes Received:
    104
    Trophy Points:
    56
    After upgrading to Debian 10 (buster) I ran in to a familiar issue with swapped output devices in the mixer. You know something is funny when every time you turn it on the volume icon shows it is on mute.

    I ran into these sort of pulseaudio shenanigans before so I just had to take the time to figure it out again, and it wasn't high priority for me.

    Edit /usr/share/pulseaudio/alsa-mixer/paths/analog-output-speaker.conf

    Look for these two Element Headphone and Speaker sections and modify them to that they look like this, by adding, editing or removing lines as necessary (requires root or sudo'ing of course) :

    [Element Headphone]
    switch = off
    volume = merge
    override-map.1 = all
    override-map.2 = all-left,all-right

    [Element Speaker]
    required-any = any
    switch = mute
    volume = off
     
    Last edited: Oct 18, 2019
    SHEEPMAN! likes this.
  2. kode-niner

    kode-niner Notebook Consultant

    Reputations:
    34
    Messages:
    260
    Likes Received:
    104
    Trophy Points:
    56
    Recently I had to ditch the Sierra MC7700 and take back the MC7455 I put into the wife's CF-31. My carrier did something to their network and I needed the extra bands to work around it.

    The MC7455 has given me a lot of trouble. I requires a kit config of 0, which is unusual. But what really got me was that I typically run a "powertop --auto-tune" on startup which helps a bit with power consumption. It will auto-suspend USB devices (including WWAN modules) when they're not in use and do a few other minor tweaks which in some cases can translate into 30 minutes of extra battery time. Normally I highly recommend doing so. No problems with the MC7700 but the MC7455 gets a little squirrely when you muck around with its power settings so I had to disable that startup script.

    Doing a few more tests to see how stable it is now that made the changes.
     
    UNCNDL1 likes this.
  3. SHEEPMAN!

    SHEEPMAN! Freelance

    Reputations:
    878
    Messages:
    2,701
    Likes Received:
    518
    Trophy Points:
    131
    [/QUOTE
    Look for these two Element Headphone and Speaker sections and modify them to that they look like this, by adding, editing or removing lines as necessary (requires root or sudo'ing of course) :

    [Element Headphone]
    switch = off
    volume = merge
    override-map.1 = all
    override-map.2 = all-left,all-right

    [Element Speaker]
    required-any = any
    switch = mute
    volume = off[/QUOTE]

    Thanks for this code Kode. :) Worked fine.
     
    kode-niner and UNCNDL1 like this.
  4. kode-niner

    kode-niner Notebook Consultant

    Reputations:
    34
    Messages:
    260
    Likes Received:
    104
    Trophy Points:
    56
    Here's one for the books.

    A few months ago I snagged a CF-31 with a Panasonic dock CF-VEB311. (thanks Morgan)
    Still with Debian buster...
    If you boot your unit with a mouse plugged into the dock, it will NOT work unless you unplug and re-plug it in. You have to pass a kernel parameter...

    Edit as sudo or root with your favourite text editor - vi, nano, pico, leafpad.... etc...

    Code:
    sudo nano /etc/default/grub
    Pass this parameter to GRUB_CMDLINE_LINUX_DEFAULT
    Code:
    usbcore.autosuspend=-1
    My GRUB_CMDLINE_LINUX_DEFAULT presently looks like this but you can ignore most of it since I was just testing and debugging stuff. The good stuff was added to the end:
    Code:
    GRUB_CMDLINE_LINUX_DEFAULT="quiet loglevel=3 rd.systemd.show_status=auto rd.udev.log_priority=3 usbcore.autosuspend=-1"
    As sudo or root - update grub.
    Code:
    sudo update-grub
    Reboot then the mouse will work immediately when the unit powers on while docked with the mouse in one of the dock's USB ports.

    I suspect other USB devices such as keyboards and so-forth might also benefit from this.


    Originally I added this kernel parameter to help with the Sierra WWAN acting all squirrely, then noticed it fixed my USB mouse issue as a side-effect.

    :beer:
     
    Last edited: Nov 19, 2019
    UNCNDL1 likes this.
  5. mklym

    mklym Notebook Evangelist

    Reputations:
    275
    Messages:
    576
    Likes Received:
    107
    Trophy Points:
    56
    Thanks for the information kode.

    I might have to try this on the 52 and see if it helps with the wifi card dropping off every 6 hours or so. All I do when it happens is cycle the wireless switch off and on again.
     
Loading...

Share This Page