CF-31 Linux

Discussion in 'Panasonic' started by kode-niner, Jan 11, 2019.

  1. UNCNDL1

    UNCNDL1 Notebook Deity

    Reputations:
    220
    Messages:
    712
    Likes Received:
    125
    Trophy Points:
    56
    Backing up, I changed (added this in front of quiet)
    GRUB_CMDLINE_LINUX_DEFAULT="i8042.notimeout i8042.nomux quiet splash"
    Exit with control X
    Saved with Y
     

    Attached Files:

  2. SHEEPMAN!

    SHEEPMAN! Freelance

    Reputations:
    868
    Messages:
    2,660
    Likes Received:
    475
    Trophy Points:
    101
    So you got this figured out?
     
  3. kode-niner

    kode-niner Notebook Consultant

    Reputations:
    27
    Messages:
    253
    Likes Received:
    97
    Trophy Points:
    41
    Are you running this from a full install on a hard drive or some form of live USB/CD/DVD?
     
  4. UNCNDL1

    UNCNDL1 Notebook Deity

    Reputations:
    220
    Messages:
    712
    Likes Received:
    125
    Trophy Points:
    56
    Not figured out yet
    Worked previous with Mx16 persistence usb but no joy Mx18 persistence usb
    I don’t want to install this (yet)
    Trying to tweak touchpad and sound first with live usb using persistence


    Sent from my CF-M34
     
  5. UNCNDL1

    UNCNDL1 Notebook Deity

    Reputations:
    220
    Messages:
    712
    Likes Received:
    125
    Trophy Points:
    56
    Just having problem with updating grub after tweaking the system as you describe.
    More information needed on the canonical path of overlay...
    $ sudo update-grub
    /usr/sbin/grub-probe: error: failed to get canonical path of `overlay'.
     
  6. SHEEPMAN!

    SHEEPMAN! Freelance

    Reputations:
    868
    Messages:
    2,660
    Likes Received:
    475
    Trophy Points:
    101
    Could this be because of the LiveUSB?

    Possibly a system in place to protect grub and thus the LiveUSB?

    Try it again using persist_static and save when you are launching the stick. Persist-static saves to the USB as you are using it. Slightly slower because of writing to the stick but you make up for it in shut down speed.

    Catching me is easier with PM.....start a new one if this subject will be long-winded.

    Lefty :D
     
  7. UNCNDL1

    UNCNDL1 Notebook Deity

    Reputations:
    220
    Messages:
    712
    Likes Received:
    125
    Trophy Points:
    56
    [QUOTE="SHEEPMAN!, post: 10932952, member: 319309"]Could this be because of the LiveUSB?
    Possibly a system in place to protect grub and thus the LiveUSB?
    Try it again using persist_static and save when you are launching the stick. Persist-static saves to the USB as you are using it. Slightly slower because of writing to the stick but you make up for it in shut down speed.
    Catching me is easier with PM.....start a new one if this subject will be long-winded.
    Lefty :D[/QUOTE]

    Great idea, will follow through and report back on the 31
     
  8. UNCNDL1

    UNCNDL1 Notebook Deity

    Reputations:
    220
    Messages:
    712
    Likes Received:
    125
    Trophy Points:
    56
    Great idea, will follow through and report back on the 31[/QUOTE]
    Follow up, a tweak that works with a one liner in Terminal and no Grub work needed:
    NEW INFORMATION AND A ONE LINER

    OPEN A TERMINAL
    CUT AND PASTE THIS:
    sudo echo "options psmouse proto=bare" | sudo tee /etc/modprobe.d/psmouse.conf >/dev/null
    REBOOT

    Uggg...Thanks!
    Mouse pad is now working with this one liner thank you very much Sheepman
     
    kode-niner likes this.
  9. kode-niner

    kode-niner Notebook Consultant

    Reputations:
    27
    Messages:
    253
    Likes Received:
    97
    Trophy Points:
    41
    Upgraded Debian to 10.0 (buster) and gpsd stopped working because I had IPv6 disabled. It needs the v6 loopback interface to work and I suspect the systemd service file is running arguments to connect to the socket in parallel to the IPv4 loopback, because gpsd runs fine when you invoke it by hand.

    Instead of mucking around with fixing it, I just re-activated IPv6.

    Edit:
    /lib/systemd/system/gpsd.socket
    Code:
    [Unit]
    Description=GPS (Global Positioning System) Daemon Sockets
    
    [Socket]
    ListenStream=/var/run/gpsd.sock
    ListenStream=[::1]:2947
    ListenStream=127.0.0.1:2947
    SocketMode=0600
    
    [Install]
    WantedBy=sockets.target
    
    Edit 2:
    Woo! Already a dist-upgrade available to 10.1 today.
     
    SHEEPMAN! likes this.
  10. kode-niner

    kode-niner Notebook Consultant

    Reputations:
    27
    Messages:
    253
    Likes Received:
    97
    Trophy Points:
    41
    Fingerprint sensor for authentication in Debian? Why the heck not.

    Install as root or sudo:
    apt-get install fprintd

    For testing, install fprint-demo, run it and enroll your left thumb (five swipes) then verify it.

    Install as root or sudo:
    apt-get install libpam-fprintd

    Run as root or sudo pam-auth-update and check the fingerprint authentication option

    fprintd-enroll -f left-thumb <username>
    (or run fprintd-enroll -f left-thumb without the username to enroll the currently logged in user)
    Swipe your thumb 5 times.

    Logout then log back in to check for results.


    Even works with my slim login manager. To disable because your thumb got amputated, bypass it all by booting in rescue mode (select it from the grub menu) then re-run pam-auth-update and uncheck fingerprint. Otherwise run pam-auth-update anytime. There are ways to shore up security even more by disallowing such an easy way to disable it in PAM but I'm not that paranoid yet. Right now it's just pretty convenient and I can put more robust passwords. If I continue using this, I better stock up on fingerprint sensor plastic covers. :p
     
    Last edited: Sep 7, 2019
    SHEEPMAN! likes this.
Loading...

Share This Page