CF-29 Touchscreen stuck on bottom

Discussion in 'Panasonic' started by Route66, Apr 21, 2009.

Thread Status:
Not open for further replies.
  1. Route66

    Route66 Notebook Enthusiast

    Reputations:
    0
    Messages:
    19
    Likes Received:
    0
    Trophy Points:
    5
    CF-29 EWPNZBM

    Just picked it up the other day, and can't get the touch screen to work correctly. Tried a few different drivers and so far the closest i've got is where i'm stuck right now. Anywhere I click on the screen the cursor shows up just below the bottom toolbar. I can move the mouse side-to-side down there..and no matter where I click on the screen with the touchscreen the cursor shows up below the tool bar. The touchpad works fine though and I can navigate the mouse around no problem. Any ideas?
     
  2. Doobi

    Doobi ToughBook DeityInTraining

    Reputations:
    414
    Messages:
    1,007
    Likes Received:
    1
    Trophy Points:
    56
    Search through the threads here regarding how to check the touchscreen cable connection under the LCD lid. This would be my first suggestion to resolve your issue. If that does not, then please report back here.

    Paul
     
  3. Alex

    Alex Super Moderator

    Reputations:
    4,081
    Messages:
    4,297
    Likes Received:
    6
    Trophy Points:
    106
  4. Toughbook

    Toughbook Drop and Give Me 20!

    Reputations:
    1,247
    Messages:
    7,239
    Likes Received:
    242
    Trophy Points:
    231
    Route66... Was the driver installed correctly? You may also look for crud stuck between the screen and screen bezel. If something is stuck there then it forces the pointer to that area. Do you get NO movement at all? Is the touchscreen enabled in the BIOS? (You wouldn't believe the people on ebay selling touchscreens that aren't!) Then I'd look at the ribbon cable connection for the touchscreen.
     
  5. Route66

    Route66 Notebook Enthusiast

    Reputations:
    0
    Messages:
    19
    Likes Received:
    0
    Trophy Points:
    5
    I played around with it a bit this morning and when I pressed hard on the screen during the calibration it would accept it, so that would lead me to believe it's crud stuck somewhere between the screen/bezel probably right? I tried the toothpick thing but it didnt really help much...
    How do I remove the bezel/check the ribbon cable? I can get the keyboard bezel off and hinge covers off..do i need to remove all 16 screens on the lid to seperate the bezel away or just the screws imbeded in the silver part?

     
  6. Route66

    Route66 Notebook Enthusiast

    Reputations:
    0
    Messages:
    19
    Likes Received:
    0
    Trophy Points:
    5
    ok, another further update. There was a bit of crud on the bottom of the screen..i was able to carefully seperate the lcd from the bezel just a hair enough to wipe it down clean to the black stuff. However, still no luck..i can click on anything on the taskbar area but not any higher with the touchscreen. Anywhere I click on the screen with my finger/stylus it defaults to the bottom area anywhere.
    I've tried all the drivers on robsnetwork with no further success...

    anybody got any ideas? thanks!
     
  7. Psych0Thrasher

    Psych0Thrasher Notebook Evangelist

    Reputations:
    32
    Messages:
    428
    Likes Received:
    0
    Trophy Points:
    30
    I'd like to see if you can figure this out because i have quite a few 29s with the same model number that are doin the same thing, and i've tried just about everything i can find on the forum to figure out what's up with the little suckers but i grow tired of it. so if you do get it i would love to know :)
     
  8. Route66

    Route66 Notebook Enthusiast

    Reputations:
    0
    Messages:
    19
    Likes Received:
    0
    Trophy Points:
    5
    Panasonic toughbook configuration page shows this as:
    ***San Antonio PD ONLY***Pentium M1.3G LV (Centrino), 13.3Transmissive Touch XGA ,512MB,60GB,WLAN802.11b+g, Win XP SP2 , HDD/Battery door with security screws, Backlit keyboard

    so, i dont know what the heck san antonio did to these toughbooks...musta pour'd too much sand into the screens or the heat got to them!
     
  9. Psych0Thrasher

    Psych0Thrasher Notebook Evangelist

    Reputations:
    32
    Messages:
    428
    Likes Received:
    0
    Trophy Points:
    30
    HAHA, which ebay user did you get those from cuz that might have been one of mine. I get all the leftovers from the SAPD
     
  10. marconi

    marconi Notebook Consultant

    Reputations:
    38
    Messages:
    115
    Likes Received:
    0
    Trophy Points:
    30
    Its intresting that some of you get results from the configurator..

    I always get " Selection is not a current or valid model "

    On my main machine, The configurator hasnt worked for over a week since updates came around.

    I got one from Mark as well with this exact same problem.
    It worked ONE time then nothing...
    I cleaned and checked everything, tried reloading drivers , nothing....I gave up. The screens just must be bad.
    But I knew that when I bought it so I'm ok anyhow.

    Chuck
     
Loading...
Thread Status:
Not open for further replies.

Share This Page