CF-29 Linux Trackpad

Discussion in 'Panasonic' started by Hypervisor, Mar 5, 2018.

  1. Hypervisor

    Hypervisor Newbie

    Reputations:
    5
    Messages:
    8
    Likes Received:
    1
    Trophy Points:
    6
    Hello everyone.

    I picked up an almost new CF-29 with a car dock last week for free and I installed antix linux on it side by side with XP however the trackpad is unusable in antix(debian) but it works fine on XP. I tried kali linux, ubuntu, manjaro and a few others. In all of them it's unusable. I've tried changing the settings with dconf editor but no changes help.

    I'm hoping someone else here has gone through this and knows the fix.

    Thank you for any help.

    CF-29HWLGZBM
     
  2. SHEEPMAN!

    SHEEPMAN! Freelance

    Reputations:
    836
    Messages:
    2,554
    Likes Received:
    355
    Trophy Points:
    101
    What does the following have to say?

    Code:
    inxi -F
    Particularly the antiX one.

    Also
    Code:
    dmesg | grep input
    Run the code in terminal, then cut and paste here.

    If the touchpad is verrry slow: (normal)

    xset m 8 1 #look at man xset - this speeds things up per session only if xset is installed

    Your going to end up with a psmouse.conf file eventually.
    sudo nano /etc/modprobe.d/psmouse.conf
    with the following line...no quotes.
    "options psmouse resolution=400"
    [save][reboot]

    EDIT http://forum.notebookreview.com/threads/toughbooks-and-linux.472724/page-9#post-6313797
    # A little history.





    ;
     
    Last edited: Mar 5, 2018
  3. Hypervisor

    Hypervisor Newbie

    Reputations:
    5
    Messages:
    8
    Likes Received:
    1
    Trophy Points:
    6
    System: Host: ANTI-TOUGHBOOK Kernel: 4.10.5-antix.1-486-smp i686 bits: 32
    Desktop: IceWM 1.4.2 Distro: antiX-17_386-full Heather Heyer 24 October 2017
    Machine: Device: laptop System: Matsushita product: CF-29HWLGZBM v: 001 serial: N/A
    Mobo: Matsushita model: CF29-3 v: 001 serial: N/A
    BIOS: Phoenix K.K. v: V3.00L13 date: 05/22/2005
    Battery BATA: charge: 18.3 Wh 25.0% condition: 73.3/73.3 Wh (100%)
    CPU: Single core Intel Pentium M (-UP-) cache: 2048 KB speed: 1400 MHz (max)
    Graphics: Card: Intel 82852/855GM Integrated Graphics Device
    Display Server: X.Org 1.19.2
    drivers: intel (unloaded: modesetting,fbdev,vesa)
    Resolution: 1024x768@60.00hz
    OpenGL: renderer: Mesa DRI Intel 852GM/855GM x86/MMX/SSE2
    version: 1.3 Mesa 13.0.6
    Audio: Card Intel 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) AC'97 Audio Controller
    driver: snd_intel8x0
    Sound: Advanced Linux Sound Architecture v: k4.10.5-antix.1-486-smp
    Network: Card-1: Intel PRO/Wireless 2915ABG [Calexico2] Network Connection
    driver: ipw2200
    IF: eth1 state: up mac: 00:12:f0:60:76:26
    Card-2: Realtek RTL-8100/8101L/8139 PCI Fast Ethernet Adapter
    driver: 8139too
    IF: eth0 state: down mac: 00:0b:97:30:28:52
    Drives: HDD Total Size: 60.0GB (5.1% used)
    ID-1: /dev/sda model: HTS541060G9AT00 size: 60.0GB
    Partition: ID-1: / size: 26G used: 2.9G (12%) fs: ext4 dev: /dev/sda2
    Sensors: System Temperatures: cpu: 60.8C mobo: N/A
    Fan Speeds (in rpm): cpu: N/A
    Info: Processes: 135 Uptime: 13 min Memory: 255.7/1247.5MB
    Client: Shell (bash) inxi: 2.3.40

    [ 1.356127] input: AT Translated Set 2 keyboard as /devices/platform/i8042/serio0/input/input0
    [ 1.927447] input: HID 413c:3010 as /devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1:1.0/0003:413C:3010.0001/input/input3
    [ 1.927850] hid-generic 0003:413C:3010.0001: input,hidraw0: USB HID v1.00 Mouse [HID 413c:3010] on usb-0000:00:1d.0-1/input0
    [ 2.200573] input: LBPS/2 Fujitsu Lifebook Touchpad as /devices/platform/i8042/serio1/input/input4
    [ 2.225345] input: LBPS/2 Fujitsu Lifebook TouchScreen as /devices/platform/i8042/serio1/input/input2
    [ 8.715449] input: Power Button as /devices/LNXSYSTM:00/LNXSYBUS:00/PNP0C0C:00/input/input5
    [ 8.724261] input: Lid Switch as /devices/LNXSYSTM:00/LNXSYBUS:00/PNP0C0D:00/input/input6
    [ 8.732891] input: Power Button as /devices/LNXSYSTM:00/LNXPWRBN:00/input/input7
    [ 8.899609] input: Video Bus as /devices/LNXSYSTM:00/LNXSYBUS:00/PNP0A03:00/LNXVIDEO:00/input/input8
    [ 8.922898] input: Panasonic Laptop Support as /devices/virtual/input/input9
    [ 11.074817] input: PC Speaker as /devices/platform/pcspkr/input/input10
    [ 253.660881] input: HID 413c:3010 as /devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1:1.0/0003:413C:3010.0002/input/input11
    [ 253.714767] hid-generic 0003:413C:3010.0002: input,hidraw0: USB HID v1.00 Mouse [HID 413c:3010] on usb-0000:00:1d.0-1/input0
    [ 827.631160] input: HID 413c:3010 as /devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1:1.0/0003:413C:3010.0003/input/input12
    [ 827.685266] hid-generic 0003:413C:3010.0003: input,hidraw0: USB HID v1.00 Mouse [HID 413c:3010] on usb-0000:00:1d.0-1/input0



    xset has no effect and it is installed.

    I just created the file and I'm going to reboot then read the link you added. I'll edit this post if the conf file worked.
    Edit: conf file change did little to nothing.
    Edit 2: Tried increasing the value. It had little to no effect as well.
     
    Last edited: Mar 6, 2018
  4. SHEEPMAN!

    SHEEPMAN! Freelance

    Reputations:
    836
    Messages:
    2,554
    Likes Received:
    355
    Trophy Points:
    101
    LiveUSB on a CF-29L.

     

    Attached Files:

    UNCNDL1 likes this.
  5. Hypervisor

    Hypervisor Newbie

    Reputations:
    5
    Messages:
    8
    Likes Received:
    1
    Trophy Points:
    6
    I tried it at 400,600,800 and 1000.

    Bringing your finger from the top of the trackpad to the bottom yeilds about 3/4ths of an inch of moment on the screen. At any of the above settings.

    [​IMG]
     
  6. SHEEPMAN!

    SHEEPMAN! Freelance

    Reputations:
    836
    Messages:
    2,554
    Likes Received:
    355
    Trophy Points:
    101
    Are you using option or options?
    option works with proto=bare etc.
    options works in psmouse.conf
    I'm running update and upgrade on Live USB


    Double post as above got "too busy".

    I've noticed before that xset doesn't work on antiX17.....try sudo xset m 8 1 #? This is only temporary. Annnd can I assume your mouse (touchpad) works but is terribly slow?

    Do you have xinput installed?

    I have added it before....although it may be added with update/upgrade.

    Code:
    dmesg | grep PS/2 -i #ignore caps
    I use the # sign to separate code from explanation.

    Code:
    $ dmesg | grep PS/2 -i
    [    1.081404] i8042: PNP: PS/2 Controller [PNP0303:K101,FJC6000:MOU2] at 0x60,0x64 irq 1,12
    [    1.085568] mousedev: PS/2 mouse device common for all mice
    [  127.629335] input: LBPS/2 Fujitsu Lifebook Touchpad as /devices/platform/i8042/serio1/input/input9
    [  127.671990] input: LBPS/2 Fujitsu Lifebook TouchScreen as /devices/platform/i8042/serio1/input/input8
    
     
  7. Hypervisor

    Hypervisor Newbie

    Reputations:
    5
    Messages:
    8
    Likes Received:
    1
    Trophy Points:
    6
    The touchpad works but is too slow to use.
    Xinput is installed.
    xset m 8 1 didn't improve it.

    Admin@ANTI-TOUGHBOOK:~
    $ dmesg | grep PS/2 -i
    [ 1.324381] i8042: PNP: PS/2 Controller [PNP0303:K101,FJC6000:MOU2] at 0x60,0x64 irq 1,12
    [ 1.326578] mousedev: PS/2 mouse device common for all mice
    [ 2.211879] input: LBPS/2 Fujitsu Lifebook Touchpad as /devices/platform/i8042/serio1/input/input3
    [ 2.236773] input: LBPS/2 Fujitsu Lifebook TouchScreen as /devices/platform/i8042/serio1/input/input2
     
  8. SHEEPMAN!

    SHEEPMAN! Freelance

    Reputations:
    836
    Messages:
    2,554
    Likes Received:
    355
    Trophy Points:
    101
    Sorry got side tracked doing update/upgrade on CF29L.

    Are you running from hard drive?
     
  9. Hypervisor

    Hypervisor Newbie

    Reputations:
    5
    Messages:
    8
    Likes Received:
    1
    Trophy Points:
    6
    Yep, It's running as a dual boot setup with Windows XP SP3
     
  10. SHEEPMAN!

    SHEEPMAN! Freelance

    Reputations:
    836
    Messages:
    2,554
    Likes Received:
    355
    Trophy Points:
    101
    Also in man xset there is a "q"
    xset q gives current setting.

    This CF-53 says:
    Pointer Control:
    acceleration: 2/1 threshold: 4

    CF-29 says 8/1 threshold 1.........>>>>>>>>>>I changed the settings in [Control Center][Mouse]....and changed again to 16/1 ,1

    Of course that's apples and oranges. Synaptic v.s. PS/2.

    Re-booting to see if the settings "stuck". Nope...reverted (xset q) to
    2/1 4....So does psmouse set this? Hmmmmmm.
     
Loading...

Share This Page